<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	
<!-- Recent Posts Widget With Thumbnails: inline CSS -->
<style type='text/css'>
.rpwwt-widget ul { list-style: outside none none; margin-left: 0; margin-right: 0; padding-left: 0; padding-right: 0; }
.rpwwt-widget ul li { overflow: hidden; margin: 0 0 1.5em; }
.rpwwt-widget ul li:last-child { margin: 0; }
.rpwwt-widget .screen-reader-text {border: 0; clip: rect(1px, 1px, 1px, 1px); -webkit-clip-path: inset(50%); clip-path: inset(50%); height: 1px; margin: -1px; overflow: hidden; padding: 0; position: absolute !important; width: 1px; word-wrap: normal !important; word-break: normal; }
.rpwwt-widget .screen-reader-text:focus {background-color: #f1f1f1; border-radius: 3px; box-shadow: 0 0 2px 2px rgba(0, 0, 0, 0.6); clip: auto !important; -webkit-clip-path: none; clip-path: none; color: #21759b; display: block; font-size: 0.875rem; font-weight: 700; height: auto; right: 5px; line-height: normal; padding: 15px 23px 14px; text-decoration: none; top: 5px; width: auto; z-index: 100000; }
.rpwwt-widget ul li img { display: inline; float: left; margin: .3em .75em .75em 0; }
#rpwwt-recent-posts-widget-with-thumbnails-3 img { width: 75px; height: 75px; }
</style>
		<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}		</style>
		<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">
	<!-- This site is optimized with the Yoast SEO plugin v19.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How to Install Linux Kernel 6.0 on Debian 11 Bullseye - LinuxCapable</title><link rel="preload" href="https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel.png" as="image" imagesrcset="https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel.png 740w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-300x180.png 300w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-583x350.png 583w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-375x225.png 375w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-238x143.png 238w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-358x215.png 358w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-75x45.png 75w" imagesizes="(max-width: 740px) 100vw, 740px" />
	<meta name="description" content="Learn how to install, and upgrade to Linux Kernel 6.0 on Debian 11 Bullseye desktop or server with complete steps and examples." />
	<link rel="canonical" href="https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How to Install Linux Kernel 6.0 on Debian 11 Bullseye - LinuxCapable" />
	<meta property="og:description" content="Learn how to install, and upgrade to Linux Kernel 6.0 on Debian 11 Bullseye desktop or server with complete steps and examples." />
	<meta property="og:url" content="https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/" />
	<meta property="og:site_name" content="LinuxCapable" />
	<meta property="article:publisher" content="https://www.facebook.com/LinuxCapable/" />
	<meta property="article:author" content="https://www.facebook.com/LinuxCapable/" />
	<meta property="article:published_time" content="2022-11-03T09:06:51+00:00" />
	<meta property="article:modified_time" content="2022-11-03T09:06:54+00:00" />
	<meta property="og:image" content="https://www.linuxcapable.com/wp-content/uploads/2022/02/How-to-install-Latest-Mainline-Kernel-on-Debian-11-Bullseye.png" />
	<meta property="og:image:width" content="2240" />
	<meta property="og:image:height" content="1260" />
	<meta property="og:image:type" content="image/png" />
	<meta name="author" content="Joshua James" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@linuxcapable" />
	<meta name="twitter:site" content="@linuxcapable" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Joshua James" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#article","isPartOf":{"@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/"},"author":{"name":"Joshua James","@id":"https://www.linuxcapable.com/#/schema/person/fb6f23d365565351c36f8fdb525b62f2"},"headline":"How to Install Linux Kernel 6.0 on Debian 11 Bullseye","datePublished":"2022-11-03T09:06:51+00:00","dateModified":"2022-11-03T09:06:54+00:00","mainEntityOfPage":{"@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/"},"wordCount":808,"commentCount":0,"publisher":{"@id":"https://www.linuxcapable.com/#organization"},"image":{"@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#primaryimage"},"thumbnailUrl":"https://www.linuxcapable.com/wp-content/uploads/2022/02/How-to-install-Latest-Mainline-Kernel-on-Debian-11-Bullseye.png","articleSection":["Debian"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#respond"]}]},{"@type":"WebPage","@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/","url":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/","name":"How to Install Linux Kernel 6.0 on Debian 11 Bullseye - LinuxCapable","isPartOf":{"@id":"https://www.linuxcapable.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#primaryimage"},"image":{"@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#primaryimage"},"thumbnailUrl":"https://www.linuxcapable.com/wp-content/uploads/2022/02/How-to-install-Latest-Mainline-Kernel-on-Debian-11-Bullseye.png","datePublished":"2022-11-03T09:06:51+00:00","dateModified":"2022-11-03T09:06:54+00:00","description":"Learn how to install, and upgrade to Linux Kernel 6.0 on Debian 11 Bullseye desktop or server with complete steps and examples.","breadcrumb":{"@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#primaryimage","url":"https://www.linuxcapable.com/wp-content/uploads/2022/02/How-to-install-Latest-Mainline-Kernel-on-Debian-11-Bullseye.png","contentUrl":"https://www.linuxcapable.com/wp-content/uploads/2022/02/How-to-install-Latest-Mainline-Kernel-on-Debian-11-Bullseye.png","width":2240,"height":1260,"caption":"How to install Latest Mainline Kernel on Debian 11 Bullseye"},{"@type":"BreadcrumbList","@id":"https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.linuxcapable.com/"},{"@type":"ListItem","position":2,"name":"Debian","item":"https://www.linuxcapable.com/debian-release/"},{"@type":"ListItem","position":3,"name":"How to Install Linux Kernel 6.0 on Debian 11 Bullseye"}]},{"@type":"WebSite","@id":"https://www.linuxcapable.com/#website","url":"https://www.linuxcapable.com/","name":"LinuxCapable","description":"Your Friendly GNU/Linux Howtos Source","publisher":{"@id":"https://www.linuxcapable.com/#organization"},"alternateName":"LinuxCapable.com","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.linuxcapable.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://www.linuxcapable.com/#organization","name":"LinuxCapable","alternateName":"LinuxCapable.com","url":"https://www.linuxcapable.com/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.linuxcapable.com/#/schema/logo/image/","url":"","contentUrl":"","caption":"LinuxCapable"},"image":{"@id":"https://www.linuxcapable.com/#/schema/logo/image/"},"sameAs":["https://www.reddit.com/r/linuxcapable/","https://www.facebook.com/LinuxCapable/","https://twitter.com/linuxcapable"]},{"@type":"Person","@id":"https://www.linuxcapable.com/#/schema/person/fb6f23d365565351c36f8fdb525b62f2","name":"Joshua James","sameAs":["https://www.linuxcapable.com","https://www.facebook.com/LinuxCapable/","https://twitter.com/linuxcapable"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='stylesheet' id='wp-block-library-css' href='https://www.linuxcapable.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.linuxcapable.com/wp-includes/css/classic-themes.min.css?ver=1' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='mkaz-code-syntax-prism-css-css' href='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism-a11y-dark.css?ver=1656119066' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/themes/default/style.css?ver=7.5' media='all' />
<style id='wpdiscuz-frontend-css-inline-css'>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</style>
<link rel='stylesheet' id='wpdiscuz-fa-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css?ver=7.5' media='all' />
<link rel='stylesheet' id='quill-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.snow.css?ver=1.3.6' media='all' />
<link rel='stylesheet' id='wmu-colorbox-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/colorbox.css?ver=6.1' media='all' />
<link rel='stylesheet' id='wpdiscuz-mu-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-mu-frontend.css?ver=6.1' media='all' />
<link rel='stylesheet' id='wpdiscuz-user-content-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.css?ver=7.5' media='all' />
<link rel='stylesheet' id='ez-toc-css' href='https://www.linuxcapable.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=6.1' media='all' />
<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 700;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container nav ul ul li ul li {font-size: 90%!important;}div#ez-toc-container {width: 100%;}
.ez-toc-container-direction {
    direction: ltr;
}

	.ez-toc-counter ul {
	    counter-reset: item;
	}


	
	.ez-toc-counter nav ul li a::before {
	    content: counters(item, ".", decimal) ". ";
	    display: inline-block;
	    counter-increment: item;
        flex-grow: 0;
        flex-shrink: 0;
	    margin-right: .2em; 

	    float: left;
	}


.ez-toc-widget-direction {
    direction: ltr;
}

	.ez-toc-widget-container ul {
	    counter-reset: item;
	}


	
	.ez-toc-widget-container nav ul li a::before {
	    content: counters(item, ".", decimal) ". ";
	    display: inline-block;
	    counter-increment: item;
        flex-grow: 0;
        flex-shrink: 0;
	    margin-right: .2em; 

	    float: left;
	}


</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=6.0.5' media='all' />
<link rel='stylesheet' id='generate-comments-css' href='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/css/components/comments.min.css?ver=3.2.1' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css' href='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/css/components/widget-areas.min.css?ver=3.2.1' media='all' />
<link rel='stylesheet' id='generate-style-css' href='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/css/main.min.css?ver=3.2.1' media='all' />
<style id='generate-style-inline-css'>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</style>
<link rel='stylesheet' id='heateor_sss_frontend_css-css' href='https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.43' media='all' />
<link rel='stylesheet' id='generate-navigation-branding-css' href='https://www.linuxcapable.com/wp-content/plugins/gp-premium/menu-plus/functions/css/navigation-branding-flex.min.css?ver=2.2.0' media='all' />
<style id='generate-navigation-branding-inline-css'>
@media (max-width: 1024px){.site-header, #site-navigation, #sticky-navigation{display:none !important;opacity:0.0;}#mobile-header{display:block !important;width:100% !important;}#mobile-header .main-nav > ul{display:none;}#mobile-header.toggled .main-nav > ul, #mobile-header .menu-toggle, #mobile-header .mobile-bar-items{display:block;}#mobile-header .main-nav{-ms-flex:0 0 100%;flex:0 0 100%;-webkit-box-ordinal-group:5;-ms-flex-order:4;order:4;}}.main-navigation.has-branding.grid-container .navigation-branding, .main-navigation.has-branding:not(.grid-container) .inside-navigation:not(.grid-container) .navigation-branding{margin-left:10px;}.navigation-branding img, .site-logo.mobile-header-logo img{height:50px;width:auto;}.navigation-branding .main-title{line-height:50px;}@media (max-width: 1210px){#site-navigation .navigation-branding, #sticky-navigation .navigation-branding{margin-left:10px;}}@media (max-width: 1024px){.main-navigation.has-branding.nav-align-center .menu-bar-items, .main-navigation.has-sticky-branding.navigation-stick.nav-align-center .menu-bar-items{margin-left:auto;}.navigation-branding{margin-right:auto;margin-left:10px;}.navigation-branding .main-title, .mobile-header-navigation .site-logo{margin-left:10px;}}
</style>
<script src='https://www.linuxcapable.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script id='wpp-json' type="application/json">
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.linuxcapable.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.linuxcapable.com\/wp-json\/wordpress-popular-posts","ID":21152,"token":"f10840cf44","lang":0,"debug":0}
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=6.0.5' id='wpp-js-js'></script>
            <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
            <script data-cfasync="false">window.nitroAds=window.nitroAds||{createAd:function(){return new Promise(e=>{window.nitroAds.queue.push(["createAd",arguments,e])})},addUserToken:function(){window.nitroAds.queue.push(["addUserToken",arguments])},queue:[]};</script>
<script data-cfasync="false" async src="https://s.nitropay.com/ads-1224.js"></script><link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2022/04/linuxcapable.com-tiny-logo.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2022/04/linuxcapable.com-tiny-logo.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.linuxcapable.com/wp-content/uploads/2022/04/linuxcapable.com-tiny-logo.png" />
<meta name="msapplication-TileImage" content="https://www.linuxcapable.com/wp-content/uploads/2022/04/linuxcapable.com-tiny-logo.png" />
		<style id="wp-custom-css">
			h2.widget-title {
		font-size: 18px;
}

.rpwwt-post-title
{
			font-size: 13px;
		  font-weight: bold;
}

.vertical-center-enabled .page-header-content-wrapper {
    align-items: end;
    justify-content: flex-end;
}

.generate-back-to-top,
.generate-back-to-top:visited {
    bottom: 115px; /* 30px from the bottom of your screen */
}

.page-header h1 {
	font-size: 1.5em;
}

@media(max-width: 768px) {
    .code-block-11 {
        display: none !important;
    }
}

@media(max-width: 768px) {
    .code-block-6 {
        display: none !important;
    }
}


@media(max-width: 768px) {
    .code-block-9 {
        display: none !important;
    }
}

@media(max-width: 768px) {
    .code-block-13 {
        display: none !important;
    }
}

@media(max-width: 728px) {
    #gtranslate_wrapper {
        display: show !important;
        top: 50px !important;
    }
}

@media(max-width: 728px) {
    .ez-toc-open-icon {
        display: show !important;
        top: 200px !important;
    }
}

@media(max-width: 1024px) {
    #ai_widget-50 {
        display: none !important;
    }
}

@media(max-width: 1024px) {
    #ai_widget-51 {
        display: none !important;
    }
}

@media(max-width: 1024px) {
    #ai_widget-52 {
        display: none !important;
    }
}

@media(min-width: 1024px) {
    .code-block-14 {
        display: none !important;
    }
}

@media(min-width: 1024px) {
    .code-block-8 {
        display: none !important;
    }
}

.code-block-label {
			font-size: 10px;
}
pre.wp-block-code code {
    white-space: pre-wrap !important;
}

pre.wp-block-code {
    padding: 1em;
    margin: 20pt auto;
}

h2 {
    line-height: 100%;
	   border-bottom: 2px solid #000; 
    line-height: 1.5em;
		font-size: 20px;
}

h3 {
    line-height: 100%;
	   border-bottom: 1px solid #000; 
    line-height: 1.5em;
		font-size: 17px;

}

.archive .page-header {
    display: none;
}

.post-image-above-header .inside-article .post-image {
    margin-bottom: 0.5em !important;
}

.copy-the-code-wrap .copy-the-code-button {
    background: #4300a2;
    color: #ffffff;
    font-weight: bold;
}

h1.entry-title {
    font-size: 25px;
}

h2.entry-title{
	font-size: 20px;
	font-weight: bold;

}

#breadcrumbs {
	font-size: 13px;
	font-weight: bold;
}

.wplogout-social-fb-header svg {
	position: relative;
	top: 8px;
}

.wplogout-social-tw-header svg {
	position: relative;
	top: 8px;
}

.wplogout-social-reddit-header svg {
	position: relative;
	top: 8px;
}

.wplogout-social-rss-header svg {
	position: relative;
	top: 8px;
}		</style>
		<script async src="https://www.googletagmanager.com/gtag/js?id=G-K88YWP9KF1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-K88YWP9KF1');
</script><script defer src='https://static.cloudflareinsights.com/beacon.min.js' data-cf-beacon='{"token": "28430396410d4ae884ca0c460c8fc3c9"}'></script></head>

<body class="post-template-default single single-post postid-21152 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-no-transition mobile-header mobile-header-logo mobile-header-sticky right-sidebar nav-below-header separate-containers nav-search-enabled header-aligned-center dropdown-hover" >
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<nav id="mobile-header" class="main-navigation mobile-header-navigation has-branding has-sticky-branding has-menu-bar-items">
			<div class="inside-navigation grid-container grid-parent">
				<form method="get" class="search-form navigation-search" action="https://www.linuxcapable.com/">
					<input type="search" class="search-field" value="" name="s" title="Search" />
				</form><div class="navigation-branding"><p class="main-title" itemprop="headline">
							<a href="https://www.linuxcapable.com/" rel="home">
								LinuxCapable
							</a>
						</p></div>					<button class="menu-toggle" aria-controls="mobile-menu" aria-expanded="false">
						<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span>					</button>
					<div id="mobile-menu" class="main-nav"><ul id="menu-primary-marketer" class=" menu sf-menu"><li id="menu-item-42" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42"><a href="https://www.linuxcapable.com/">Home</a></li>
<li id="menu-item-29143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29143"><a href="https://www.linuxcapable.com/commands/">Commands &#038; Tips</a></li>
<li id="menu-item-21310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21310"><a>Arch Linux Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-27166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27166"><a href="https://www.linuxcapable.com/arch-linux-release/">Arch Linux</a></li>
	<li id="menu-item-27180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27180"><a href="https://www.linuxcapable.com/manjaro-release/">Manjaro</a></li>
</ul>
</li>
<li id="menu-item-19049" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19049"><a>Debian Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-29489" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29489"><a href="https://www.linuxcapable.com/debian-release/">Debian</a></li>
	<li id="menu-item-27169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27169"><a href="https://www.linuxcapable.com/lmde-release/">Linux Mint Debian Edition</a></li>
</ul>
</li>
<li id="menu-item-27170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27170"><a href="https://www.linuxcapable.com/fedora-release/">Fedora</a></li>
<li id="menu-item-19048" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19048"><a>RHEL Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-27176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27176"><a href="https://www.linuxcapable.com/almalinux-release/">AlmaLinux</a></li>
	<li id="menu-item-27177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27177"><a href="https://www.linuxcapable.com/centos-stream-release/">CentOS Stream</a></li>
	<li id="menu-item-27178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27178"><a href="https://www.linuxcapable.com/rocky-linux-release/">Rocky Linux</a></li>
</ul>
</li>
<li id="menu-item-16629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16629"><a>Ubuntu Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-27173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27173"><a href="https://www.linuxcapable.com/linux-mint-release/">Linux Mint</a></li>
	<li id="menu-item-27174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27174"><a href="https://www.linuxcapable.com/pop_os-release/">Pop!_OS</a></li>
	<li id="menu-item-27175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27175"><a href="https://www.linuxcapable.com/ubuntu-release/">Ubuntu</a></li>
</ul>
</li>
<li id="menu-item-27171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27171"><a href="https://www.linuxcapable.com/opensuse-release/">openSUSE</a></li>
<li id="menu-item-34097" class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34097"><a target="_blank" rel="nofollow" href="https://www.facebook.com/LinuxCapable/"><a href="https://www.facebook.com/LinuxCapable/" target="_blank" class="wplogout-social-fb-header" rel="noopener"><svg width="23px" height="23px" viewBox="0 0 1024 1024" xmlns="http://www.w3.org/2000/svg">    <circle cx="512" cy="512" r="512" style="fill:#1877f2"/>    <path d="M552 766.4V587.6h59.7l11.4-74h-71v-48c0-20.2 9.9-40 41.7-40H626v-63s-29.3-5-57.3-5c-58.5 0-96.7 35.4-96.7 99.6v56.4h-65v74h65v178.9c-122.4-19.2-216-125.1-216-252.9 0-141.4 114.6-256 256-256s256 114.6 256 256c0 127.7-93.6 233.6-216 252.8z" style="fill:#fff"/> </svg></a></a></li>
<li id="menu-item-34098" class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34098"><a target="_blank" rel="nofollow" href="https://twitter.com/linuxcapable/"><a href="https://twitter.com/linuxcapable/" target="_blank" class="wplogout-social-tw-header" rel="noopener"><svg width="23px" height="23px" viewBox="0 0 1024 1024" xmlns="http://www.w3.org/2000/svg">    <circle cx="512" cy="512" r="512" style="fill:#1da1f2"/>    <path d="M778 354.8c-18.8 8.3-38.9 13.9-60.1 16.5 21.6-13 38.2-33.5 46-57.9-20.2 11.8-42.7 20.4-66.5 25.2-19.1-20.4-46.2-33.2-76.4-33.2-57.8 0-104.7 46.9-104.7 104.6 0 8.3 1 16.3 2.7 23.9-87-4.1-164.2-45.9-215.8-109.1-9.1 15.4-14.2 33.2-14.2 52.7 0 36.4 18.5 68.4 46.6 87.2-17.2-.6-33.3-5.3-47.4-13.1v1.3c0 50.8 36 93.1 84 102.7-8.8 2.4-18.1 3.6-27.6 3.6-6.7 0-13.1-.6-19.5-1.8 13.4 41.6 52 71.9 98 72.7-35.7 28.1-81.1 44.8-129.8 44.8-8.3 0-16.6-.5-24.9-1.4 46.6 29.7 101.5 47 160.8 47C621.7 720.5 727 561 727 422.9c0-4.4 0-8.9-.3-13.4 20.4-14.7 38.3-33.2 52.3-54.2l-1-.5z" style="fill:#fff"/> </svg></a></a></li>
<li id="menu-item-34140" class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34140"><a target="_blank" rel="nofollow" href="https://www.reddit.com/r/linuxcapable/"><a href="https://www.reddit.com/r/linuxcapable/" target="_blank" class="wplogout-social-reddit-header" rel="noopener"><svg width="23px" height="23px" viewBox="0 0 256 256" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" preserveAspectRatio="xMidYMid">     <g>         <circle fill="#FF4500" cx="128" cy="128" r="128"></circle>         <path d="M213.149867,129.220267 C213.149867,118.843733 204.758756,110.603378 194.532978,110.603378 C189.498311,110.603378 184.918756,112.585956 181.562311,115.791644 C168.745244,106.635378 151.195022,100.6848 131.662222,99.9224889 L140.206933,59.9409778 L167.980089,65.8915556 C168.287289,72.9116444 174.084267,78.5578667 181.257956,78.5578667 C188.5824,78.5578667 194.532978,72.6072889 194.532978,65.28 C194.532978,57.9555556 188.5824,52.0049778 181.257956,52.0049778 C176.069689,52.0049778 171.490133,55.0570667 169.353956,59.4830222 L138.377956,52.9208889 C137.462044,52.7672889 136.546133,52.9208889 135.934578,53.3788444 C135.172267,53.8368 134.714311,54.5991111 134.563556,55.5150222 L125.100089,100.073244 C105.262933,100.6848 87.4083556,106.635378 74.4376889,115.945244 C71.0812444,112.739556 66.5016889,110.756978 61.4670222,110.756978 C51.0904889,110.756978 42.8501333,119.148089 42.8501333,129.373867 C42.8501333,137.002667 47.4268444,143.4112 53.8382222,146.312533 C53.5310222,148.141511 53.3802667,149.973333 53.3802667,151.958756 C53.3802667,180.644978 86.7996444,203.995022 128.001422,203.995022 C169.2032,203.995022 202.622578,180.798578 202.622578,151.958756 C202.622578,150.126933 202.468978,148.141511 202.164622,146.312533 C208.573156,143.4112 213.149867,136.849067 213.149867,129.220267 Z M85.2721778,142.495289 C85.2721778,135.170844 91.2227556,129.220267 98.5500444,129.220267 C105.874489,129.220267 111.825067,135.170844 111.825067,142.495289 C111.825067,149.819733 105.874489,155.773156 98.5500444,155.773156 C91.2227556,155.923911 85.2721778,149.819733 85.2721778,142.495289 Z M159.588978,177.746489 C150.432711,186.902756 133.036089,187.514311 128.001422,187.514311 C122.813156,187.514311 105.416533,186.749156 96.4110222,177.746489 C95.04,176.372622 95.04,174.236444 96.4110222,172.862578 C97.7848889,171.491556 99.9210667,171.491556 101.294933,172.862578 C107.094756,178.6624 119.303111,180.644978 128.001422,180.644978 C136.699733,180.644978 149.058844,178.6624 154.705067,172.862578 C156.078933,171.491556 158.215111,171.491556 159.588978,172.862578 C160.809244,174.236444 160.809244,176.372622 159.588978,177.746489 Z M157.1456,155.923911 C149.821156,155.923911 143.870578,149.973333 143.870578,142.648889 C143.870578,135.324444 149.821156,129.373867 157.1456,129.373867 C164.472889,129.373867 170.423467,135.324444 170.423467,142.648889 C170.423467,149.819733 164.472889,155.923911 157.1456,155.923911 Z" fill="#FFFFFF" fill-rule="nonzero"></path>     </g> </svg></a></a></li>
<li id="menu-item-34099" class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34099"><a target="_blank" rel="nofollow" href="https://www.linuxcapable.com/feed/"><a href="https://www.linuxcapable.com/feed/" target="_blank" class="wplogout-social-rss-header" rel="noopener"><svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" 	 width="23px" height="23px"  viewBox="0 0 512 512" style="enable-background:new 0 0 512 512;" xml:space="preserve"> <circle style="fill:#FF9911;" cx="256" cy="256" r="256"/> <path style="fill:#ED8800;" d="M256,0c-11.317,0-22.461,0.744-33.391,2.167C348.216,18.53,445.217,125.933,445.217,256 	s-97.002,237.47-222.609,253.833C233.539,511.256,244.683,512,256,512c141.385,0,256-114.616,256-256S397.385,0,256,0z"/> <g> 	<path style="fill:#FCFCFC;" d="M155.826,401.252c-24.856,0-45.078-20.222-45.078-45.078c0-24.856,20.222-45.078,45.078-45.078 		s45.078,20.222,45.078,45.078C200.904,381.03,180.683,401.252,155.826,401.252z"/> 	<path style="fill:#FCFCFC;" d="M249.878,387.908v-10.041c0-63.924-51.821-115.744-115.744-115.744h-10.041 		c-1.223,0-2.214-0.992-2.214-2.214v-57.902c0-1.223,0.992-2.214,2.214-2.214h10.041c98.349,0,178.075,79.727,178.075,178.075 		v10.041c0,1.223-0.992,2.214-2.214,2.214h-57.902C250.87,390.122,249.878,389.13,249.878,387.908z"/> 	<path style="fill:#FCFCFC;" d="M361.183,387.908v-10.041c0-125.395-101.653-227.049-227.049-227.049h-10.041 		c-1.223,0-2.214-0.992-2.214-2.214V90.701c0-1.223,0.992-2.214,2.214-2.214h12.255c76.705,0,148.818,29.87,203.057,84.108 		c54.239,54.239,84.108,126.352,84.108,203.057v12.256c0,1.223-0.992,2.214-2.214,2.214h-57.902 		C362.174,390.122,361.183,389.13,361.183,387.908z"/> </g> </svg></a></a></li>
</ul></div><div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div>			</div><!-- .inside-navigation -->
		</nav><!-- #site-navigation -->
				<nav class="has-branding main-navigation nav-align-right has-menu-bar-items sub-menu-right" id="site-navigation" aria-label="Primary">
			<div class="inside-navigation grid-container">
				<div class="navigation-branding"><p class="main-title" itemprop="headline">
					<a href="https://www.linuxcapable.com/" rel="home">
						LinuxCapable
					</a>
				</p></div><form method="get" class="search-form navigation-search" action="https://www.linuxcapable.com/">
					<input type="search" class="search-field" value="" name="s" title="Search" />
				</form>				<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-primary-marketer-1" class=" menu sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42"><a href="https://www.linuxcapable.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29143"><a href="https://www.linuxcapable.com/commands/">Commands &#038; Tips</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-21310"><a>Arch Linux Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27166"><a href="https://www.linuxcapable.com/arch-linux-release/">Arch Linux</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27180"><a href="https://www.linuxcapable.com/manjaro-release/">Manjaro</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19049"><a>Debian Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29489"><a href="https://www.linuxcapable.com/debian-release/">Debian</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27169"><a href="https://www.linuxcapable.com/lmde-release/">Linux Mint Debian Edition</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27170"><a href="https://www.linuxcapable.com/fedora-release/">Fedora</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19048"><a>RHEL Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27176"><a href="https://www.linuxcapable.com/almalinux-release/">AlmaLinux</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27177"><a href="https://www.linuxcapable.com/centos-stream-release/">CentOS Stream</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27178"><a href="https://www.linuxcapable.com/rocky-linux-release/">Rocky Linux</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16629"><a>Ubuntu Based<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27173"><a href="https://www.linuxcapable.com/linux-mint-release/">Linux Mint</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27174"><a href="https://www.linuxcapable.com/pop_os-release/">Pop!_OS</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27175"><a href="https://www.linuxcapable.com/ubuntu-release/">Ubuntu</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27171"><a href="https://www.linuxcapable.com/opensuse-release/">openSUSE</a></li>
<li class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34097"><a target="_blank" rel="nofollow" href="https://www.facebook.com/LinuxCapable/"><a href="https://www.facebook.com/LinuxCapable/" target="_blank" class="wplogout-social-fb-header" rel="noopener"><svg width="23px" height="23px" viewBox="0 0 1024 1024" xmlns="http://www.w3.org/2000/svg">    <circle cx="512" cy="512" r="512" style="fill:#1877f2"/>    <path d="M552 766.4V587.6h59.7l11.4-74h-71v-48c0-20.2 9.9-40 41.7-40H626v-63s-29.3-5-57.3-5c-58.5 0-96.7 35.4-96.7 99.6v56.4h-65v74h65v178.9c-122.4-19.2-216-125.1-216-252.9 0-141.4 114.6-256 256-256s256 114.6 256 256c0 127.7-93.6 233.6-216 252.8z" style="fill:#fff"/> </svg></a></a></li>
<li class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34098"><a target="_blank" rel="nofollow" href="https://twitter.com/linuxcapable/"><a href="https://twitter.com/linuxcapable/" target="_blank" class="wplogout-social-tw-header" rel="noopener"><svg width="23px" height="23px" viewBox="0 0 1024 1024" xmlns="http://www.w3.org/2000/svg">    <circle cx="512" cy="512" r="512" style="fill:#1da1f2"/>    <path d="M778 354.8c-18.8 8.3-38.9 13.9-60.1 16.5 21.6-13 38.2-33.5 46-57.9-20.2 11.8-42.7 20.4-66.5 25.2-19.1-20.4-46.2-33.2-76.4-33.2-57.8 0-104.7 46.9-104.7 104.6 0 8.3 1 16.3 2.7 23.9-87-4.1-164.2-45.9-215.8-109.1-9.1 15.4-14.2 33.2-14.2 52.7 0 36.4 18.5 68.4 46.6 87.2-17.2-.6-33.3-5.3-47.4-13.1v1.3c0 50.8 36 93.1 84 102.7-8.8 2.4-18.1 3.6-27.6 3.6-6.7 0-13.1-.6-19.5-1.8 13.4 41.6 52 71.9 98 72.7-35.7 28.1-81.1 44.8-129.8 44.8-8.3 0-16.6-.5-24.9-1.4 46.6 29.7 101.5 47 160.8 47C621.7 720.5 727 561 727 422.9c0-4.4 0-8.9-.3-13.4 20.4-14.7 38.3-33.2 52.3-54.2l-1-.5z" style="fill:#fff"/> </svg></a></a></li>
<li class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34140"><a target="_blank" rel="nofollow" href="https://www.reddit.com/r/linuxcapable/"><a href="https://www.reddit.com/r/linuxcapable/" target="_blank" class="wplogout-social-reddit-header" rel="noopener"><svg width="23px" height="23px" viewBox="0 0 256 256" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" preserveAspectRatio="xMidYMid">     <g>         <circle fill="#FF4500" cx="128" cy="128" r="128"></circle>         <path d="M213.149867,129.220267 C213.149867,118.843733 204.758756,110.603378 194.532978,110.603378 C189.498311,110.603378 184.918756,112.585956 181.562311,115.791644 C168.745244,106.635378 151.195022,100.6848 131.662222,99.9224889 L140.206933,59.9409778 L167.980089,65.8915556 C168.287289,72.9116444 174.084267,78.5578667 181.257956,78.5578667 C188.5824,78.5578667 194.532978,72.6072889 194.532978,65.28 C194.532978,57.9555556 188.5824,52.0049778 181.257956,52.0049778 C176.069689,52.0049778 171.490133,55.0570667 169.353956,59.4830222 L138.377956,52.9208889 C137.462044,52.7672889 136.546133,52.9208889 135.934578,53.3788444 C135.172267,53.8368 134.714311,54.5991111 134.563556,55.5150222 L125.100089,100.073244 C105.262933,100.6848 87.4083556,106.635378 74.4376889,115.945244 C71.0812444,112.739556 66.5016889,110.756978 61.4670222,110.756978 C51.0904889,110.756978 42.8501333,119.148089 42.8501333,129.373867 C42.8501333,137.002667 47.4268444,143.4112 53.8382222,146.312533 C53.5310222,148.141511 53.3802667,149.973333 53.3802667,151.958756 C53.3802667,180.644978 86.7996444,203.995022 128.001422,203.995022 C169.2032,203.995022 202.622578,180.798578 202.622578,151.958756 C202.622578,150.126933 202.468978,148.141511 202.164622,146.312533 C208.573156,143.4112 213.149867,136.849067 213.149867,129.220267 Z M85.2721778,142.495289 C85.2721778,135.170844 91.2227556,129.220267 98.5500444,129.220267 C105.874489,129.220267 111.825067,135.170844 111.825067,142.495289 C111.825067,149.819733 105.874489,155.773156 98.5500444,155.773156 C91.2227556,155.923911 85.2721778,149.819733 85.2721778,142.495289 Z M159.588978,177.746489 C150.432711,186.902756 133.036089,187.514311 128.001422,187.514311 C122.813156,187.514311 105.416533,186.749156 96.4110222,177.746489 C95.04,176.372622 95.04,174.236444 96.4110222,172.862578 C97.7848889,171.491556 99.9210667,171.491556 101.294933,172.862578 C107.094756,178.6624 119.303111,180.644978 128.001422,180.644978 C136.699733,180.644978 149.058844,178.6624 154.705067,172.862578 C156.078933,171.491556 158.215111,171.491556 159.588978,172.862578 C160.809244,174.236444 160.809244,176.372622 159.588978,177.746489 Z M157.1456,155.923911 C149.821156,155.923911 143.870578,149.973333 143.870578,142.648889 C143.870578,135.324444 149.821156,129.373867 157.1456,129.373867 C164.472889,129.373867 170.423467,135.324444 170.423467,142.648889 C170.423467,149.819733 164.472889,155.923911 157.1456,155.923911 Z" fill="#FFFFFF" fill-rule="nonzero"></path>     </g> </svg></a></a></li>
<li class="menu-item-float-right menu-item menu-item-type-custom menu-item-object-custom menu-item-34099"><a target="_blank" rel="nofollow" href="https://www.linuxcapable.com/feed/"><a href="https://www.linuxcapable.com/feed/" target="_blank" class="wplogout-social-rss-header" rel="noopener"><svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" 	 width="23px" height="23px"  viewBox="0 0 512 512" style="enable-background:new 0 0 512 512;" xml:space="preserve"> <circle style="fill:#FF9911;" cx="256" cy="256" r="256"/> <path style="fill:#ED8800;" d="M256,0c-11.317,0-22.461,0.744-33.391,2.167C348.216,18.53,445.217,125.933,445.217,256 	s-97.002,237.47-222.609,253.833C233.539,511.256,244.683,512,256,512c141.385,0,256-114.616,256-256S397.385,0,256,0z"/> <g> 	<path style="fill:#FCFCFC;" d="M155.826,401.252c-24.856,0-45.078-20.222-45.078-45.078c0-24.856,20.222-45.078,45.078-45.078 		s45.078,20.222,45.078,45.078C200.904,381.03,180.683,401.252,155.826,401.252z"/> 	<path style="fill:#FCFCFC;" d="M249.878,387.908v-10.041c0-63.924-51.821-115.744-115.744-115.744h-10.041 		c-1.223,0-2.214-0.992-2.214-2.214v-57.902c0-1.223,0.992-2.214,2.214-2.214h10.041c98.349,0,178.075,79.727,178.075,178.075 		v10.041c0,1.223-0.992,2.214-2.214,2.214h-57.902C250.87,390.122,249.878,389.13,249.878,387.908z"/> 	<path style="fill:#FCFCFC;" d="M361.183,387.908v-10.041c0-125.395-101.653-227.049-227.049-227.049h-10.041 		c-1.223,0-2.214-0.992-2.214-2.214V90.701c0-1.223,0.992-2.214,2.214-2.214h12.255c76.705,0,148.818,29.87,203.057,84.108 		c54.239,54.239,84.108,126.352,84.108,203.057v12.256c0,1.223-0.992,2.214-2.214,2.214h-57.902 		C362.174,390.122,361.183,389.13,361.183,387.908z"/> </g> </svg></a></a></li>
</ul></div><div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div>			</div>
		</nav>
		
	<div class="site grid-container container hfeed" id="page">
				<div class="site-content" id="content">
			
	<div class="content-area" id="primary">
		<main class="site-main" id="main">
			
<article id="post-21152" class="post-21152 post type-post status-publish format-standard has-post-thumbnail hentry category-debian-release no-featured-image-padding" >
	<div class="inside-article">
		<p id="breadcrumbs"><span><span><a href="https://www.linuxcapable.com/">Home</a> » <span><a href="https://www.linuxcapable.com/debian-release/">Debian</a> » <strong class="breadcrumb_last" aria-current="page">How to Install Linux Kernel 6.0 on Debian 11 Bullseye</strong></span></span></span></p>			<header class="entry-header" aria-label="Content">
				<h1 class="entry-title">How to Install Linux Kernel 6.0 on Debian 11 Bullseye</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2022-11-03T17:06:51+08:00" itemprop="datePublished">Published on: Thursday, November 3, 2022</time></span>  <span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author">by <span class="fn n author-name" itemprop="name">Joshua James</span></span></span>		</div>
					</header>
			
		<div class="entry-content">
			<div class='code-block code-block-11 code-block-block-11' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<div id="top-article"></div>

<script>
window['nitroAds'].createAd('top-article', {
  "renderVisibleOnly": false,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 1025px)"
});
</script></div>

<p id="speakable-summary">For most users, the standard Linux Kernel that ships with your distribution suites your purpose fine. But for users that would like to install the latest kernels that the Debian team is working on, which is usually found in the sid repository or better known as unstable can be more beneficial to install given it should be better compatible than a generic kernel in some circumstances along with being easy to upgrade.</p>



<p>The tutorial will demonstrate how to add the sid repository and create an apt pin using the command line terminal for users who prefer installing an upgraded kernel from the Debian team.</p>



<div id="ez-toc-container" class="ez-toc-v2_0_36 counter-hierarchy ez-toc-counter ez-toc-transparent ez-toc-container-direction">
<p class="ez-toc-title">Table of Contents</p>
<label for="item" class="cssicon"><span style="display: flex;align-items: center;width: 35px;height: 30px;justify-content: center;"><svg style="fill: #999;color:#999" xmlns="http://www.w3.org/2000/svg" class="list-377408" width="20px" height="20px" viewBox="0 0 24 24" fill="none"><path d="M6 6H4v2h2V6zm14 0H8v2h12V6zM4 11h2v2H4v-2zm16 0H8v2h12v-2zM4 16h2v2H4v-2zm16 0H8v2h12v-2z" fill="currentColor"></path></svg><svg style="fill: #999;color:#999" class="arrow-unsorted-368013" xmlns="http://www.w3.org/2000/svg" width="10px" height="10px" viewBox="0 0 24 24" version="1.2" baseProfile="tiny"><path d="M18.2 9.3l-6.2-6.3-6.2 6.3c-.2.2-.3.4-.3.7s.1.5.3.7c.2.2.4.3.7.3h11c.3 0 .5-.1.7-.3.2-.2.3-.5.3-.7s-.1-.5-.3-.7zM5.8 14.7l6.2 6.3 6.2-6.3c.2-.2.3-.5.3-.7s-.1-.5-.3-.7c-.2-.2-.4-.3-.7-.3h-11c-.3 0-.5.1-.7.3-.2.2-.3.5-.3.7s.1.5.3.7z"/></svg></span></label><label for="item" class="cssiconcheckbox">1</label><input type="checkbox" id="item" ><nav><ul class='ez-toc-list ez-toc-list-level-1' ><li class='ez-toc-page-1 ez-toc-heading-level-2'><a class="ez-toc-link ez-toc-heading-1" href="#Recommended_Steps_Before_Installation" title="Recommended Steps Before Installation">Recommended Steps Before Installation</a></li><li class='ez-toc-page-1 ez-toc-heading-level-2'><a class="ez-toc-link ez-toc-heading-2" href="#Import_Sid_Unstable_Repository" title="Import Sid / Unstable Repository">Import Sid / Unstable Repository</a></li><li class='ez-toc-page-1 ez-toc-heading-level-2'><a class="ez-toc-link ez-toc-heading-3" href="#Create_APT_Pinning_File" title="Create APT Pinning File">Create APT Pinning File</a></li><li class='ez-toc-page-1 ez-toc-heading-level-2'><a class="ez-toc-link ez-toc-heading-4" href="#Install_Linux_Kernel_60" title="Install Linux Kernel 6.0">Install Linux Kernel 6.0</a></li><li class='ez-toc-page-1 ez-toc-heading-level-2'><a class="ez-toc-link ez-toc-heading-5" href="#How_to_Restore_the_Default_Kernel" title="How to Restore the Default Kernel">How to Restore the Default Kernel</a></li><li class='ez-toc-page-1 ez-toc-heading-level-2'><a class="ez-toc-link ez-toc-heading-6" href="#Install_Linux_Kernel_Alternative_Methods" title="Install Linux Kernel Alternative Methods">Install Linux Kernel Alternative Methods</a></li></ul></nav></div>
<h2 id="ftoc-heading-2"><span class="ez-toc-section" id="Recommended_Steps_Before_Installation"></span>Recommended Steps Before Installation<span class="ez-toc-section-end"></span></h2>



<p>Before proceeding with the tutorial, ensuring your system is up-to-date with all existing packages is good.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update</code></pre>



<p>Optionally, you can list the updates for users who require review or are curious.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt --list upgradable</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_8"></div>

<script>
window['nitroAds'].createAd('article_8', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_8"></div>

<script>
window['nitroAds'].createAd('posts_mobile_8', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p>Proceed to upgrade any outdated packages using the following command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt upgrade</code></pre>



<h2 id="import-sid-unstable-repository"><span class="ez-toc-section" id="Import_Sid_Unstable_Repository"></span>Import Sid / Unstable Repository<span class="ez-toc-section-end"></span></h2>



<p>The following steps will explain how to import the sid/unstable repository. This is the repository.</p>



<p>First, copy and paste the following command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">echo "deb http://deb.debian.org/debian unstable main contrib non-free" | sudo tee -a /etc/apt/sources.list
echo "deb-src http://deb.debian.org/debian unstable main contrib non-free" | sudo tee -a /etc/apt/sources.list</code></pre>



<h2 id="create-apt-pinning-file"><span class="ez-toc-section" id="Create_APT_Pinning_File"></span>Create APT Pinning File<span class="ez-toc-section-end"></span></h2>



<p>Next, an easy solution is to use apt-pinning to avoid having different version branches causing your system to prompt for updates from the experimental repository. Open the following file using a text editor.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo tee /etc/apt/preferences&lt;&lt;EOF
Package: *
Pin: release a=bullseye
Pin-Priority: 500

Package: linux-image-amd64
Pin:release a=unstable
Pin-Priority: 1000

Package: *
Pin: release a=unstable
Pin-Priority: 100
EOF</code></pre>



<p><strong>Please remember to <mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">replace the amd64</mark> with the architecture of your system.</strong></p>



<p>Optionally, you can open the preferences file to confirm that it has been added successfully using a text editor such as nano.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo nano /etc/apt/preferences</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_9"></div>

<script>
window['nitroAds'].createAd('article_9', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_9"></div>

<script>
window['nitroAds'].createAd('posts_mobile_9', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p><em>Example:</em></p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img data-perfmatters-preload decoding="async" width="740" height="444" src="https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel.png" alt="How to Install Linux Kernel 6.0 on Debian 11 Bullseye" class="wp-image-34209" srcset="https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel.png 740w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-300x180.png 300w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-583x350.png 583w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-375x225.png 375w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-238x143.png 238w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-358x215.png 358w, https://www.linuxcapable.com/wp-content/uploads/2022/11/example-apt-pinning-debian-11-bullseye-kernel-75x45.png 75w" sizes="(max-width: 740px) 100vw, 740px" /></figure></div>


<p>The order goes, all packages are preferred to <mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color"><strong>Bullseye with a higher score (500) than unstable (100)</strong>,</mark> so you are not prompted on various packages to be updated from the unstable repository.</p>



<p>However, to make it easy to keep the kernel up to date when you run the apt update command for your standard Bullseye packages, the example above has set <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">linux-image-amd64 as a high priority (1000)</mark></strong> using the unstable repository above any other source for that <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">package only.</mark></strong></p>



<h2 id="install-or-upgrade-to-linux-kernel-5-15-lts"><span class="ez-toc-section" id="Install_Linux_Kernel_60"></span>Install Linux Kernel 6.0<span class="ez-toc-section-end"></span></h2>



<p>The first thing to do is update your repository to reflect the changes to your sources list and preferences.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update</code></pre>



<p>You will notice you have a package to update.</p>



<pre class="wp-block-code"><code lang="" class="">1 package can be upgraded. Run 'apt list --upgradable' to see it.</code></pre>



<p>For users newer to Linux, you can list what is upgradeable using the following command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">apt list --upgradable -a</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_10"></div>

<script>
window['nitroAds'].createAd('article_10', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_10"></div>

<script>
window['nitroAds'].createAd('posts_mobile_10', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p><em>Example output:</em></p>



<pre class="wp-block-code"><code class="">joshua@debian-11-bullseye:~$ apt list --upgradable -a
Listing... Done
linux-image-amd64/unstable 6.0.6-2 amd64 [upgradable from: 5.10.149-2]
linux-image-amd64/stable-security,now 5.10.149-2 amd64 [installed,upgradable to: 6.0.6-2]
linux-image-amd64/stable 5.10.84-1 amd64</code></pre>



<p>The <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">-a flag</mark></strong> added to the command lists all versions available since alternatives may exist.</p>



<p>Run the apt upgrade command to begin updating to Linux Kernel 6.0, as this is what you have set in the preferences.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt upgrade</code></pre>



<p>Once completed, reboot your system for the new kernel to activate.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">reboot</code></pre>



<p>Once logged back in, open your terminal and type the following command to verify the installation.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">uname -r</code></pre>



<p><em>Example output:</em></p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">6.0.0-2-amd64</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_11"></div>

<script>
window['nitroAds'].createAd('article_11', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_11"></div>

<script>
window['nitroAds'].createAd('posts_mobile_11', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p>Alternatively, print your system specs with neofetch.</p>



<pre class="wp-block-code"><code class="">sudo apt install neofetch -y</code></pre>



<p>Now run neofetch to get your Linux kernel version.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">neofetch</code></pre>



<p><em>Example Neofetch output:</em></p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye.png"><img decoding="async" loading="lazy" width="740" height="444" src="https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye.png" alt="How to Install Linux Kernel 6.0 on Debian 11 Bullseye" class="wp-image-34208" srcset="https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye.png 740w, https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye-300x180.png 300w, https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye-583x350.png 583w, https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye-375x225.png 375w, https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye-238x143.png 238w, https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye-358x215.png 358w, https://www.linuxcapable.com/wp-content/uploads/2022/11/linux-kernel-6.0-debian-11-bullseye-75x45.png 75w" sizes="(max-width: 740px) 100vw, 740px" /></a></figure></div>


<p>Any new updates will automatically be seen when you run the <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">apt update command</mark> </strong>to check for updates for the rest of your Debian 11 Bullseye repository packages.</p>



<h2><span class="ez-toc-section" id="How_to_Restore_the_Default_Kernel"></span>How to Restore the Default Kernel<span class="ez-toc-section-end"></span></h2>



<p>For users who find the new kernel has bugs for their hardware, say, loss of sound, use the following steps to restore the default kernel; if you installed an alternative kernel, replace the default kernel section with whatever you want to install.</p>



<p>First, remove the kernel using the following command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt autoremove linux-image-6.0*</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_12"></div>

<script>
window['nitroAds'].createAd('article_12', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_12"></div>

<script>
window['nitroAds'].createAd('posts_mobile_12', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p>Next, you will see the following prompt advising that you must make sure a kernel is installed or re-installed before you reboot if you remove the current kernel. Otherwise, your system will be destroyed, unbootable, broken, etc.</p>



<p><em>Example:</em></p>


<div class="wp-block-image">
<figure class="aligncenter size-full"><img decoding="async" loading="lazy" width="740" height="444" src="https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye.png" alt="How to Install Linux Kernel 6.0 on Debian 11 Bullseye" class="wp-image-34211" srcset="https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye.png 740w, https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye-300x180.png 300w, https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye-583x350.png 583w, https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye-375x225.png 375w, https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye-238x143.png 238w, https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye-358x215.png 358w, https://www.linuxcapable.com/wp-content/uploads/2022/11/remove-linux-kernel-6.0-debian-11-bullseye-75x45.png 75w" sizes="(max-width: 740px) 100vw, 740px" /></figure></div>


<p>Press the <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">tab</mark></strong> key, select <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">&lt;No&gt;,</mark></strong> and press the <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">ENTER KEY</mark></strong>.</p>



<p>For users with the preferences file configured for this package, you can remove the experimental repository or take out the kernel priority package referencing the unstable repository.</p>



<p>Remove the preferences file as an example.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo rm /etc/apt/preferences</code></pre>



<p>Import the alternative with the kernel package now removed.</p>



<pre class="wp-block-code"><code class="">sudo tee /etc/apt/preferences&lt;&lt;EOF
Package: *
Pin: release a=bullseye
Pin-Priority: 500

Package: *
Pin: release a=unstable
Pin-Priority: 100
EOF</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_13"></div>

<script>
window['nitroAds'].createAd('article_13', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_13"></div>

<script>
window['nitroAds'].createAd('posts_mobile_13', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p>The alternative is using a text editor and removing the lines manually, which works just as well. This should be done if you have other packages customized.</p>



<p>Now run an APT update.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update</code></pre>



<p>Before we reboot, make sure the default generic is installed, do not fuss too much as you can install alternative versions later on as we are just trying to get your system back to working order with the default kernel for Debian.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install --reinstall linux-image-generic</code></pre>



<p>Now reboot.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">reboot</code></pre>



<p>Now verify the kernel installed, which should be the default generic kernel.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">uname -r</code></pre>



<p><em>Example output:</em></p>



<pre class="wp-block-code"><code class="">5.10.0-19-amd64</code></pre>



<div class='code-block code-block-9 code-block-block-9' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 100px;'>
<br><div id="article_14"></div>

<script>
window['nitroAds'].createAd('article_14', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "728",
      "90"
    ]
  ],
  "mediaQuery": "(min-width: 768px)"
});
</script><br>

</div>
<div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="posts_mobile_14"></div>

<script>
window['nitroAds'].createAd('posts_mobile_14', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 320px) and (max-width: 767px)"
});
</script></div>
<p>As mentioned above, you have fallen back to the default kernel.</p>



<h2><span class="ez-toc-section" id="Install_Linux_Kernel_Alternative_Methods"></span>Install Linux Kernel Alternative Methods<span class="ez-toc-section-end"></span></h2>



<p>For those who want options besides the unstable repository, check out the following custom kernel tutorials, which often boast the latest Linux custom-built kernels.</p>



<ul>
<li><a href="https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/"><strong>How to Install XanMod Linux Kernel on Debian 11 Bullseye</strong> &#8211;</a> <strong><mark style="background-color:var(--contrast-2)" class="has-inline-color has-base-3-color">Edge branch</mark></strong> contains the latest kernel.</li>



<li><strong><a href="https://www.linuxcapable.com/how-to-install-liquorix-linux-kernel-on-debian-11-bullseye/">How to Install Liquorix Linux Kernel on Debian 11 Bullseye</a></strong> &#8211; Often up-to-date but not as fast as XanMod, often a week behind.</li>
</ul>
<div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/'><div class='heateor_sss_sharing_title' style="font-weight:bold" >Like the tutorial? Please feel free to share.</div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?via=linuxcapable&text=How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F&title=How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff"/></svg></span></a><a class="heateor_sss_button_telegram" href="https://telegram.me/share/url?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F&text=How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye" title="Telegram" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_telegram" style="background-color:#3da5f1;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M25.515 6.896L6.027 14.41c-1.33.534-1.322 1.276-.243 1.606l5 1.56 1.72 5.66c.226.625.115.873.77.873.506 0 .73-.235 1.012-.51l2.43-2.363 5.056 3.734c.93.514 1.602.25 1.834-.863l3.32-15.638c.338-1.363-.52-1.98-1.41-1.577z"></path></svg></span></a><a class="heateor_sss_button_mastodon" href="https://mastodon.social/share?text=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F&title=How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye" title="Mastodon" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_mastodon" style="background-color:#2b90d9;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M27 12c0-5.12-3.35-6.62-3.35-6.62C22 4.56 19.05 4.23 16 4.21c-3 0-5.92.35-7.61 1.12C8.36 5.33 5 6.83 5 12v4c.12 5 .92 9.93 5.54 11.16a17.67 17.67 0 005.44.6 10.88 10.88 0 004.18-.95l-.09-1.95a13.36 13.36 0 01-4.07.54c-2.12-.07-4.37-.23-4.71-2.84a5.58 5.58 0 01-.05-.73 27.46 27.46 0 004.73.63 26.76 26.76 0 004.68-.28c3-.35 5.53-2.17 5.85-3.83A39.25 39.25 0 0027 12zm-3.95 6.59h-2.46v-6c0-1.27-.53-1.91-1.6-1.91s-1.77.76-1.77 2.27v3.29h-2.44v-3.35c0-1.51-.59-2.27-1.77-2.27s-1.6.64-1.6 1.91v6H9v-6.18a4.49 4.49 0 011-3 3.39 3.39 0 012.63-1.12 3.17 3.17 0 012.84 1.44l.61 1 .61-1a3.17 3.17 0 012.84-1.44 3.39 3.39 0 012.63 1.12 4.49 4.49 0 011 3z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_tumblr" href="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F&title=How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye&caption=" title="Tumblr" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg aheateor_sss_s__default heateor_sss_s_tumblr" style="background-color:#29435d;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 36 36"><path fill="#fff" d="M20.775 21.962c-.37.177-1.08.33-1.61.345-1.598.043-1.907-1.122-1.92-1.968v-6.217h4.007V11.1H17.26V6.02h-2.925s-.132.044-.144.15c-.17 1.556-.895 4.287-3.923 5.378v2.578h2.02v6.522c0 2.232 1.647 5.404 5.994 5.33 1.467-.025 3.096-.64 3.456-1.17l-.96-2.846z"/></svg></span></a><a class="heateor_sss_whatsapp" href="https://api.whatsapp.com/send?text=How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-linux-kernel-mainline-on-debian-11-bullseye%2F" title="Whatsapp" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#55eb4c;width:70px;height:35px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-6 -5 40 40"><path class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke="#fff" stroke-width="2" fill="none" d="M 11.579798566743314 24.396926207859085 A 10 10 0 1 0 6.808479557110079 20.73576436351046"></path><path d="M 7 19 l -1 6 l 6 -1" class="heateor_sss_no_fill heateor_sss_svg_stroke" stroke="#fff" stroke-width="2" fill="none"></path><path d="M 10 10 q -1 8 8 11 c 5 -1 0 -6 -1 -3 q -4 -3 -5 -5 c 4 -2 -1 -5 -1 -4" fill="#fff"></path></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:70px;height:35px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://www.linuxcapable.com/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/', 'How%20to%20Install%20Linux%20Kernel%206.0%20on%20Debian%2011%20Bullseye', '' )"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="-.3 0 32 32" version="1.1" width="100%" height="100%" style="display:block;" xml:space="preserve"><g><path fill="#fff" d="M18 14V8h-4v6H8v4h6v6h4v-6h6v-4h-6z" fill-rule="evenodd"></path></g></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>		</div>

				<footer class="entry-meta" aria-label="Entry meta">
			<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://www.linuxcapable.com/debian-release/" rel="category tag">Debian</a></span> 		<nav id="nav-below" class="post-navigation" aria-label="Posts">
			<div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" /></svg></span><span class="prev"><a href="https://www.linuxcapable.com/how-to-install-backports-experimental-repository-on-debian-11/" rel="prev">How to Enable Backports on Debian 11 Bullseye</a></span></div><div class="nav-next"><span class="gp-icon icon-arrow-right"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 256.001c0 2.266-1.133 4.815-2.832 6.515L43.599 394.509c-1.7 1.7-4.248 2.833-6.514 2.833s-4.816-1.133-6.515-2.833l-14.163-14.162c-1.699-1.7-2.832-3.966-2.832-6.515 0-2.266 1.133-4.815 2.832-6.515l111.317-111.316L16.407 144.685c-1.699-1.7-2.832-4.249-2.832-6.515s1.133-4.815 2.832-6.515l14.163-14.162c1.7-1.7 4.249-2.833 6.515-2.833s4.815 1.133 6.514 2.833l131.994 131.993c1.7 1.7 2.832 4.249 2.832 6.515z" fill-rule="nonzero" /></svg></span><span class="next"><a href="https://www.linuxcapable.com/install-audacious-on-ubuntu/" rel="next">2 Ways to Install Audacious on Ubuntu 22.10 | 22.04 | 20.04</a></span></div>		</nav>
				</footer>
		
<p></p>



<hr class="wp-block-separator has-alpha-channel-opacity"/>



<p><strong>Not what you were looking for? Try searching for additional tutorials.</strong></p>


<form role="search" method="get" action="https://www.linuxcapable.com/" class="wp-block-search__button-outside wp-block-search__text-button wp-block-search"><label for="wp-block-search__input-1" class="wp-block-search__label" >Search</label><div class="wp-block-search__inside-wrapper " ><input type="search" id="wp-block-search__input-1" class="wp-block-search__input wp-block-search__input" name="s" value="" placeholder=""  required /><button type="submit" class="wp-block-search__button wp-element-button"  >Search</button></div></form>	</div>
</article>

			<div class="comments-area">
				    <div class="wpdiscuz_top_clearing"></div>
    <div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpdiscuz_no_avatar wpd-layout-3 wpd-comments-open">
                    <div class="wc_social_plugin_wrapper">
                            </div>
            <div class="wpd-form-wrap">
                <div class="wpd-form-head">
                                            <div class="wpd-sbs-toggle">
                            <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
                        </div>
                                            <div class="wpd-auth">
                                                <div class="wpd-login">
                                                    </div>
                    </div>
                </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://www.linuxcapable.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">new follow-up comments</option>
                                                                                                                                <option value="all_comment" >new replies to my comments</option>
                                                                                </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                    <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" class="wpd-prim-button wpd_not_clicked" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="8e3c07378f" /><input type="hidden" name="_wp_http_referer" value="/how-to-install-linux-kernel-mainline-on-debian-11-bullseye/" />                            </form>
                                                </div>
                            <div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'>
                                        <form class="wpd_comm_form wpd_main_comm_form"
                      method="post" enctype="multipart/form-data" data-uploading="false">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">
                                            <div id="wpd-editor-wraper-0_0" style="display: none;">
                <div id="wpd-editor-char-counter-0_0"
                     class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-0_0">Label</label>
                <textarea id="wc-textarea-0_0" name="wc_comment"
                          class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-0_0"></div>
                        <div id="wpd-editor-toolbar-0_0">
                            <button title="Bold"
                        class="ql-bold"  ></button>
                                <button title="Italic"
                        class="ql-italic"  ></button>
                                <button title="Underline"
                        class="ql-underline"  ></button>
                                <button title="Strike"
                        class="ql-strike"  ></button>
                                <button title="Ordered List"
                        class="ql-list" value='ordered' ></button>
                                <button title="Unordered List"
                        class="ql-list" value='bullet' ></button>
                                <button title="Blockquote"
                        class="ql-blockquote"  ></button>
                                <button title="Code Block"
                        class="ql-code-block"  ></button>
                                <button title="Link"
                        class="ql-link"  ></button>
                                <button title="Source Code"
                        class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button>
                                <button title="Spoiler"
                        class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button>
                            <div class="wpd-editor-buttons-right">
                            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot" style='display:none;'>
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper">
                                <input id="wc_name-0_0" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
                <label for="wc_name-0_0" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper">
                                <input id="wc_email-0_0" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
                <label for="wc_email-0_0" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper">
                                        <input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
                    <label for="wc_website-0_0" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
            <div class="wpdiscuz-cfturnstile">	<div id="cf-turnstile" class="cf-turnstile" data-callback="turnstileWPDiscuzCallback"	data-sitekey="0x4AAAAAAAAlquPnAGakj5Ky"
	data-theme="light"
	data-name="cf-turnstile" style="margin-left: -15px;"></div>
		<style>.wc_comm_submit { pointer-events: none; opacity: 0.5; }</style>
  	<br/>
	    <script>
    if (typeof jQuery != 'undefined') {
      jQuery(document).ready(function() {
        setTimeout(function() {
          if (jQuery('#cf-turnstile iframe').length <= 0) {
              turnstile.remove('#cf-turnstile');
              turnstile.render('#cf-turnstile', { sitekey: '0x4AAAAAAAAlquPnAGakj5Ky', });
          }
        }, 200);
      });
    } else {
      document.addEventListener("DOMContentLoaded", function() {
        setTimeout(function() {
          turnstile.remove('#cf-turnstile');
          turnstile.render('#cf-turnstile', { sitekey: '0x4AAAAAAAAlquPnAGakj5Ky', });
        }, 200);
      });
    }
    </script>
    </div><div style="clear: both;"></div><br/>        <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" checked='checked'/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="0_0"
                           name="wpdiscuz_unique_id">
                                    </form>
                        </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
                            <div class="wpd-secondary-forms-social-content"></div>
                <div class="clearfix"></div>
                                        <form class="wpd_comm_form wpd-secondary-form-wrapper"
                      method="post" enctype="multipart/form-data" data-uploading="false">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">
                                            <div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;">
                <div id="wpd-editor-char-counter-wpdiscuzuniqueid"
                     class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label>
                <textarea id="wc-textarea-wpdiscuzuniqueid" name="wc_comment"
                          class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-wpdiscuzuniqueid"></div>
                        <div id="wpd-editor-toolbar-wpdiscuzuniqueid">
                            <button title="Bold"
                        class="ql-bold"  ></button>
                                <button title="Italic"
                        class="ql-italic"  ></button>
                                <button title="Underline"
                        class="ql-underline"  ></button>
                                <button title="Strike"
                        class="ql-strike"  ></button>
                                <button title="Ordered List"
                        class="ql-list" value='ordered' ></button>
                                <button title="Unordered List"
                        class="ql-list" value='bullet' ></button>
                                <button title="Blockquote"
                        class="ql-blockquote"  ></button>
                                <button title="Code Block"
                        class="ql-code-block"  ></button>
                                <button title="Link"
                        class="ql-link"  ></button>
                                <button title="Source Code"
                        class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button>
                                <button title="Spoiler"
                        class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button>
                            <div class="wpd-editor-buttons-right">
                            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot" style='display:none;'>
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper">
                                <input id="wc_name-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
                <label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper">
                                <input id="wc_email-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
                <label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper">
                                        <input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
                    <label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
            <div class="wpdiscuz-cfturnstile">	<div id="cf-turnstile" class="cf-turnstile" data-callback="turnstileWPDiscuzCallback"	data-sitekey="0x4AAAAAAAAlquPnAGakj5Ky"
	data-theme="light"
	data-name="cf-turnstile" style="margin-left: -15px;"></div>
		<style>.wc_comm_submit { pointer-events: none; opacity: 0.5; }</style>
  	<br/>
	    <script>
    if (typeof jQuery != 'undefined') {
      jQuery(document).ready(function() {
        setTimeout(function() {
          if (jQuery('#cf-turnstile iframe').length <= 0) {
              turnstile.remove('#cf-turnstile');
              turnstile.render('#cf-turnstile', { sitekey: '0x4AAAAAAAAlquPnAGakj5Ky', });
          }
        }, 200);
      });
    } else {
      document.addEventListener("DOMContentLoaded", function() {
        setTimeout(function() {
          turnstile.remove('#cf-turnstile');
          turnstile.render('#cf-turnstile', { sitekey: '0x4AAAAAAAAlquPnAGakj5Ky', });
        }, 200);
      });
    }
    </script>
    </div><div style="clear: both;"></div><br/>        <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" checked='checked'/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid"
                           name="wpdiscuz_unique_id">
                                    </form>
                        </div>
                </div>
                    </div>
                <script>
    if (typeof jQuery != 'undefined') {
      jQuery(document).ready(function() {
        setTimeout(function() {
          if (jQuery('#cf-turnstile iframe').length <= 0) {
              turnstile.remove('#cf-turnstile');
              turnstile.render('#cf-turnstile', { sitekey: '0x4AAAAAAAAlquPnAGakj5Ky', });
          }
        }, 200);
      });
    } else {
      document.addEventListener("DOMContentLoaded", function() {
        setTimeout(function() {
          turnstile.remove('#cf-turnstile');
          turnstile.render('#cf-turnstile', { sitekey: '0x4AAAAAAAAlquPnAGakj5Ky', });
        }, 200);
      });
    }
    </script>
                <div id="wpd-threads" class="wpd-thread-wrapper">
                <div class="wpd-thread-head">
                    <div class="wpd-thread-info " data-comments-count="0">
                        <span class='wpdtc' title='0'>0</span> Comments                    </div>
                                        <div class="wpd-space"></div>
                    <div class="wpd-thread-filter">
                                                    <div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
                                                        <div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
                                                </div>
                </div>
                <div class="wpd-comment-info-bar">
                    <div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
                    <div class="wpd-filter-view-all">View all comments</div>
                </div>
                                <div class="wpd-thread-list">
                                        <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
            </div>
                </div>
        </div>
    <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
    <div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
    			</div>

					</main>
	</div>

	<div class="widget-area sidebar is-right-sidebar" id="right-sidebar">
	<div class="inside-right-sidebar">
		<aside id="ai_widget-51" class="widget inner-padding ai_widget"><div class='code-block code-block-2 code-block-top-side-ads' style='margin: 0px auto; text-align: center; display: block; clear: both; min-height: 285px;'>
<div id="sidebar-top-1"></div>

<script>
window['nitroAds'].createAd('sidebar-top-1', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": false,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "336",
      "280"
    ],
    [
      "300",
      "250"
    ]
  ],
  "mediaQuery": "(min-width: 1025px)"
});
</script></div>
</aside><aside id="recent-posts-widget-with-thumbnails-3" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-3" class="rpwwt-widget">
<h2 class="widget-title">Recent Posts</h2>
	<ul>
		<li class="debian-release"><a href="https://www.linuxcapable.com/install-freeoffice-on-debian/"><span class="rpwwt-post-title">How to Install FreeOffice on Debian 11/10/Sid</span></a></li>
		<li class="fedora-release"><a href="https://www.linuxcapable.com/install-firefox-nightly-on-fedora-linux/"><span class="rpwwt-post-title">How to Install Firefox Nightly on Fedora 37/36</span></a></li>
		<li class="fedora-release"><a href="https://www.linuxcapable.com/install-hare-on-fedora-linux/"><span class="rpwwt-post-title">How to Install Hare on Fedora 37/36</span></a></li>
		<li class="fedora-release"><a href="https://www.linuxcapable.com/install-otter-browser-on-fedora-linux/"><span class="rpwwt-post-title">How to Install Otter on Fedora 37/36</span></a></li>
		<li class="fedora-release"><a href="https://www.linuxcapable.com/install-mirage-on-fedora-linux/"><span class="rpwwt-post-title">How to Install Mirage on Fedora 37/36</span></a></li>
		<li class="ubuntu-release"><a href="https://www.linuxcapable.com/install-postgresql-15-on-ubuntu/"><span class="rpwwt-post-title">How to Install PostgreSQL 15 on Ubuntu 22.04 | 20.04</span></a></li>
		<li class="centos-stream-release"><a href="https://www.linuxcapable.com/install-linux-kernel-mainline-on-centos-stream/"><span class="rpwwt-post-title">How to Install Linux Kernel 6.0 on CentOS 9 | CentOS 8 Stream</span></a></li>
		<li class="pop_os-release"><a href="https://www.linuxcapable.com/install-google-chrome-on-pop-os/"><span class="rpwwt-post-title">2 Ways to Install Google Chrome on Pop!_OS 22.04 | 20.04</span></a></li>
		<li class="ubuntu-release"><a href="https://www.linuxcapable.com/install-seamonkey-on-ubuntu/"><span class="rpwwt-post-title">How to Install SeaMonkey on Ubuntu 22.10 | 22.04 | 20.04</span></a></li>
		<li class="pop_os-release"><a href="https://www.linuxcapable.com/install-wine-winehq-on-pop_os/"><span class="rpwwt-post-title">How to Install Wine (WineHQ) on Pop!_OS 22.04 | 20.04</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside><aside id="ai_widget-50" class="widget inner-padding ai_widget"><div class='code-block code-block-1 code-block-sticky-ad' style='margin: 0px auto; text-align: center; display: block; clear: both; min-height: 600px;'>
<div id="sticky-right-main"></div>

<script>
window['nitroAds'].createAd('sticky-right-main', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "160",
      "600"
    ],
    [
      "336",
      "280"
    ],
    [
      "300",
      "600"
    ],
    [
      "300",
      "250"
    ]
  ],
  "mediaQuery": "(min-width: 1825px)"
});
</script>

<div id="sticky-right-small"></div>

<script>
window['nitroAds'].createAd('sticky-right-small', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "renderVisibleOnly": true,
  "refreshVisibleOnly": true,
  "sizes": [
    [
      "300",
      "250"
    ],
    [
      "336",
      "280"
    ]
  ],
  "mediaQuery": "(min-width: 1024px) and (max-width: 1824px)"
});
</script></div>
</aside>	</div>
</div>

	</div>
</div>


<div class="site-footer grid-container footer-bar-active footer-bar-align-center">
			<footer class="site-info" aria-label="Site">
			<div class="inside-site-info grid-container">
						<div class="footer-bar">
			<aside id="nav_menu-1" class="widget inner-padding widget_nav_menu"><div class="menu-footer-bar-marketer-container"><ul id="menu-footer-bar-marketer" class="menu"><li id="menu-item-17884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17884"><a href="https://www.linuxcapable.com/contact-us/">Contact Us</a></li>
<li id="menu-item-21407" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21407"><a href="https://www.linuxcapable.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-21398" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21398"><a href="https://www.linuxcapable.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-16597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-16597"><a href="https://www.linuxcapable.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-16599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16599"><a href="https://www.linuxcapable.com/terms-and-conditions/">Terms Of Use</a></li>
</ul></div></aside>		</div>
						<div class="copyright-bar">
					&copy; 2021 - 2022 LinuxCapable all rights reserved.<br>
<b><span data-ccpa-link="1"></span></b>				</div>
			</div>
		</footer>
		</div>

<div class="ai-delayed ai-delayed-5" data-delay="4500" data-block="5" data-code="PGRpdiBpZD0idmlkZW8tYWRzIj48L2Rpdj4KCjxzY3JpcHQ+CndpbmRvd1snbml0cm9BZHMnXS5jcmVhdGVBZCgndmlkZW8tYWRzJywgewogICJmb3JtYXQiOiAidmlkZW8tbmMiLAogICJ2aWRlbyI6IHsKICAgICJmbG9hdCI6ICJhbHdheXMiLAogICAgIm1vYmlsZSI6ICJjb21wYWN0IiwKICAgICJpbnRlcnZhbCI6IDEwCiAgfQp9KTsKPC9zY3JpcHQ+" data-class="Y29kZS1ibG9jaw=="></div>
<script>
window['nitroAds'].createAd('interstitial', {
  "format": "interstitial"
});
</script>

<script>
window['nitroAds'].createAd('anchor-ads', {
  "refreshLimit": 10,
  "refreshTime": 30,
  "format": "anchor",
  "anchor": "bottom",
  "anchorPersistClose": false,
  "mediaQuery": "(min-width: 1025px), (min-width: 768px) and (max-width: 1024px), (min-width: 320px) and (max-width: 767px)"
});
</script><a href='javascript:void(0);' id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><script id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><link rel='stylesheet' id='cfturnstile-css-css' href='https://www.linuxcapable.com/wp-content/plugins/simple-cloudflare-turnstile/css/cfturnstile.css?ver=1.1' media='all' />
<script src='https://www.linuxcapable.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=2.2.0' id='generate-sticky-js'></script>
<script id='mkaz-code-syntax-prism-js-js-extra'>
var prism_settings = {"pluginUrl":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/code-syntax-block\/"};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism/prism.js?ver=1656119066' id='mkaz-code-syntax-prism-js-js'></script>
<script id='contact-form-7-js-extra'>
var wpcf7 = {"api":{"root":"https:\/\/www.linuxcapable.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js?ver=7.5' id='wpdiscuz-cookie-js-js'></script>
<script id='quill-js-before'>
        var wpdiscuzEditorOptions = {
        modules: {
        toolbar: "",
        counter: {
        uniqueID: "",
        commentmaxcount : 0,
        replymaxcount : 0,
        commentmincount : 1,
        replymincount : 1,
        },
                },
        wc_be_the_first_text: "Be the First to Comment!",
        wc_comment_join_text: "Join the discussion",
        theme: 'snow',
        debug: 'warn'
        };
        
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.js?ver=1.3.6' id='quill-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpd-editor.js?ver=1.3.6' id='wpd-editor-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=1.3.6' id='autogrowtextarea-js-js'></script>
<script id='wpdiscuz-ajax-js-js-extra'>
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"600","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"1","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"16e85469d57b903c13feeeabe1c8326a","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"collapsed","enableDropAnimation":"1","isNativeAjaxEnabled":"0","enableBubble":"0","bubbleLiveUpdate":"0","bubbleHintTimeout":"300","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"0","bubbleLocation":"content_left","firstLoadWithAjax":"2","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"6LcsvXMiAAAAACSeTY164PWSkZUJkc9LG42Guzdq","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"10485760","wmuPostMaxSize":"209715200","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 10MB","wmuPhrasePostMaxSize":"Maximum post size is 200MB","wmuPhraseDoingUpload":"Uploading in progress! Please wait.","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.5","wc_post_id":"21152","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/www.linuxcapable.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/www.linuxcapable.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"f10840cf44","validateNonceForGuests":""};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.js?ver=7.5' id='wpdiscuz-ajax-js-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/jquery.colorbox.js?ver=7.5' id='wmu-colorbox-js-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-mu-frontend.js?ver=7.5' id='wpdiscuz-mu-js-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.js?ver=7.5' id='wpdiscuz-lity-js-js'></script>
<script id='wpdiscuz-user-content-js-js-extra'>
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.js?ver=7.5' id='wpdiscuz-user-content-js-js'></script>
<!--[if lte IE 11]>
<script src='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.2.1' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.2.1' id='generate-menu-js'></script>
<script id='generate-navigation-search-js-extra'>
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=3.2.1' id='generate-navigation-search-js'></script>
<script src='https://www.linuxcapable.com/wp-includes/js/comment-reply.min.js?ver=6.1' id='comment-reply-js'></script>
<script id='q2w3_fixed_widget-js-extra'>
var q2w3_sidebar_options = [{"sidebar":"sidebar-1","use_sticky_position":true,"margin_top":0,"margin_bottom":0,"stop_elements_selectors":"","screen_max_width":768,"screen_max_height":0,"widgets":["#ai_widget-50"]}];
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/q2w3-fixed-widget/js/frontend.min.js?ver=6.2.0' id='q2w3_fixed_widget-js'></script>
<script id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://www.linuxcapable.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.43' id='heateor_sss_sharing_js-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/simple-cloudflare-turnstile/js/cfturnstile.js?ver=2.10' id='cfturnstile-js-js'></script>
<script src='https://challenges.cloudflare.com/turnstile/v0/api.js?onload=onloadTurnstileCallback' id='cfturnstile-js'></script>
<script>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</script>

        
</body>
</html>
