<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-AU" prefix="og: https://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.linuxcapable.com/xmlrpc.php" />
<link rel='preload' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/font/fontawesome-webfont.woff2' as='font' type='font/woff2' crossorigin>
<link rel='preload' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/font/jegicon.woff' as='font' type='font/woff' crossorigin>
<link rel='preload' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=10.0.3' as='style' crossorigin onload="this.rel='stylesheet';this.removeAttribute('onload');">
<link rel='preload' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=10.0.3' as='script' crossorigin>
<link rel='preload' href='https://www.linuxcapable.com/wp-content/plugins/elementor/assets/lib/font-awesome/fonts/fontawesome-webfont.woff2?v=4.7.0' as='font' crossorigin>
<link rel='preconnect' href='https://pagead2.googlesyndication.com' crossorigin>
<link rel='preconnect' href='https://tpc.googlesyndication.com' crossorigin>
<link rel='preconnect' href='https://www.googletagmanager.com' crossorigin>
<link rel='preconnect' href='https://googleads.g.doubleclick.net' crossorigin>
<link rel='preconnect' href='https://www.google-analytics.com' crossorigin>
<link rel='preconnect' href='https://static.cloudflareinsights.com' crossorigin>
<link rel='preconnect' href='https://stats.g.doubleclick.net' crossorigin>
<link rel='preconnect' href='https://www.google.com' crossorigin>
<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
<script type="text/javascript">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</script>

<title>How to Install XanMod Linux Kernel on Debian 11 Bullseye - LinuxCapable</title>
<meta name="description" content="XanMod is a free, open-source general-purpose Linux Kernel alternative to the stock kernel with Debian 11 Bullseye. It features custom settings and new" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install XanMod Linux Kernel on Debian 11 Bullseye - LinuxCapable" />
<meta property="og:description" content="XanMod is a free, open-source general-purpose Linux Kernel alternative to the stock kernel with Debian 11 Bullseye. It features custom settings and new" />
<meta property="og:url" content="https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/" />
<meta property="og:site_name" content="LinuxCapable" />
<meta property="article:publisher" content="https://www.linuxcapable.com/linuxcapable" />
<meta property="article:tag" content="Debian 11 Bullseye" />
<meta property="article:tag" content="Linux Kernel" />
<meta property="article:tag" content="XanMod" />
<meta property="article:section" content="Debian" />
<meta property="og:updated_time" content="2021-11-16T16:22:02+08:00" />
<meta property="og:image" content="https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-768x432.png" />
<meta property="og:image:secure_url" content="https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-768x432.png" />
<meta property="og:image:width" content="768" />
<meta property="og:image:height" content="432" />
<meta property="og:image:alt" content="Install XanMod Debian 11" />
<meta property="og:image:type" content="image/png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to Install XanMod Linux Kernel on Debian 11 Bullseye - LinuxCapable" />
<meta name="twitter:description" content="XanMod is a free, open-source general-purpose Linux Kernel alternative to the stock kernel with Debian 11 Bullseye. It features custom settings and new" />
<meta name="twitter:site" content="@linuxcapable" />
<meta name="twitter:creator" content="@LinuxCapable" />
<meta name="twitter:image" content="https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-768x432.png" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.linuxcapable.com/#organization","name":"LinuxCapable.com","logo":{"@type":"ImageObject","@id":"https://www.linuxcapable.com/#logo","url":"https://www.linuxcapable.com/wp-content/uploads/2021/07/linuxcapable.webp","caption":"LinuxCapable.com","inLanguage":"en-AU"}},{"@type":"WebSite","@id":"https://www.linuxcapable.com/#website","url":"https://www.linuxcapable.com","name":"LinuxCapable.com","publisher":{"@id":"https://www.linuxcapable.com/#organization"},"inLanguage":"en-AU"},{"@type":"ImageObject","@id":"https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11.png","url":"https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11.png","width":"2240","height":"1260","caption":"Install XanMod Debian 11","inLanguage":"en-AU"},{"@type":"BreadcrumbList","@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.linuxcapable.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.linuxcapable.com/distro-tutorials/debian/","name":"Debian"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/","name":"How to Install XanMod Linux Kernel on Debian 11 Bullseye"}}]},{"@type":"Person","@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#author","name":"Joshua James","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/95d766cbde8b7da9dc0ca224f93b988b?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/95d766cbde8b7da9dc0ca224f93b988b?s=96&amp;r=g","caption":"Joshua James","inLanguage":"en-AU"},"sameAs":["https://www.linuxcapable.com","https://twitter.com/LinuxCapable"],"worksFor":{"@id":"https://www.linuxcapable.com/#organization"}},{"@type":"WebPage","@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#webpage","url":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/","name":"How to Install XanMod Linux Kernel on Debian 11 Bullseye - LinuxCapable","datePublished":"2021-11-16T11:51:47+08:00","dateModified":"2021-11-16T16:22:02+08:00","author":{"@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#author"},"isPartOf":{"@id":"https://www.linuxcapable.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11.png"},"inLanguage":"en-AU","breadcrumb":{"@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#breadcrumb"}},{"@type":"BlogPosting","headline":"How to Install XanMod Linux Kernel on Debian 11 Bullseye - LinuxCapable","keywords":"XanMod","datePublished":"2021-11-16T11:51:47+08:00","dateModified":"2021-11-16T16:22:02+08:00","author":{"@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#author"},"publisher":{"@id":"https://www.linuxcapable.com/#organization"},"description":"XanMod is a free, open-source general-purpose Linux Kernel alternative to the stock kernel with Debian 11 Bullseye. It features custom settings and new","name":"How to Install XanMod Linux Kernel on Debian 11 Bullseye - LinuxCapable","@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#richSnippet","isPartOf":{"@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#webpage"},"image":{"@id":"https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11.png"},"inLanguage":"en-AU","mainEntityOfPage":{"@id":"https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxCapable &raquo; Feed" href="https://www.linuxcapable.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxCapable &raquo; Comments Feed" href="https://www.linuxcapable.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxCapable &raquo; How to Install XanMod Linux Kernel on Debian 11 Bullseye Comments Feed" href="https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/feed/" />
<script id="linux-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.linuxcapable.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='mkaz-code-syntax-prism-css-css' href='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism-a11y-dark.css?ver=1635732604' type='text/css' media='all' />
<link rel='stylesheet' id='copy-the-code-css' href='https://www.linuxcapable.com/wp-content/plugins/copy-the-code/assets/css/copy-the-code.css?ver=2.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='lbwps-styles-css' href='https://www.linuxcapable.com/wp-content/plugins/lightbox-photoswipe/assets/styles/default.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='toc-screen-css' href='https://www.linuxcapable.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=2106' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-frontend-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/themes/default/style.css?ver=7.3.7' type='text/css' media='all' />
<style id='wpdiscuz-frontend-css-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpdiscuz-fa-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css?ver=7.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='quill-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.snow.min.css?ver=1.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='wmu-colorbox-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/colorbox.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-mu-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-mu-frontend.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-user-content-css-css' href='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.min.css?ver=7.3.7' type='text/css' media='all' />
<style id="jeg_customizer_font-css" media="all">@font-face {
  font-family: 'Source Sans Pro';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/sourcesanspro/v18/6xK3dSBYKcSV-LCoeQqfX1RYOo3qOK7g.ttf) format('truetype');
}
@font-face {
  font-family: 'Source Sans Pro';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/sourcesanspro/v18/6xKydSBYKcSV-LCoeQqfX1RYOo3ig4vwlxdr.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='jnews-frontend-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=10.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-elementor-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/css/elementor-frontend.css?ver=10.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/style.css?ver=10.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/data/import/tutorial/scheme.css?ver=10.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css' href='https://www.linuxcapable.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/uploads/790/847/public/assets/js/177.js?ver=1.30.2' id='advanced-ads-advanced-js-js'></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-201586352-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.linuxcapable.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-201586352-1", {"anonymize_ip":true});
gtag("config", "G-3QMFH07WVP");
</script>

<link rel="alternate" type="application/json+oembed" href="https://www.linuxcapable.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxcapable.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.45.0" /><style type="text/css">div#toc_container {width: 100%;}div#toc_container ul li {font-size: 100%;}</style><script>document.createElement( "picture" );if(!window.HTMLPictureElement && document.addEventListener) {window.addEventListener("DOMContentLoaded", function() {var s = document.createElement("script");s.src = "https://www.linuxcapable.com/wp-content/plugins/webp-express/js/picturefill.min.js";document.body.appendChild(s);});}</script><style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
<script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">

<style>ins.adsbygoogle { background-color: transparent; padding: 0; }</style><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-270x270.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style> <style type="text/css" id="wp-custom-css">
			/** Menu **/
.jeg_main_menu > li > a {
	text-transform: none;
	font-weight: 600;
	font-size: 16px;
}

.jeg_postblock_36 .jeg_post_category a {
    padding : 7px 6px 7px 7px;
}

.jeg_mobile_menu li a:hover {
	color : #f1f7ed;
}

.jeg_postblock_23 .jeg_post_title {
	font-size : 24px;
}

.jeg_sidebar .jeg_meta_views {
display:none;
}

.jnews_related_post_container .jeg_meta_views {
display:none !important;
}		</style>
</head>
<body class="post-template-default single single-post postid-16235 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal elementor-default elementor-kit-3206 aa-prefix-linux-">
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper  '></div> </div>

<div class="jeg_viewport">
<div class="jeg_header_wrapper">
<div class="jeg_header_instagram_wrapper">
</div>

<div class="jeg_header normal">
<div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_shadow jeg_navbar_fitwidth jeg_navbar_dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class="site-title">
<a href="https://www.linuxcapable.com/" style="padding: 0 0 0 0;">
LinuxCapable </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animate"><li id="menu-item-11960" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-11960 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/">Distro Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-10902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10902 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/almalinux/">AlmaLinux</a></li>
<li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9010 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/debian/">Debian</a></li>
<li id="menu-item-9745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9745 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/fedora/">Fedora</a></li>
<li id="menu-item-9012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9012 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/linux-mint/">Linux Mint</a></li>
<li id="menu-item-13276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13276 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/opensuse/">openSUSE</a></li>
<li id="menu-item-12611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12611 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/pop_os/">Pop!_OS</a></li>
<li id="menu-item-9014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9014 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
<li id="menu-item-9015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9015 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li id="menu-item-13028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13028 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/">General Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-11979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11979 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/commands-tips/">Commands/Tips</a></li>
<li id="menu-item-13030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13030 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/cms-tutorials/">CMS Tutorials</a></li>
<li id="menu-item-14538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14538 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/server-tutorials/">Server Tutorials</a></li>
</ul>
</li>
<li id="menu-item-14352" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14352 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com">Latest Tutorials</a></li>
<li id="menu-item-16000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16000 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/monthly-most-popular/">Monthly Most Popular</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item socials_widget jeg_social_icon_block nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>

<div class="jeg_nav_item jeg_nav_search">
<div class="jeg_search_wrapper jeg_search_no_expand rounded">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div> </div>
</div> </div>
</div>
</div>
</div>
</div></div> </div>
<div class="jeg_header_sticky">
<div class="sticky_blankspace"></div>
<div class="jeg_header normal">
<div class="jeg_container">
<div data-mode="fixed" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_shadow jeg_navbar_dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo">
<div class="site-title">
 <a href="https://www.linuxcapable.com/">
LinuxCapable </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animate"><li id="menu-item-11960" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-11960 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/">Distro Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-10902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10902 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/almalinux/">AlmaLinux</a></li>
<li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9010 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/debian/">Debian</a></li>
<li id="menu-item-9745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9745 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/fedora/">Fedora</a></li>
<li id="menu-item-9012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9012 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/linux-mint/">Linux Mint</a></li>
<li id="menu-item-13276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13276 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/opensuse/">openSUSE</a></li>
<li id="menu-item-12611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12611 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/pop_os/">Pop!_OS</a></li>
<li id="menu-item-9014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9014 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
<li id="menu-item-9015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9015 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/distro-tutorials/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li id="menu-item-13028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13028 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/">General Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-11979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11979 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/commands-tips/">Commands/Tips</a></li>
<li id="menu-item-13030" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13030 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/cms-tutorials/">CMS Tutorials</a></li>
<li id="menu-item-14538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14538 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/general-tutorials/server-tutorials/">Server Tutorials</a></li>
</ul>
</li>
<li id="menu-item-14352" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14352 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com">Latest Tutorials</a></li>
<li id="menu-item-16000" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16000 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/monthly-most-popular/">Monthly Most Popular</a></li>
</ul></div></div>
</div>
</div>

<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item socials_widget jeg_social_icon_block nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div> </div>
</div>
</div>
</div>
<div class="jeg_navbar_mobile_wrapper">
<div class="jeg_navbar_mobile" data-mode="scroll">
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_mobile_logo">
<div class="site-title">
<a href="https://www.linuxcapable.com/">
LinuxCapable </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div> </div>
<div class="post-wrapper">
<div class="post-wrap">
<div class="jeg_main ">
<div class="jeg_container">
<div class="jeg_content jeg_singlepage">
<div class="container">
<div class="jeg_ad jeg_article jnews_article_top_ads">
<div class='ads-wrapper  '></div> </div>
<div class="row">
<div class="jeg_main_content col-md-8">
<div class="jeg_inner_content">
<div class="jeg_breadcrumbs jeg_breadcrumb_container">
<div id="breadcrumbs"><span class="">
<a href="https://www.linuxcapable.com">Home</a>
</span><i class="fa fa-angle-right"></i><span class="">
<a href="https://www.linuxcapable.com/distro-tutorials/">Distro Tutorials</a>
</span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
<a href="https://www.linuxcapable.com/distro-tutorials/debian/">Debian</a>
</span></div> </div>
<div class="entry-header">
<h1 class="jeg_post_title">How to Install XanMod Linux Kernel on Debian 11 Bullseye</h1>
<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">
<div class="meta_left">
<div class="jeg_meta_author">
<span class="meta_text">by</span>
<a href="https://www.linuxcapable.com/author/josh/">Joshua James</a> </div>
<div class="jeg_meta_date">
<a href="https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/">November 16, 2021</a>
</div>
<div class="jeg_meta_category">
<span><span class="meta_text">in</span>
<a href="https://www.linuxcapable.com/distro-tutorials/debian/" rel="category tag">Debian</a> </span>
</div>
<div class="jeg_meta_reading_time">
<span>
Reading Time: 10 mins read
</span>
</div> </div>
<div class="meta_right">
<div class="jeg_meta_zoom" data-in-step="4" data-out-step="3">
<div class="zoom-dropdown">
<div class="zoom-icon">
<span class="zoom-icon-small">A</span>
<span class="zoom-icon-big">A</span>
</div>
<div class="zoom-item-wrapper">
<div class="zoom-item">
<button class="zoom-out"><span>A</span></button>
<button class="zoom-in"><span>A</span></button>
<div class="zoom-bar-container">
<div class="zoom-bar"></div>
</div>
<button class="zoom-reset"><span>Reset</span></button>
</div>
</div>
</div>
</div> <div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/#comments"><i class="fa fa-comment-o"></i> 0</a></div>
</div>
</div>
</div>
</div>
<div class="jeg_featured featured_image"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11.png" data-lbwps-width="2240" data-lbwps-height="1260"><div class="thumbnail-container" style="padding-bottom:50%"><picture><source srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/Install-XanMod-Debian-11-750x375.png.webp 750w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/Install-XanMod-Debian-11-360x180.png.webp 360w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/Install-XanMod-Debian-11-1140x570.png.webp 1140w" sizes="(max-width: 750px) 100vw, 750px" type="image/webp"><img width="750" height="375" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-750x375.png" class="attachment-jnews-750x375 size-jnews-750x375 wp-post-image webpexpress-processed" alt="Install XanMod Debian 11" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11-1140x570.png 1140w" sizes="(max-width: 750px) 100vw, 750px" title="How to Install XanMod Linux Kernel on Debian 11 Bullseye 1"></picture></div></a></div>
<div class="jeg_share_top_container"><div class="jeg_share_button clearfix">
<div class="jeg_share_stats">
<div class="jeg_views_count">
<div class="counts">45</div>
<span class="sharetext">VIEWS</span>
</div>
</div>
<div class="jeg_sharelist">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Facebook</span></a><a href="https://twitter.com/intent/tweet?text=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye%20via%20%40LinuxCapable&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Twitter</span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&title=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-reddit expanded"><i class="fa fa-reddit"></i><span>Reddit</span></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&media=https://www.linuxcapable.com/wp-content/uploads/2021/11/Install-XanMod-Debian-11.png&description=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-pinterest expanded"><i class="fa fa-pinterest"></i><span>Pinterest</span></a><a href="https://telegram.me/share/url?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&text=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-telegram expanded"><i class="fa fa-telegram"></i><span>Telegram</span></a><a href="https://www.tumblr.com/widgets/share/tool?canonicalUrl=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&title=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-tumbrl expanded"><i class="fa fa-tumblr"></i><span>Tumblr</span></a>
<div class="share-secondary">
<a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&title=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://telegram.me/share/url?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&text=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-telegram "><i class="fa fa-telegram"></i></a><a href="https://chart.googleapis.com/chart?chs=400x400&cht=qr&choe=UTF-8&chl=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-wechat "><i class="fa fa-wechat"></i></a><a href="/cdn-cgi/l/email-protection#f8c78b8d9a929d9b8cc5b0978fddcac88c97ddcac8b1968b8c999494ddcac8a09996b5979cddcac8b491968d80ddcac8b39d8a969d94ddcac89796ddcac8bc9d9a919996ddcac8c9c9ddcac8ba8d94948b9d819dde999588c39a979c81c5908c8c888bddcbb9ddcabeddcabe8f8f8fd69491968d809b9988999a949dd69b9795ddcabe90978fd58c97d591968b8c999494d580999695979cd59491968d80d5939d8a969d94d59796d59c9d9a919996d5c9c9d59a8d94948b9d819dddcabe" rel='nofollow' class="jeg_btn-email "><i class="fa fa-envelope"></i></a><a href="https://vk.com/share.php?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-vk "><i class="fa fa-vk"></i></a><a href="http://b.hatena.ne.jp/bookmarklet?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F&btitle=How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye" rel='nofollow' class="jeg_btn-hatena "><i class="fa fa-hatena"></i></a>
</div>
<a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
<div class="entry-content no-share">
<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
<div class="jeg_share_float_container"></div> </div>
<div class="content-inner ">
<p><strong><a href="https://xanmod.org/" target="_blank" rel="noreferrer noopener">XanMod</a></strong> is a free, open-source general-purpose Linux Kernel alternative to the stock kernel with Debian 11 Bullseye. It features custom settings and new features and is built to provide a responsive and smooth desktop experience, especially for new hardware. XanMod is popular amongst Linux Gaming, streaming, and ultra-low latency requirements and often boasts the latest Linux Kernels, having multiple branches to choose from the stable, edge, and development.</p>
<p>For users seeking to have their Debian 11 Bullseye system kernel up to date and not wanting to manually install kernels or use the testing/unstable repositories, installing a third-party kernel that may be for you.</p>
<p>In the following tutorial, you will learn <strong>how to import the XanMod repository and install the latest Linux Kernel on your Debian 11 Bullseye.</strong></p>
<div id="toc_container" class="no_bullets"><p class="toc_title">Table of Contents</p><ul class="toc_list"><li><a href="#Prerequisites"><span class="toc_number toc_depth_1">1</span> Prerequisites</a><ul><li><a href="#Update_Operating_System"><span class="toc_number toc_depth_2">1.1</span> Update Operating System</a></li></ul></li><li><a href="#Import_the_XanMod_Repository"><span class="toc_number toc_depth_1">2</span> Import the XanMod Repository</a></li><li><a href="#Install_XanMod_Linux_Kernel"><span class="toc_number toc_depth_1">3</span> Install XanMod Linux Kernel</a></li><li><a href="#How_to_Update_XanMod_Linux_Kernel"><span class="toc_number toc_depth_1">4</span> How to Update XanMod Linux Kernel</a></li><li><a href="#How_to_Remove_Uninstall_XanMod_Linux_Kernel"><span class="toc_number toc_depth_1">5</span> How to Remove (Uninstall) XanMod Linux Kernel</a></li><li><a href="#Comments_and_Conclusion"><span class="toc_number toc_depth_1">6</span> Comments and Conclusion</a></li></ul></div>
<h2 id="prerequisites"><span id="Prerequisites"><span class="has-inline-color has-vivid-purple-color">Prerequisites</span></span></h2>
<ul><li><strong>Recommended OS:</strong>&nbsp;<a href="https://www.linuxcapable.com/how-to-upgrade-debian-10-buster-to-debian-11-bullseye/">Debian 11 Bullseye</a></li><li><strong>User account:</strong>&nbsp;A user account with&nbsp;sudo or root access.</li></ul>
<h3><span id="Update_Operating_System">Update Operating System</span></h3>
<p>Update your&nbsp;<strong>Debian</strong>&nbsp;operating system to make sure all existing packages are up to date:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update &amp;&amp; sudo apt upgrade -y</code></pre>
<p>The tutorial will be using the<strong>&nbsp;sudo command</strong>&nbsp;and&nbsp;<strong>assuming you have sudo status</strong>.</p>
<p>To verify sudo status on your account:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo whoami</code></pre>
<p><em>Example output showing sudo status:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">[<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="0862677b607d69486c6d6a616966">[email&#160;protected]</a>~]$ sudo whoami
root</code></pre>
<p>To set up an existing or new sudo account, visit our tutorial on&nbsp;<a href="https://www.linuxcapable.com/how-to-add-a-user-to-sudoers-on-debian/" target="_blank" rel="noreferrer noopener"><strong>Adding a User to Sudoers on Debian</strong>.</a></p>
<p>To use the&nbsp;<strong>root account</strong>, use the following command with the root password to log in.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">su</code></pre>
<p>The tutorial will be utilizing the terminal, and for those unfamiliar, this can be found in your show applications menu.</p>
<p><em>Example:</em></p>
<div class="wp-block-image"><figure class="aligncenter"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/11/terminal-for-debian-11-bullseye.png" data-lbwps-width="392" data-lbwps-height="222"><picture><source srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/terminal-for-debian-11-bullseye.png.webp" type="image/webp"><img loading="lazy" width="392" height="222" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/terminal-for-debian-11-bullseye.png" alt="How to Install XanMod Linux Kernel on Debian 11 Bullseye" class="wp-image-15955 webpexpress-processed" title="How to Install Spotify on Debian 11 Bullseye 2"></picture></a></figure></div>
<p><a href="https://www.linuxcapable.com/wp-content/uploads/2021/11/terminal-for-debian-11-bullseye.png" data-lbwps-width="392" data-lbwps-height="222"></a></p>
<div class="linux-content" id="linux-1523651030"><div class="jeg_block_heading jeg_block_heading_6 jnews_617de8f6c0f1a"><b class="jeg_block_title"><span>Advertisement</span></b></div>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="5637155356" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><h2><span id="Import_the_XanMod_Repository"><span class="has-inline-color has-vivid-purple-color">Import the XanMod Repository</span></span></h2>
<p>The first task is to import the XanMod repository. This can be done in several ways, but the tutorial will use the apt package manager&#8217;s terminal to keep things simple.</p>
<p>First, import the repository using the following command.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">echo 'deb http://deb.xanmod.org releases main' | sudo tee /etc/apt/sources.list.d/xanmod-kernel.list</code></pre>
<p>Verify the command worked using the grep command.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">grep xanmod /etc/apt/sources.list.d/xanmod-kernel.list</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">deb http://deb.xanmod.org releases main</code></pre>
<p>With the repository successfully imported, the next task is to import the GPG key using the following command.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">wget -qO - https://dl.xanmod.org/gpg.key | sudo apt-key --keyring /etc/apt/trusted.gpg.d/xanmod-kernel.gpg add -</code></pre>
<p><em>Example output if successful:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">OK</code></pre>
<p>Next, update your APT repository source listing to reflect the new addition.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update</code></pre>
<h2><span id="Install_XanMod_Linux_Kernel"><span class="has-inline-color has-vivid-purple-color">Install XanMod Linux Kernel</span></span></h2>
<p>With the XanMod repository installed and up to date, you can install the Linux kernel from XanMod. </p>
<p>As mentioned n the start of the tutorial, there are three branches to choose from. At the time of the tutorial, the stable has version 5.14, the edge has the latest stable 5.15, and development has the latest unstable in development Linux Kernel 5.15 kernel.</p>
<p>The tutorial will go over installing all three, but it&#8217;s recommended to stick to stable and edge, do not use development unless you know what you are doing.</p>
<p><strong><em><span class="has-inline-color has-vivid-purple-color">To install XanMod stable:</span></em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install linux-xanmod</code></pre>
<p><strong><em><span class="has-inline-color has-vivid-purple-color">To install XanMod edge:</span></em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install linux-xanmod-edge</code></pre>
<p><strong><em><span class="has-inline-color has-vivid-purple-color">To install XanMod development:</span></em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install linux-xanmod-tt</code></pre>
<p><em>Example output from (edge):</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/11/install-xanmod-edge-on-debian-11-bullseye.png" data-lbwps-width="786" data-lbwps-height="353"><picture><source srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/install-xanmod-edge-on-debian-11-bullseye.png.webp 786w" sizes="(max-width: 786px) 100vw, 786px" type="image/webp"><img loading="lazy" width="786" height="353" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/install-xanmod-edge-on-debian-11-bullseye.png" alt="How to Install XanMod Linux Kernel on Debian 11 Bullseye" class="wp-image-16237 webpexpress-processed" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/install-xanmod-edge-on-debian-11-bullseye.png 786w, https://www.linuxcapable.com/wp-content/uploads/2021/11/install-xanmod-edge-on-debian-11-bullseye-768x345.png 768w, https://www.linuxcapable.com/wp-content/uploads/2021/11/install-xanmod-edge-on-debian-11-bullseye-750x337.png 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install XanMod Linux Kernel on Debian 11 Bullseye 2"></picture></a></figure></div>
<p><strong>Type Y,</strong> then press the <strong>ENTER KEY</strong> to proceed with the installation.</p>
<p>Once the chosen repository Linux kernel has been installed, you will need to reboot your system to complete the installation.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">reboot</code></pre>
<p>Once you have returned to your system, verify the installation. </p>
<p>At the time of the tutorial, the edge branch contained Linux kernel 5.15.2.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">hostnamectl</code></pre>
<p>Or you can use the cat version command.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">cat /proc/version</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/11/cat-command-and-hostnamectl-command-xanmod-5.15-debian-11-bullseye.png" data-lbwps-width="786" data-lbwps-height="389"><picture><source srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/cat-command-and-hostnamectl-command-xanmod-5.15-debian-11-bullseye.png.webp 786w" sizes="(max-width: 786px) 100vw, 786px" type="image/webp"><img loading="lazy" width="786" height="389" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/cat-command-and-hostnamectl-command-xanmod-5.15-debian-11-bullseye.png" alt="How to Install XanMod Linux Kernel on Debian 11 Bullseye" class="wp-image-16210 webpexpress-processed" title="How to Install Linux Kernel 5.15 on Debian 11 Bullseye 8" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/cat-command-and-hostnamectl-command-xanmod-5.15-debian-11-bullseye.png 786w, https://www.linuxcapable.com/wp-content/uploads/2021/11/cat-command-and-hostnamectl-command-xanmod-5.15-debian-11-bullseye-768x380.png 768w, https://www.linuxcapable.com/wp-content/uploads/2021/11/cat-command-and-hostnamectl-command-xanmod-5.15-debian-11-bullseye-750x371.png 750w" sizes="(max-width: 786px) 100vw, 786px"></picture></a></figure></div>
<div class="linux-content" id="linux-1422392924"><div class="jeg_block_heading jeg_block_heading_6 jnews_617de8f6c0f1a"><b class="jeg_block_title"><span>Advertisement</span></b></div>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="5637155356" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><h2><span id="How_to_Update_XanMod_Linux_Kernel"><span class="has-inline-color has-vivid-purple-color">How to Update XanMod Linux Kernel</span></span></h2>
<p>To keep the Linux kernel you installed with XanMod up to date, you will run the standard apt update and upgrade commands if you installed XanMod using APT, which the tutorial has shown.</p>
<p>To check for updates.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update</code></pre>
<p>If an upgrade is available.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt upgrade</code></pre>
<p>Alternatively, users on stable can upgrade to edge by using the installation command. Ideally, do not swap too frequently. This can cause issues.</p>
<h2><span id="How_to_Remove_Uninstall_XanMod_Linux_Kernel"><span class="has-inline-color has-vivid-purple-color">How to Remove (Uninstall) XanMod Linux Kernel</span></span></h2>
<p>To remove XanMod, use the following command.</p>
<p><strong><em><span class="has-inline-color has-vivid-purple-color">To install XanMod stable:</span></em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt remove linux-xanmod --purge</code></pre>
<p><strong><em><span class="has-inline-color has-vivid-purple-color">To install XanMod edge:</span></em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt remove linux-xanmod-edge --purge</code></pre>
<p><strong><em><span class="has-inline-color has-vivid-purple-color">To install XanMod development:</span></em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt remove linux-xanmod-tt --purge</code></pre>
<p>This will entirely remove all traces of XanMod possible and unused dependencies.</p>
<p>Ideally, you can remove the repository as well.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo rm /etc/apt/sources.list.d/xanmod-kernel.list</code></pre>
<p>Alternatively, you may need to remove the Liquorix with the following command.</p>
<p>Note, you will need to use the exact name of the Linux image and header package. This can be found by using the following command.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">dpkg --list | grep `uname -r`</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/11/dkpg-command-xanmod-debian-11-bullseye.png" data-lbwps-width="786" data-lbwps-height="191"><img loading="lazy" width="786" height="191" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/dkpg-command-xanmod-debian-11-bullseye.png" alt="How to Install XanMod Linux Kernel on Debian 11 Bullseye" class="wp-image-16285" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/dkpg-command-xanmod-debian-11-bullseye.png 786w, https://www.linuxcapable.com/wp-content/uploads/2021/11/dkpg-command-xanmod-debian-11-bullseye-768x187.png 768w, https://www.linuxcapable.com/wp-content/uploads/2021/11/dkpg-command-xanmod-debian-11-bullseye-750x182.png 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install XanMod Linux Kernel on Debian 11 Bullseye 3"></a></figure></div>
<p>The names shown in the output are the ones you need to remove that involve the Liqourix Kernel.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt-get remove linux-headers-5.15.2-xanmod1 linux-image-5.15.2-xanmod1 --purge</code></pre>
<p>Alternatively, the following command without the version number <strong>may work</strong>, this is universal. If this doesn&#8217;t work, use the above.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt-get remove linux-headers-xanmod1 linux-image-xanmod1 --purge</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><picture><source srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/remove-rest-of-xanmod-kernel-debian-11-bullseye.png.webp 786w" sizes="(max-width: 786px) 100vw, 786px" type="image/webp"><img loading="lazy" width="786" height="353" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/remove-rest-of-xanmod-kernel-debian-11-bullseye.png" alt="How to Install XanMod Linux Kernel on Debian 11 Bullseye" class="wp-image-16286 webpexpress-processed" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/remove-rest-of-xanmod-kernel-debian-11-bullseye.png 786w, https://www.linuxcapable.com/wp-content/uploads/2021/11/remove-rest-of-xanmod-kernel-debian-11-bullseye-768x345.png 768w, https://www.linuxcapable.com/wp-content/uploads/2021/11/remove-rest-of-xanmod-kernel-debian-11-bullseye-750x337.png 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install XanMod Linux Kernel on Debian 11 Bullseye 4"></picture></figure></div>
<p>Warning, run the following command to make sure you have an existing Linux Kernel installed.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install linux-image-amd64</code></pre>
<p>By default, the Debian 11 Bullseye default kernel should be installed.</p>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">linux-image-amd64 is already the newest version (5.10.70-1).</code></pre>
<p><strong><span class="has-inline-color has-vivid-red-color">Failure to do this will result in your system being unbootable and will create a headache.</span></strong></p>
<p>Next, update-grub.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo update-grub2</code></pre>
<p>Now restart your PC to finalize the removal of Liquorix.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo reboot</code></pre>
<p>Once you have returned to your system, verify the installation.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">hostnamectl</code></pre>
<p>Or you can use the cat version command.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">cat /proc/version</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><picture><source srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/uploads/2021/11/xanmod-rolled-back-to-default-debian-bullseye-kernel.png.webp 786w" sizes="(max-width: 786px) 100vw, 786px" type="image/webp"><img loading="lazy" width="786" height="389" src="https://www.linuxcapable.com/wp-content/uploads/2021/11/xanmod-rolled-back-to-default-debian-bullseye-kernel.png" alt="How to Install XanMod Linux Kernel on Debian 11 Bullseye" class="wp-image-16287 webpexpress-processed" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/xanmod-rolled-back-to-default-debian-bullseye-kernel.png 786w, https://www.linuxcapable.com/wp-content/uploads/2021/11/xanmod-rolled-back-to-default-debian-bullseye-kernel-768x380.png 768w, https://www.linuxcapable.com/wp-content/uploads/2021/11/xanmod-rolled-back-to-default-debian-bullseye-kernel-750x371.png 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install XanMod Linux Kernel on Debian 11 Bullseye 5"></picture></figure></div>
<p>As the above output has shown, you have rolled back to the default Linux kernel that Debian 11 Bullseye has, thus successfully removing XanMod from your system.</p>
<div class="linux-content" id="linux-1367293977"><div class="jeg_block_heading jeg_block_heading_6 jnews_617de8f6c0f1a"><b class="jeg_block_title"><span>Advertisement</span></b></div>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="5637155356" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><h2><span id="Comments_and_Conclusion"><span class="has-inline-color has-vivid-purple-color">Comments and Conclusion</span></span></h2>
<p>In the tutorial, you have learned how to install XanMod on Debian 11 Bullseye. XanMod is designed for desktop users with the latest hardware, but this can be installed on any Debian desktop or server. However, it&#8217;s advised to research before upgrading, and it is ill-advised to use it on critical or production-type systems.</p>
<p>One of the best features of using XanMod is that when the next Linux Kernel comes around, it is included on development/edge very quickly. Hence, it is worth the look, especially if you are into Linux gaming.</p>
<div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.linuxcapable.com/tag/debian-11-bullseye/" rel="tag">Debian 11 Bullseye</a><a href="https://www.linuxcapable.com/tag/linux-kernel/" rel="tag">Linux Kernel</a><a href="https://www.linuxcapable.com/tag/xanmod/" rel="tag">XanMod</a></div>
</div>
</div>
<div class="jeg_share_bottom_container"></div>
<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container "></div><div class="jnews_related_post_container"></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"> <div class="wpdiscuz_top_clearing"></div>
<div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div> <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpdiscuz_no_avatar wpd-layout-2 wpd-comments-open">
<div class="wc_social_plugin_wrapper">
</div>
<div class="wpd-form-wrap">
<div class="wpd-form-head">
<div class="wpd-sbs-toggle">
<i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
</div>
<div class="wpd-auth">
<div class="wpd-login">
</div>
</div>
</div>
<div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
<form action="https://www.linuxcapable.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
<div class="wpdiscuz-subscribe-form-intro">Notify of </div>
<div class="wpdiscuz-subscribe-form-option" style="width:40%;">
<select class="wpdiscuz_select" name="wpdiscuzSubscriptionType">
<option value="post">new follow-up comments</option>
<option value="all_comment">new replies to my comments</option>
</select>
</div>
<div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
<input class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email" />
</div>
<div class="wpdiscuz-subscribe-form-button">
<input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
</div>
<input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="4cadca3dc3" /><input type="hidden" name="_wp_http_referer" value="/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye/" /> </form>
</div>
<div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'>
<form class="wpd_comm_form wpd_main_comm_form" method="post" enctype="multipart/form-data">
<div class="wpd-field-comment">
<div class="wpdiscuz-item wc-field-textarea">
<div class="wpdiscuz-textarea-wrap ">
<div id="wpd-editor-wraper-0_0" style="display: none;">
<div id="wpd-editor-char-counter-0_0" class="wpd-editor-char-counter"></div>
<label style="display: none;" for="wc-textarea-0_0">Label</label>
<textarea id="wc-textarea-0_0" required name="wc_comment" class="wc_comment wpd-field"></textarea>
<div id="wpd-editor-0_0"></div>
<div id="wpd-editor-toolbar-0_0">
<button title="Bold" class="ql-bold"></button>
<button title="Italic" class="ql-italic"></button>
<button title="Underline" class="ql-underline"></button>
<button title="Strike" class="ql-strike"></button>
<button title="Ordered List" class="ql-list" value='ordered'></button>
<button title="Unordered List" class="ql-list" value='bullet'></button>
<button title="Blockquote" class="ql-blockquote"></button>
<button title="Code Block" class="ql-code-block"></button>
<button title="Link" class="ql-link"></button>
<button title="Source Code" class="ql-sourcecode" data-wpde_button_name='sourcecode'>{}</button>
<button title="Spoiler" class="ql-spoiler" data-wpde_button_name='spoiler'>[+]</button>
<div class="wpd-editor-buttons-right">
<span class='wmu-upload-wrap' wpd-tooltip='Attach an image to this comment' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]' accept='image/*' /></label></span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="wpd-form-foot" style='display:none;'>
<div class="wpdiscuz-textarea-foot">
<div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div>
</div>
<div class="wpd-form-row">
<div class="wpd-form-col-left">
<div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
<div class="wpd-field-icon"><i class="fas fa-user"></i></div>
<input id="wc_name-0_0" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
<label for="wc_name-0_0" class="wpdlb">Name*</label>
</div>
<div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
<div class="wpd-field-icon"><i class="fas fa-at"></i></div>
<input id="wc_email-0_0" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
<label for="wc_email-0_0" class="wpdlb">Email*</label>
</div>
<div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
<div class="wpd-field-icon"><i class="fas fa-link"></i></div>
<input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
<label for="wc_website-0_0" class="wpdlb">Website</label>
</div>
</div>
<div class="wpd-form-col-right">
<div class="wc-field-submit">
<label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
<input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" checked='checked' />
<span class="wpd_label__text">
<span class="wpd_label__check">
<i class="fas fa-bell wpdicon wpdicon-on"></i>
<i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
</span>
</span>
</label>
<input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
</div>
</div>
<div class="clearfix"></div>
</div>
</div>
<input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id">
</form>
</div>
<div id="wpdiscuz_hidden_secondary_form" style="display: none;">
<div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
<div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div>
<form class="wpd_comm_form wpd-secondary-form-wrapper" method="post" enctype="multipart/form-data">
<div class="wpd-field-comment">
<div class="wpdiscuz-item wc-field-textarea">
<div class="wpdiscuz-textarea-wrap ">
<div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;">
<div id="wpd-editor-char-counter-wpdiscuzuniqueid" class="wpd-editor-char-counter"></div>
<label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label>
<textarea id="wc-textarea-wpdiscuzuniqueid" required name="wc_comment" class="wc_comment wpd-field"></textarea>
<div id="wpd-editor-wpdiscuzuniqueid"></div>
<div id="wpd-editor-toolbar-wpdiscuzuniqueid">
<button title="Bold" class="ql-bold"></button>
<button title="Italic" class="ql-italic"></button>
<button title="Underline" class="ql-underline"></button>
<button title="Strike" class="ql-strike"></button>
<button title="Ordered List" class="ql-list" value='ordered'></button>
<button title="Unordered List" class="ql-list" value='bullet'></button>
<button title="Blockquote" class="ql-blockquote"></button>
<button title="Code Block" class="ql-code-block"></button>
<button title="Link" class="ql-link"></button>
<button title="Source Code" class="ql-sourcecode" data-wpde_button_name='sourcecode'>{}</button>
<button title="Spoiler" class="ql-spoiler" data-wpde_button_name='spoiler'>[+]</button>
<div class="wpd-editor-buttons-right">
<span class='wmu-upload-wrap' wpd-tooltip='Attach an image to this comment' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]' accept='image/*' /></label></span> </div>
</div>
</div>
</div>
</div>
</div>
<div class="wpd-form-foot" style='display:none;'>
<div class="wpdiscuz-textarea-foot">
<div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div>
</div>
<div class="wpd-form-row">
<div class="wpd-form-col-left">
<div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
<div class="wpd-field-icon"><i class="fas fa-user"></i></div>
<input id="wc_name-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
<label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label>
</div>
<div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
<div class="wpd-field-icon"><i class="fas fa-at"></i></div>
<input id="wc_email-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
<label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email*</label>
</div>
<div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
<div class="wpd-field-icon"><i class="fas fa-link"></i></div>
<input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
<label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label>
</div>
</div>
<div class="wpd-form-col-right">
<div class="wc-field-submit">
<label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
<input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" checked='checked' />
<span class="wpd_label__text">
<span class="wpd_label__check">
<i class="fas fa-bell wpdicon wpdicon-on"></i>
<i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
</span>
</span>
</label>
<input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
</div>
</div>
<div class="clearfix"></div>
</div>
</div>
<input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id">
</form>
</div>
</div>
</div>
<div id="wpd-threads" class="wpd-thread-wrapper">
<div class="wpd-thread-head">
<div class="wpd-thread-info " data-comments-count="0">
<span class='wpdtc' title='0'>0</span> Comments </div>
<div class="wpd-space"></div>
<div class="wpd-thread-filter">
<div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
<div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
</div>
</div>
<div class="wpd-comment-info-bar">
<div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
<div class="wpd-filter-view-all">View all comments</div>
</div>
<div class="wpd-thread-list">
<div class="wpdiscuz-comment-pagination">
</div>
</div>
</div>
</div>
</div>
<div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
<div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
</div>
</div>
</div>
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
<div class="widget linux-widget"><div class="jeg_block_heading jeg_block_heading_6 jnews_617de8f6c0f1a"><b class="jeg_block_title"><span>Advertisement</span></b></div>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="7665742260" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="widget widget_jnews_module_block_25" id="jnews_module_block_25-5"><div class="jeg_postblock_25 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_16235_0_619500f0d7952  normal " data-unique="jnews_module_16235_0_619500f0d7952">
<div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
<h3 class="jeg_block_title"><span>You might also like</span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts jeg_load_more_flag"><article class="jeg_post format-standard">
<div class="jeg_postblock_heading">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-download-install-fedora-35-gnome-41-from-usb-bootable-disk/">How to Download &#038; Install Fedora 35 &#038; GNOME 41 from USB Bootable Disk</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-download-install-fedora-35-gnome-41-from-usb-bootable-disk/"><i class="fa fa-clock-o"></i> October 22, 2021 - Updated on November 3, 2021</a></div><div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-download-install-fedora-35-gnome-41-from-usb-bootable-disk/#comments"><i class="fa fa-comment-o"></i> 0 </a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-download-install-fedora-35-gnome-41-from-usb-bootable-disk/"><i class="fa fa-eye"></i> 675 </a></div></div>
</div>
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-download-install-fedora-35-gnome-41-from-usb-bootable-disk/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="How to Download &#038; Install Fedora 35 &#038; GNOME 41 from USB Bootable Disk" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Download-Install-Fedora-35-GNOME-41-from-USB-Bootable-Disk-360x180.png" data-srcset="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Download-Install-Fedora-35-GNOME-41-from-USB-Bootable-Disk-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Download-Install-Fedora-35-GNOME-41-from-USB-Bootable-Disk-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Download-Install-Fedora-35-GNOME-41-from-USB-Bootable-Disk-1140x570.png 1140w" data-sizes="auto" data-expand="700" title="How to Download &amp; Install Fedora 35 &amp; GNOME 41 from USB Bootable Disk 6"></div></a>
</div>
<div class="jeg_postblock_content">
<div class="jeg_post_excerpt">
<p>Fedora 35 has brought with it many improvements over its predecessor with GNOME 41, Linux Kernel 5.14, and a range...</p>
<a href="https://www.linuxcapable.com/how-to-download-install-fedora-35-gnome-41-from-usb-bootable-disk/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post format-standard">
<div class="jeg_postblock_heading">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-configure-git-on-almalinux-8/">How to Install &#038; Configure Git on AlmaLinux 8</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-configure-git-on-almalinux-8/"><i class="fa fa-clock-o"></i> October 21, 2021</a></div><div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-configure-git-on-almalinux-8/#comments"><i class="fa fa-comment-o"></i> 0 </a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-configure-git-on-almalinux-8/"><i class="fa fa-eye"></i> 206 </a></div></div>
</div>
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-configure-git-on-almalinux-8/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="How to Install &amp; Configure Git on AlmaLinux 8" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-Configure-Git-on-AlmaLinux-8-360x180.png" data-srcset="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-Configure-Git-on-AlmaLinux-8-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-Configure-Git-on-AlmaLinux-8-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-Configure-Git-on-AlmaLinux-8-1140x570.png 1140w" data-sizes="auto" data-expand="700" title="How to Install &amp; Configure Git on AlmaLinux 8 7"></div></a>
</div>
<div class="jeg_postblock_content">
<div class="jeg_post_excerpt">
<p>Git&nbsp;is a mature, actively maintained open source project initially developed in 2005 by Linus Torvalds, the famous Linux operating system...</p>
<a href="https://www.linuxcapable.com/how-to-install-configure-git-on-almalinux-8/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post format-standard">
<div class="jeg_postblock_heading">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-firefox-next-beta-or-firefox-quantum-nightly-on-ubuntu-desktop/">How to Install Firefox Next (Beta) or Firefox Quantum (Nightly) on Ubuntu Desktop</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-firefox-next-beta-or-firefox-quantum-nightly-on-ubuntu-desktop/"><i class="fa fa-clock-o"></i> November 6, 2021</a></div><div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-firefox-next-beta-or-firefox-quantum-nightly-on-ubuntu-desktop/#comments"><i class="fa fa-comment-o"></i> 0 </a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-firefox-next-beta-or-firefox-quantum-nightly-on-ubuntu-desktop/"><i class="fa fa-eye"></i> 98 </a></div></div>
</div>
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-firefox-next-beta-or-firefox-quantum-nightly-on-ubuntu-desktop/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="How to Install Firefox Next (Beta) or Firefox Quantum (Nightly) on Ubuntu Desktop" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-Firefox-Next-Beta-or-Firefox-Quantum-Nightly-on-Ubuntu-Desktop-360x180.png" data-srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-Firefox-Next-Beta-or-Firefox-Quantum-Nightly-on-Ubuntu-Desktop-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-Firefox-Next-Beta-or-Firefox-Quantum-Nightly-on-Ubuntu-Desktop-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-Firefox-Next-Beta-or-Firefox-Quantum-Nightly-on-Ubuntu-Desktop-1140x570.png 1140w" data-sizes="auto" data-expand="700" title="How to Install Firefox Next (Beta) or Firefox Quantum (Nightly) on Ubuntu Desktop 8"></div></a>
</div>
<div class="jeg_postblock_content">
<div class="jeg_post_excerpt">
<p>Mozilla Firefox is a free and open-source web browser developed by the Mozilla Foundation. Firefox utilizes the Gecko rendering engine...</p>
<a href="https://www.linuxcapable.com/how-to-install-firefox-next-beta-or-firefox-quantum-nightly-on-ubuntu-desktop/" class="jeg_readmore">Read more</a>
</div>
</div>
</article></div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_16235_0_619500f0d7952 = {"header_icon":"","first_title":"You might also like","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":"0","unique_content":"unique1","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"random_month","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"20","excerpt_ellipsis":"...","force_normal_image_load":"1","pagination_mode":"disable","pagination_nextprev_showtext":"0","pagination_number_post":"3","pagination_scroll_limit":"0","ads_type":"disable","ads_position":"1","ads_random":"0","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"0","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"0","boxed":"0","boxed_shadow":"0","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_25"};</script>
</div></div><div class="widget linux-widget"><div class="jeg_block_heading jeg_block_heading_6 jnews_617de8f6c0f1a"><b class="jeg_block_title"><span>Advertisement</span></b></div>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="3753228044" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="widget widget_jnews_module_block_25" id="jnews_module_block_25-4"><div class="jeg_postblock_25 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_16235_1_619500f0db244  normal " data-unique="jnews_module_16235_1_619500f0db244">
<div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
<h3 class="jeg_block_title"><span>Trending Tutorials</span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts jeg_load_more_flag"><article class="jeg_post format-standard">
<div class="jeg_postblock_heading">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/">How to Install the Latest Nvidia Graphic Drivers on Fedora 35 &#038; Gnome 41</a>
</h3>
 <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/"><i class="fa fa-clock-o"></i> October 10, 2021 - Updated on November 4, 2021</a></div><div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/#comments"><i class="fa fa-comment-o"></i> 7 </a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/"><i class="fa fa-eye"></i> 8.9k </a></div></div>
</div>
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="How to Install or Upgrade Nvidia Graphic Drivers on Fedora 35 &amp; Gnome 41" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Fedora-35-Gnome-41-360x180.png" data-srcset="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Fedora-35-Gnome-41-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Fedora-35-Gnome-41-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Fedora-35-Gnome-41-1140x570.png 1140w" data-sizes="auto" data-expand="700" title="How to Install the Latest Nvidia Graphic Drivers on Fedora 35 &amp; Gnome 41 9"></div></a>
</div>
<div class="jeg_postblock_content">
<div class="jeg_post_excerpt">
<p>Most modern Linux Desktop systems such as&nbsp;Fedora&nbsp;come with an&nbsp;Nvidia driver&nbsp;pre-installed in the&nbsp;Nouveau&nbsp;open-source graphics device driver for Nvidia video cards. For...</p>
<a href="https://www.linuxcapable.com/how-to-install-the-latest-nvidia-graphic-drivers-on-fedora-35-gnome-41/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post format-standard">
<div class="jeg_postblock_heading">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-or-upgrade-nvidia-drivers-on-debian-11-bullseye/">How to Install or Upgrade Nvidia Drivers on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-or-upgrade-nvidia-drivers-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> October 3, 2021 - Updated on November 9, 2021</a></div><div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-or-upgrade-nvidia-drivers-on-debian-11-bullseye/#comments"><i class="fa fa-comment-o"></i> 12 </a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-or-upgrade-nvidia-drivers-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 9.8k </a></div></div>
</div>
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-or-upgrade-nvidia-drivers-on-debian-11-bullseye/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="How to Install or Upgrade Nvidia Graphic Drivers on Debian 11 Bullseye" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Debian-11-Bullseye-360x180.png" data-srcset="https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Debian-11-Bullseye-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Debian-11-Bullseye-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/10/How-to-Install-or-Upgrade-Nvidia-Graphic-Drivers-on-Debian-11-Bullseye-1140x570.png 1140w" data-sizes="auto" data-expand="700" title="How to Install or Upgrade Nvidia Drivers on Debian 11 Bullseye 10"></div></a>
</div>
<div class="jeg_postblock_content">
<div class="jeg_post_excerpt">
<p>Most modern Linux Desktop systems such as&nbsp;Debian&nbsp;come with an&nbsp;Nvidia driver&nbsp;pre-installed in the&nbsp;Nouveau&nbsp;open-source graphics device driver for Nvidia video cards. For...</p>
<a href="https://www.linuxcapable.com/how-to-install-or-upgrade-nvidia-drivers-on-debian-11-bullseye/" class="jeg_readmore">Read more</a>
</div>
</div>
</article><article class="jeg_post format-standard">
<div class="jeg_postblock_heading">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-gnome-41-desktop-on-ubuntu-20-04/">How to Install GNOME 41 Desktop on Ubuntu 20.04</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-gnome-41-desktop-on-ubuntu-20-04/"><i class="fa fa-clock-o"></i> November 2, 2021</a></div><div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-gnome-41-desktop-on-ubuntu-20-04/#comments"><i class="fa fa-comment-o"></i> 3 </a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-gnome-41-desktop-on-ubuntu-20-04/"><i class="fa fa-eye"></i> 3.6k </a></div></div>
</div>
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-gnome-41-desktop-on-ubuntu-20-04/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="How to Install GNOME 41 Desktop on Ubuntu 20.04 LTS" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-GNOME-41-Desktop-on-Ubuntu-20.04-LTS-360x180.png" data-srcset="https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-GNOME-41-Desktop-on-Ubuntu-20.04-LTS-360x180.png 360w, https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-GNOME-41-Desktop-on-Ubuntu-20.04-LTS-750x375.png 750w, https://www.linuxcapable.com/wp-content/uploads/2021/11/How-to-Install-GNOME-41-Desktop-on-Ubuntu-20.04-LTS-1140x570.png 1140w" data-sizes="auto" data-expand="700" title="How to Install GNOME 41 Desktop on Ubuntu 20.04 11"></div></a>
</div>
<div class="jeg_postblock_content">
 <div class="jeg_post_excerpt">
<p>GNOME 41 introduces many changes from visual changes, new apps, and overhaul back-end changes to improve performance. Overall, it is...</p>
<a href="https://www.linuxcapable.com/how-to-install-gnome-41-desktop-on-ubuntu-20-04/" class="jeg_readmore">Read more</a>
</div>
</div>
</article></div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_16235_1_619500f0db244 = {"header_icon":"","first_title":"Trending Tutorials","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":"0","unique_content":"unique1","include_post":"","exclude_post":"14594,14634,15761","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"popular_post_week","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"20","excerpt_ellipsis":"...","force_normal_image_load":"1","pagination_mode":"disable","pagination_nextprev_showtext":"0","pagination_number_post":"3","pagination_scroll_limit":"0","ads_type":"disable","ads_position":"1","ads_random":"0","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"0","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"0","boxed":"0","boxed_shadow":"0","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_25"};</script>
</div></div><div class="widget linux-widget"><div class="jeg_block_heading jeg_block_heading_6 jnews_617de8f6c0f1a"><b class="jeg_block_title"><span>Advertisement</span></b></div>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="8355991492" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="widget linux-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7703471362501005" data-ad-slot="5131658824" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> </div>
<div class="jeg_ad jeg_article jnews_article_bottom_ads">
<div class='ads-wrapper  '></div> </div>
</div>
</div>
</div>
</div>
<div id="post-body-class" class="post-template-default single single-post postid-16235 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal elementor-default elementor-kit-3206 aa-prefix-linux-"></div>
</div>
<div class="post-ajax-overlay">
<div class="preloader_type preloader_dot">
<div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="newsfeed_preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="newsfeed_preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="footer-holder" id="footer" data-id="footer">
<div class="jeg_footer jeg_footer_4 dark">
<div class="jeg_footer_container jeg_container">
<div class="jeg_footer_content">
<div class="container">
<div class="row">
<div class="jeg_footer_primary clearfix">
<div class="col-md-9 footer_column">
<ul class="jeg_menu_footer"><li id="menu-item-11239" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11239"><a href="https://www.linuxcapable.com/about-linuxcapable/">About LinuxCapable</a></li>
<li id="menu-item-15945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15945"><a href="https://www.linuxcapable.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16001" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16001"><a target="_blank" rel="noopener" href="https://www.buymeacoffee.com/linuxcapable">Donate</a></li>
<li id="menu-item-8989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-8989"><a href="https://www.linuxcapable.com/privacy-policy-statement/">Privacy Policy Statement</a></li>
<li id="menu-item-8991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8991"><a href="https://www.linuxcapable.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul> </div>
<div class="col-md-3 footer_column footer_right">
<div class="footer-text">
</div>
</div>
</div>
<div class="jeg_footer_secondary clearfix">
<div class="col-md-9 footer_column">
<p class="copyright"> © 2021 <a href="https://www.linuxcapable.com" title="LinuxCapable - Linux Articles, Guides and Tutorials">LinuxCapable</a> all rights reserved.<br>
All logos, trademarks and registered trademarks are the property of their respective owners.<BR>
This website is for educational purposes only. No warranty or compensation is given for any loss of data or hardware. </p>
</div>
<div class="col-md-3 footer_column footer_right">
<div class="jeg_social_icon_block socials_widget nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
</div>
 </div>

<div id="jeg_off_canvas" class="dark">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
<div class="jeg_bg_overlay"></div>
<div class="jeg_mobile_wrapper">
<div class="nav_wrap">
<div class="item_main">

<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand rounded">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_aside_item">
<ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-11960"><a href="https://www.linuxcapable.com/distro-tutorials/">Distro Tutorials</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10902"><a href="https://www.linuxcapable.com/distro-tutorials/almalinux/">AlmaLinux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9010"><a href="https://www.linuxcapable.com/distro-tutorials/debian/">Debian</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9745"><a href="https://www.linuxcapable.com/distro-tutorials/fedora/">Fedora</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9012"><a href="https://www.linuxcapable.com/distro-tutorials/linux-mint/">Linux Mint</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13276"><a href="https://www.linuxcapable.com/distro-tutorials/opensuse/">openSUSE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12611"><a href="https://www.linuxcapable.com/distro-tutorials/pop_os/">Pop!_OS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9014"><a href="https://www.linuxcapable.com/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9015"><a href="https://www.linuxcapable.com/distro-tutorials/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13028"><a href="https://www.linuxcapable.com/general-tutorials/">General Tutorials</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11979"><a href="https://www.linuxcapable.com/general-tutorials/commands-tips/">Commands/Tips</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13030"><a href="https://www.linuxcapable.com/general-tutorials/cms-tutorials/">CMS Tutorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14538"><a href="https://www.linuxcapable.com/general-tutorials/server-tutorials/">Server Tutorials</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-14352"><a href="https://www.linuxcapable.com">Latest Tutorials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16000"><a href="https://www.linuxcapable.com/monthly-most-popular/">Monthly Most Popular</a></li>
</ul></div> </div>
<div class="item_bottom">
<div class="jeg_aside_item jeg_aside_copyright">
<p>© 2021 <a href="https://www.linuxcapable.com" title="LinuxCapable - Linux Articles, Guides and Tutorials">LinuxCapable</a> all rights reserved.<br>
All logos, trademarks and registered trademarks are the property of their respective owners.<BR>
This website is for educational purposes only. No warranty or compensation is given for any loss of data or hardware.</p>
</div><div class="jeg_aside_item socials_widget nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a></div> </div>
</div> </div>
</div><script type="text/javascript">var jfla = ["view_counter"]</script><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
<div class="pswp__bg"></div>
<div class="pswp__scroll-wrap">
<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>
<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">
<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>
<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip">
</div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"></button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"></button>
<div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div><a href='javascript:void(0);' id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><div id='wpd-bubble-wrapper'><span id='wpd-bubble-all-comments-count' style='display:none;' title='0'>0</span><div id='wpd-bubble-count'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-count-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z' /><path class='wpd-bubble-count-second' d='M0 0h24v24H0z' /></svg><span class='wpd-new-comments-count'>0</span></div><div id='wpd-bubble'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-plus-first' d='M19 13h-6v6h-2v-6H5v-2h6V5h2v6h6v2z' /><path class='wpd-bubble-plus-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-add-message'>Would love your thoughts, please comment.<span id='wpd-bubble-add-message-close'><a href='#'>x</a></span></div></div><div id='wpd-bubble-notification'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-notification-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z' /><path class='wpd-bubble-notification-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-notification-message'><div id='wpd-bubble-author'><div><span id='wpd-bubble-author-avatar'></span><span id='wpd-bubble-author-name'></span><span id='wpd-bubble-comment-date'>(<span class='wpd-bubble-spans'></span>)</span></div><span id='wpd-bubble-comment-close'><a href='#'>x</a></span></div><div id='wpd-bubble-comment'><span id='wpd-bubble-comment-text'></span><span id='wpd-bubble-comment-reply-link'>| <a href='#'>Reply</a></span></div></div></div></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><div id="selectShareContainer">
<div class="selectShare-inner">
<div class="select_share jeg_share_button">
<button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" data-image-url="" data-title="How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye"><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-xanmod-linux-kernel-on-debian-11-bullseye%2F" data-image-url="" data-title="How%20to%20Install%20XanMod%20Linux%20Kernel%20on%20Debian%2011%20Bullseye%20via%20%40LinuxCapable"><i class="fa fa-twitter"></i></a>
</div>
<div class="selectShare-arrowClip">
<div class="selectShare-arrow"></div>
</div>
</div>
</div><div class="jnews-cookie-law-policy">This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="https://www.linuxcapable.com/privacy-policy-statement/">Privacy and Cookie Policy</a>. <button data-expire="30" class="btn btn-cookie">I Agree</button></div><div class="jeg_read_progress_wrapper"><div class="jeg_progress_container bottom"><span class="progress-bar"></span></div></div><script type='text/javascript' id='mkaz-code-syntax-prism-js-js-extra'>
/* <![CDATA[ */
var prism_settings = {"pluginUrl":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/code-syntax-block\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism/prism.js?ver=1635732604' id='mkaz-code-syntax-prism-js-js'></script>
<script type='text/javascript' id='copy-the-code-js-extra'>
/* <![CDATA[ */
var copyTheCode = {"copy_content_as":"","previewMarkup":"<h2>Hello World<\/h2>","buttonMarkup":"<button class=\"copy-the-code-button\" title=\"\"><\/button>","buttonSvg":"<svg viewBox=\"-21 0 512 512\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\"><path d=\"m186.667969 416c-49.984375 0-90.667969-40.683594-90.667969-90.667969v-218.664062h-37.332031c-32.363281 0-58.667969 26.300781-58.667969 58.664062v288c0 32.363281 26.304688 58.667969 58.667969 58.667969h266.664062c32.363281 0 58.667969-26.304688 58.667969-58.667969v-37.332031zm0 0\"><\/path><path d=\"m469.332031 58.667969c0-32.40625-26.261719-58.667969-58.664062-58.667969h-224c-32.40625 0-58.667969 26.261719-58.667969 58.667969v266.664062c0 32.40625 26.261719 58.667969 58.667969 58.667969h224c32.402343 0 58.664062-26.261719 58.664062-58.667969zm0 0\"><\/path><\/svg>","selectors":[{"selector":"pre","style":"svg-icon","button_text":"Copy","button_title":"Copy to Clipboard","button_copy_text":"Copied!","button_position":"inside"}],"selector":"pre","settings":{"selector":"pre","button-text":"Copy","button-title":"Copy to Clipboard","button-copy-text":"Copied!","button-position":"inside"},"string":{"title":"Copy to Clipboard","copy":"Copy","copied":"Copied!"},"image-url":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/copy-the-code\/\/assets\/images\/copy-1.svg"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/copy-the-code/assets/js/copy-the-code.js?ver=2.2.2' id='copy-the-code-js'></script>
<script type='text/javascript' id='lbwps-js-extra'>
/* <![CDATA[ */
var lbwpsOptions = {"label_facebook":"Share on Facebook","label_twitter":"Tweet","label_pinterest":"Pin it","label_download":"Download image","label_copyurl":"Copy image URL","share_facebook":"1","share_twitter":"1","share_pinterest":"1","share_download":"1","share_direct":"0","share_copyurl":"0","share_custom_label":"","share_custom_link":"","wheelmode":"close","close_on_drag":"1","history":"1","show_counter":"1","show_fullscreen":"1","show_zoom":"1","show_caption":"1","loop":"1","pinchtoclose":"1","taptotoggle":"1","spacing":"12","close_on_click":"1","fulldesktop":"0","use_alt":"0","desktop_slider":"1","idletime":"4000","hide_scrollbars":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/lightbox-photoswipe/assets/scripts.js?ver=3.2.4' id='lbwps-js'></script>
<script type='text/javascript' id='toc-front-js-extra'>
/* <![CDATA[ */
var tocplus = {"smooth_scroll":"1","visibility_show":"show","visibility_hide":"hide","width":"100%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=2106' id='toc-front-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js?ver=7.3.7' id='wpdiscuz-cookie-js-js'></script>
<script type='text/javascript' id='quill-js-before'>
        var wpdiscuzEditorOptions = {
        modules: {
        toolbar: "",
        counter: {
        uniqueID: "",
        commentmaxcount : 0,
        replymaxcount : 0,
        commentmincount : 1,
        replymincount : 1,
        },
		        },
        wc_be_the_first_text: "Be the First to Comment!",
        wc_comment_join_text: "Join the discussion",
        theme: 'snow',
        debug: 'error'
        };
		
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.min.js?ver=1.3.6' id='quill-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpd-editor.min.js?ver=1.3.6' id='wpd-editor-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=1.3.6' id='autogrowtextarea-js-js'></script>
<script type='text/javascript' id='wpdiscuz-ajax-js-js-extra'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"1","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"16e85469d57b903c13feeeabe1c8326a","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"collapsed","enableDropAnimation":"1","isNativeAjaxEnabled":"0","enableBubble":"1","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"content_left","firstLoadWithAjax":"0","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"103809024","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 2MB","wmuPhrasePostMaxSize":"Maximum post size is 99MB","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.3.7","wc_post_id":"16235","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/www.linuxcapable.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/www.linuxcapable.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"dc024f8cd1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.min.js?ver=7.3.7' id='wpdiscuz-ajax-js-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/jquery.colorbox.min.js?ver=7.3.7' id='wmu-colorbox-js-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-mu-frontend.min.js?ver=7.3.7' id='wpdiscuz-mu-js-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.min.js?ver=7.3.7' id='wpdiscuz-lity-js-js'></script>
<script type='text/javascript' id='wpdiscuz-user-content-js-js-extra'>
/* <![CDATA[ */
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.min.js?ver=7.3.7' id='wpdiscuz-user-content-js-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/uploads/790/297/assets/js/604.js?ver=2.14.1' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/www.linuxcapable.com\/how-to-install-xanmod-linux-kernel-on-debian-11-bullseye","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_AU","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"16235","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"www.linuxcapable.com","zoom_button":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=10.0.3' id='jnews-frontend-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=10.0.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' data-cfasync="false" data-no-optimize="1" src='https://www.linuxcapable.com/wp-content/plugins/perfmatters/vendor/instant-page/instantpage.js?ver=1.8.1' id='perfmatters-instant-page-js'></script>
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(e.data.counter,(function(e,n){o[n].length&&t.forEach(o[n],(function(n,o){t.setText(n,e)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6af962422ad87003","token":"788993a4efd34b7dae05c67735826b00","version":"2021.11.0","si":100}' crossorigin="anonymous"></script>
</body>
</html>
