<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-AU" prefix="og: https://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-AU" prefix="og: https://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.linuxcapable.com/xmlrpc.php" />
<link rel='dns-prefetch' href='//www.linuxcapable.com'>
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com'>
<link rel='dns-prefetch' href='//www.googletagmanager.com'>
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net'>
<link rel='dns-prefetch' href='//www.googletagservices.com'>
<link rel='dns-prefetch' href='//tpc.googlesyndication.com'>
<link rel='dns-prefetch' href='//www.clarity.ms'>
<link rel='dns-prefetch' href='//e.clarity.ms'>
<link rel='dns-prefetch' href='//www.google-analytics.com'>
<link rel='dns-prefetch' href='//fonts.googleapis.com'>
<link rel='dns-prefetch' href='//www.gstatic.com'>
<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
<script type="text/javascript">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</script>

<title>How to Install Memcached on Debian 11 Bullseye - LinuxCapable</title>
<meta name="description" content="Memcached&nbsp;is used to speed up dynamic database-driven websites by caching data and objects in RAM. This reduces the number of times an external data" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install Memcached on Debian 11 Bullseye - LinuxCapable" />
<meta property="og:description" content="Memcached&nbsp;is used to speed up dynamic database-driven websites by caching data and objects in RAM. This reduces the number of times an external data" />
<meta property="og:url" content="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/" />
<meta property="og:site_name" content="LinuxCapable" />
<meta property="article:publisher" content="https://www.linuxcapable.com/linuxcapable" />
<meta property="article:tag" content="Cache" />
<meta property="article:tag" content="Debian" />
<meta property="article:tag" content="Debian 11" />
<meta property="article:tag" content="Debian Bullseye" />
<meta property="article:tag" content="Memcached" />
<meta property="article:section" content="Debian" />
<meta property="og:updated_time" content="2021-09-18T10:24:08+08:00" />
<meta property="og:image" content="https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-768x432.png" />
<meta property="og:image:secure_url" content="https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-768x432.png" />
<meta property="og:image:width" content="768" />
<meta property="og:image:height" content="432" />
<meta property="og:image:alt" content="How to Install Memcached on Debian 11 Bullseye" />
<meta property="og:image:type" content="image/png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to Install Memcached on Debian 11 Bullseye - LinuxCapable" />
<meta name="twitter:description" content="Memcached&nbsp;is used to speed up dynamic database-driven websites by caching data and objects in RAM. This reduces the number of times an external data" />
<meta name="twitter:site" content="@linuxcapable" />
<meta name="twitter:creator" content="@linuxcapable" />
<meta name="twitter:image" content="https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-768x432.png" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.linuxcapable.com/#organization","name":"LinuxCapable.com","logo":{"@type":"ImageObject","@id":"https://www.linuxcapable.com/#logo","url":"https://www.linuxcapable.com/wp-content/uploads/2021/07/linuxcapable.webp","caption":"LinuxCapable.com","inLanguage":"en-AU"}},{"@type":"WebSite","@id":"https://www.linuxcapable.com/#website","url":"https://www.linuxcapable.com","name":"LinuxCapable.com","publisher":{"@id":"https://www.linuxcapable.com/#organization"},"inLanguage":"en-AU"},{"@type":"ImageObject","@id":"https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png","url":"https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png","width":"2240","height":"1260","caption":"How to Install Memcached on Debian 11 Bullseye","inLanguage":"en-AU"},{"@type":"BreadcrumbList","@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.linuxcapable.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.linuxcapable.com/category/distro-tutorials/debian/","name":"Debian"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/","name":"How to Install Memcached on Debian 11 Bullseye"}}]},{"@type":"Person","@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#author","name":"Joshua James","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/951485f28d02bbbc21ebd637d12fe2bc?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/951485f28d02bbbc21ebd637d12fe2bc?s=96&amp;r=g","caption":"Joshua James","inLanguage":"en-AU"},"sameAs":["https://www.linuxcapable.com"],"worksFor":{"@id":"https://www.linuxcapable.com/#organization"}},{"@type":"WebPage","@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#webpage","url":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/","name":"How to Install Memcached on Debian 11 Bullseye - LinuxCapable","datePublished":"2021-09-18T10:24:06+08:00","dateModified":"2021-09-18T10:24:08+08:00","author":{"@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#author"},"isPartOf":{"@id":"https://www.linuxcapable.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png"},"inLanguage":"en-AU","breadcrumb":{"@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#breadcrumb"}},{"@type":"BlogPosting","headline":"How to Install Memcached on Debian 11 Bullseye - LinuxCapable","keywords":"Memcached","datePublished":"2021-09-18T10:24:06+08:00","dateModified":"2021-09-18T10:24:08+08:00","author":{"@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#author"},"publisher":{"@id":"https://www.linuxcapable.com/#organization"},"description":"Memcached&nbsp;is used to speed up dynamic database-driven websites by caching data and objects in RAM. This reduces the number of times an external data","name":"How to Install Memcached on Debian 11 Bullseye - LinuxCapable","@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#richSnippet","isPartOf":{"@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#webpage"},"image":{"@id":"https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png"},"inLanguage":"en-AU","mainEntityOfPage":{"@id":"https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxCapable &raquo; Feed" href="https://www.linuxcapable.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxCapable &raquo; Comments Feed" href="https://www.linuxcapable.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxCapable &raquo; How to Install Memcached on Debian 11 Bullseye Comments Feed" href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/feed/" />
<script id="linux-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.linuxcapable.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='mkaz-code-syntax-prism-css-css' href='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism-a11y-dark.css?ver=1631988615' type='text/css' media='all' />
<link rel='stylesheet' id='copy-the-code-css' href='https://www.linuxcapable.com/wp-content/plugins/copy-the-code/assets/css/copy-the-code.css?ver=2.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='toc-screen-css' href='https://www.linuxcapable.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=2106' type='text/css' media='all' />
<style id="jeg_customizer_font-css" media="all">@font-face {
  font-family: 'Source Sans Pro';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/sourcesanspro/v14/6xK3dSBYKcSV-LCoeQqfX1RYOo3qOK7g.ttf) format('truetype');
}
@font-face {
  font-family: 'Source Sans Pro';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/sourcesanspro/v14/6xKydSBYKcSV-LCoeQqfX1RYOo3ig4vwlxdr.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='jnews-frontend-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=9.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-elementor-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/assets/css/elementor-frontend.css?ver=9.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/style.css?ver=9.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css' href='https://www.linuxcapable.com/wp-content/themes/jnews/data/import/tutorial/scheme.css?ver=9.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css' href='https://www.linuxcapable.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.28.0' id='advanced-ads-advanced-js-js' defer></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-201586352-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.linuxcapable.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-201586352-1", {"anonymize_ip":true});
gtag("config", "G-3QMFH07WVP");
</script>

<link rel="alternate" type="application/json+oembed" href="https://www.linuxcapable.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxcapable.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.41.0" /><style type="text/css">div#toc_container {width: 100%;}div#toc_container ul li {font-size: 100%;}</style><style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
<script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/07/cropped-linuxcapable-32x32.webp" sizes="32x32" />
<link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/07/cropped-linuxcapable-192x192.webp" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/07/cropped-linuxcapable-180x180.webp" />
<meta name="msapplication-TileImage" content="https://www.linuxcapable.com/wp-content/uploads/2021/07/cropped-linuxcapable-270x270.webp" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style> <style type="text/css" id="wp-custom-css">
			/** Menu **/
.jeg_main_menu > li > a {
	text-transform: none;
	font-weight: 600;
	font-size: 16px;
}

.jeg_postblock_36 .jeg_post_category a {
    padding : 7px 6px 7px 7px;
}

.jeg_mobile_menu li a:hover {
	color : #f1f7ed;
}

.jeg_postblock_23 .jeg_post_title {
	font-size : 24px;
}		</style>
</head>
<body class="post-template-default single single-post postid-12055 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal elementor-default elementor-kit-3206 aa-prefix-linux-">
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper'></div> </div>

<div class="jeg_viewport">
<div class="jeg_header_wrapper">
<div class="jeg_header_instagram_wrapper">
</div>

<div class="jeg_header normal">
<div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_shadow jeg_navbar_fitwidth jeg_navbar_dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class="site-title">
<a href="https://www.linuxcapable.com/" style="padding: 0 0 0 0;">
LinuxCapable </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animate"><li id="menu-item-11965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-11965 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/cms-tutorials/">CMS Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-11978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11978 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/cms-tutorials/wordpress/">WordPress</a></li>
</ul>
</li>
<li id="menu-item-11979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11979 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/commands-tips/">Commands/Tips</a></li>
<li id="menu-item-11960" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-11960 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/">Distro Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-10902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10902 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/almalinux/">AlmaLinux</a></li>
<li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9010 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/">Debian</a></li>
<li id="menu-item-9745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9745 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/fedora/">Fedora</a></li>
<li id="menu-item-9012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9012 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/linux-mint/">Linux Mint</a></li>
<li id="menu-item-9014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9014 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
<li id="menu-item-9015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9015 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li id="menu-item-11966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11966 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/webserver-tutorials/">Webserver Tutorials</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item socials_widget jeg_social_icon_block nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://linuxcapable.tumblr.com" target='_blank' rel='external noopener nofollow' class="jeg_tumblr"><i class="fa fa-tumblr"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>

<div class="jeg_nav_item jeg_nav_search">
<div class="jeg_search_wrapper jeg_search_no_expand rounded">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div> </div>
</div> </div>
</div>
</div>
</div>
</div></div> </div>
<div class="jeg_header_sticky">
<div class="sticky_blankspace"></div>
<div class="jeg_header normal">
<div class="jeg_container">
<div data-mode="fixed" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_shadow jeg_navbar_dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
</div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
 <div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_logo">
<div class="site-title">
<a href="https://www.linuxcapable.com/">
LinuxCapable </a>
</div>
</div><div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animate"><li id="menu-item-11965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-11965 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/cms-tutorials/">CMS Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-11978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11978 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/cms-tutorials/wordpress/">WordPress</a></li>
</ul>
</li>
<li id="menu-item-11979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11979 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/commands-tips/">Commands/Tips</a></li>
<li id="menu-item-11960" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-11960 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/">Distro Tutorials</a>
<ul class="sub-menu">
<li id="menu-item-10902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10902 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/almalinux/">AlmaLinux</a></li>
<li id="menu-item-9010" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9010 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/">Debian</a></li>
<li id="menu-item-9745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9745 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/fedora/">Fedora</a></li>
<li id="menu-item-9012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9012 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/linux-mint/">Linux Mint</a></li>
<li id="menu-item-9014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9014 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
<li id="menu-item-9015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9015 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/distro-tutorials/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li id="menu-item-11966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11966 bgnav" data-item-row="default"><a href="https://www.linuxcapable.com/category/webserver-tutorials/">Webserver Tutorials</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item socials_widget jeg_social_icon_block nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://linuxcapable.tumblr.com" target='_blank' rel='external noopener nofollow' class="jeg_tumblr"><i class="fa fa-tumblr"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div> </div>
</div>
</div>
</div>
<div class="jeg_navbar_mobile_wrapper">
<div class="jeg_navbar_mobile" data-mode="scroll">
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_mobile_logo">
<div class="site-title">
<a href="https://www.linuxcapable.com/">
LinuxCapable </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div> </div>
<div class="post-wrapper">
<div class="post-wrap">
<div class="jeg_main">
<div class="jeg_container">
<div class="jeg_content jeg_singlepage">
<div class="container">
<div class="jeg_ad jeg_article jnews_article_top_ads">
<div class='ads-wrapper'></div> </div>
<div class="row">
<div class="jeg_main_content col-md-8">
<div class="jeg_inner_content">
<div class="jeg_breadcrumbs jeg_breadcrumb_container">
<div id="breadcrumbs"><span class="">
<a href="https://www.linuxcapable.com">Home</a>
</span><i class="fa fa-angle-right"></i><span class="">
<a href="https://www.linuxcapable.com/category/distro-tutorials/">Distro Tutorials</a>
</span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
<a href="https://www.linuxcapable.com/category/distro-tutorials/debian/">Debian</a>
 </span></div> </div>
<div class="entry-header">
<h1 class="jeg_post_title">How to Install Memcached on Debian 11 Bullseye</h1>
<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">
<div class="meta_left">
<div class="jeg_meta_author">
<span class="meta_text">by</span>
<a href="https://www.linuxcapable.com/author/josh/">Joshua James</a> </div>
<div class="jeg_meta_date">
<a href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/">September 18, 2021</a>
</div>
<div class="jeg_meta_category">
<span><span class="meta_text">in</span>
<a href="https://www.linuxcapable.com/category/distro-tutorials/debian/" rel="category tag">Debian</a> </span>
</div>
<div class="jeg_meta_reading_time">
<span>
Reading Time: 11 mins read
</span>
</div> </div>
<div class="meta_right">
<div class="jeg_meta_comment"><a href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/#comments"><i class="fa fa-comment-o"></i> 0</a></div>
</div>
</div>
</div>
</div>
<div class="jeg_featured featured_image"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png"><div class="thumbnail-container" style="padding-bottom:50%"><img width="750" height="375" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-750x375.png.webp" class="attachment-jnews-750x375 size-jnews-750x375 wp-post-image" alt="How to Install Memcached on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-750x375.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-360x180.png.webp 360w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-1140x570.png.webp 1140w" sizes="(max-width: 750px) 100vw, 750px" title="How to Install Memcached on Debian 11 Bullseye 1"></div></a></div>
<div class="jeg_share_top_container"><div class="jeg_share_button clearfix">
<div class="jeg_share_stats">
<div class="jeg_share_count">
<div class="counts">0</div>
<span class="sharetext">SHARES</span>
</div>
<div class="jeg_views_count">
<div class="counts">34</div>
<span class="sharetext">VIEWS</span>
</div>
</div>
<div class="jeg_sharelist">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=How+to+Install+Memcached+on+Debian+11+Bullseye&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-reddit"><i class="fa fa-reddit"></i></a><a href="https://www.tumblr.com/widgets/share/tool?canonicalUrl=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-tumbrl"><i class="fa fa-tumblr"></i></a>
<div class="share-secondary">
<a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-linkedin"><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&media=https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png&description=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-pinterest"><i class="fa fa-pinterest"></i></a><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-stumbleupon"><i class="fa fa-stumbleupon"></i></a>
</div>
<a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_top_ads"><div class='ads-wrapper'></div></div>
<div class="entry-content no-share">
<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
<div class="jeg_share_float_container"></div> </div>
<div class="content-inner  jeg_link_underline">
<p><a target="_blank" href="https://memcached.org/" rel="noreferrer noopener">Memcached</a>&nbsp;is used to speed up dynamic database-driven websites by caching data and objects in RAM. This reduces the number of times an external data source must be read, which lowers overheads and speeds up response times. The memory caching software is a free, open-source project that anyone can use.</p>
<p>At the end of the guide, you will know <strong>how to install and configure Memcached on your Debian 11 Bullseye</strong> operating system.</p>
<div id="toc_container" class="no_bullets"><p class="toc_title">Table of Contents</p><ul class="toc_list"><li><a href="#Prerequisites"><span class="toc_number toc_depth_1">1</span> Prerequisites</a><ul><li><a href="#Updating_Operating_System"><span class="toc_number toc_depth_2">1.1</span> Updating Operating System</a></li><li><a href="#Root_or_Sudo_Access"><span class="toc_number toc_depth_2">1.2</span> Root or Sudo Access</a></li></ul></li><li><a href="#Install_Memcached"><span class="toc_number toc_depth_1">2</span> Install Memcached</a></li><li><a href="#Configure_Memcached"><span class="toc_number toc_depth_1">3</span> Configure Memcached</a></li><li><a href="#Optional_Allow_Memcached_UFW_Rules"><span class="toc_number toc_depth_1">4</span> Optional – Allow Memcached UFW Rules</a></li><li><a href="#Install_Memcached_PHP_Libraries"><span class="toc_number toc_depth_1">5</span> Install Memcached PHP Libraries</a><ul><li><a href="#Apache_HTTP_Server"><span class="toc_number toc_depth_2">5.1</span> Apache HTTP Server</a></li><li><a href="#Nginx_HTTP_Server"><span class="toc_number toc_depth_2">5.2</span> Nginx HTTP Server</a></li></ul></li><li><a href="#Install_Additional_Libraries"><span class="toc_number toc_depth_1">6</span> Install Additional Libraries</a></li><li><a href="#Accessing_Memcached_from_Command_Line"><span class="toc_number toc_depth_1">7</span> Accessing Memcached from Command Line</a></li><li><a href="#Comments_and_Conclusion"><span class="toc_number toc_depth_1">8</span> Comments and Conclusion</a></li></ul></div>
<h2 id="prerequisites"><span id="Prerequisites"><span class="has-inline-color has-vivid-purple-color">Prerequisites</span></span></h2>
<ul><li><strong>Recommended OS:</strong>&nbsp;<a href="https://www.linuxcapable.com/how-to-upgrade-debian-10-buster-to-debian-11-bullseye/">Debian 11 Bullseye</a></li><li><strong>User account:</strong>&nbsp;A user account with&nbsp;<strong>sudo privilages</strong>&nbsp;or&nbsp;<strong>root access (su command)</strong>.</li></ul>

<h3><span id="Updating_Operating_System">Updating Operating System</span></h3>
<p>Update your&nbsp;<strong>Debian 11</strong>&nbsp;operating system to make sure all existing packages are up to date:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt update &amp;&amp; sudo apt upgrade</code></pre>
<h3><span id="Root_or_Sudo_Access">Root or Sudo Access</span></h3>
<p>By default, when you create your account at startup with Debian compared to other distributions, it does not automatically receive sudoers status. You must either have access to the <strong>root password</strong> to use <strong>the su command</strong> or visit our tutorial on <a href="https://www.linuxcapable.com/how-to-add-a-user-to-sudoers-on-debian/">How to Add a User to Sudoers on Debian</a>.</p>
<h2><span id="Install_Memcached"><span class="has-inline-color has-vivid-purple-color">Install Memcached</span></span></h2>
<p>By default, Debian 11 has Memcached in its repositories. To install Memcached, enter the following command:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install memcached libmemcached-tools</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><img loading="lazy" width="786" height="353" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/install-memcached-on-debian-11.png.webp" alt="How to Install Memcached on Debian 11 Bullseye" class="wp-image-12057" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/install-memcached-on-debian-11.png.webp 786w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/install-memcached-on-debian-11-768x345.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/install-memcached-on-debian-11-750x337.png.webp 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install Memcached on Debian 11 Bullseye 2"></figure></div>
<p>Type <strong>Y,</strong> then press <strong>ENTER KEY</strong> to proceed with the installation.</p>
<p>Note, the second install option, the “<strong>libmemcached-tools</strong>” package, provides additional commands to bring extra interaction and execute abilities to Memcached.</p>
<p>Next, verify Memcached was installed correctly by verifying using the <strong>apt-cache policy command</strong>:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt-cache policy memcached</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><img loading="lazy" width="786" height="263" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/apt-cache-policy-debian-11-memcached.png.webp" alt="How to Install Memcached on Debian 11 Bullseye" class="wp-image-12059" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/apt-cache-policy-debian-11-memcached.png.webp 786w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/apt-cache-policy-debian-11-memcached-768x257.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/apt-cache-policy-debian-11-memcached-750x251.png.webp 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install Memcached on Debian 11 Bullseye 3"></figure></div>
<p>Memcached should be activated by default. To verify this, use the <strong>systemctl status command</strong> as follows:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">systemctl status memcached</code></pre>
<p><em>Example output:</em></p>
<div class="wp-block-image"><figure class="aligncenter size-full"><img loading="lazy" width="786" height="263" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/memcached-systemctl-status-ok-debian-11.png.webp" alt="How to Install Memcached on Debian 11 Bullseye" class="wp-image-12060" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/memcached-systemctl-status-ok-debian-11.png.webp 786w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/memcached-systemctl-status-ok-debian-11-768x257.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/memcached-systemctl-status-ok-debian-11-750x251.png.webp 750w" sizes="(max-width: 786px) 100vw, 786px" title="How to Install Memcached on Debian 11 Bullseye 4"></figure></div>
<p>If the service has not been activated, start Memcached using the following command:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl start memcached</code></pre>
<p><strong>Other useful commands to managing the Memcached service are as follows:</strong></p>
<p><em>To enable the Memcached service on system boot:</em></p><div class="linux-content" id="linux-484585450"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7703471362501005" data-ad-slot="7240151726" data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl enable Memcached</code></pre>
<p><em>To stop the Memcached service:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl stop memcached</code></pre>
<p><em>To disable the Memcached service on system boot:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl disable memcached</code></pre>
<p><em>To restart the Memcached service:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl restart memcached</code></pre>
<p>Next, verify Memcached is actively listening to localhost on the default <strong>port 11211</strong>. To confirm this type, the following:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">ps -ef | grep memcached</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">memcache    5934       1  0 09:36 ?        00:00:00 /usr/bin/memcached -m 64 -p 11211 -u memcache -l 127.0.0.1 -P /var/run/memcached/memcached.pid
root        6591    3653  0 09:55 pts/0    00:00:00 grep memcached</code></pre>
<h2><span id="Configure_Memcached"><span class="has-inline-color has-vivid-purple-color">Configure Memcached</span></span></h2>
<p>Memcached must be listening to <strong>127.0.0.1</strong>. Next, open the default setting in the configuration file located at “<strong>/etc/memcached.conf</strong>“.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo nano /etc/memcached.conf</code></pre>
<p>Now scroll down and find the following line and check the <strong>&#8220;-l&#8221; </strong>parameter that exists. Leave as the default unless you have internal IP on a local network or external IP from outside; you must modify the default IP address from 127.0.0.1 to the new IP address.</p>
<pre class="wp-block-code"><code lang="vim" class="language-vim">-l 127.0.0.1</code></pre>
<p>It is recommended to disable UDP. Unless you require this function to be enabled, add the following line to disable it.</p>
<pre class="wp-block-code"><code lang="vim" class="language-vim">-U 0</code></pre>
<p>Before you finish, changing the default 64MB memory allocation is recommended as this isn’t much for larger websites, and you will not see much benefit using Memcached.</p>
<p>You need to set this to something reasonable for your server. If you have 3 to 6 GB of hardly used RAM, put it to 1GB or 2GB. This is a setting you must decide that runs best for your server. The guide’s server runs on 8GB, so we adjusted our cache to 2GB as an example only.</p>
<pre class="wp-block-code"><code lang="vim" class="language-vim">-m 2000</code></pre>
<p>Now save the file <strong>CTRL+O </strong>and hit <strong>“Y,”</strong> then <strong>CTRL+X </strong>to exit and restart your Memcached instance.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl restart memcached</code></pre>
<h2><span id="Optional_Allow_Memcached_UFW_Rules"><span class="has-inline-color has-vivid-purple-color">Optional – Allow Memcached UFW Rules</span></span></h2>
<p>If you have UFW installed, you need to create UFW allow rules on the <strong>TCP port 11211</strong>. Depending on your installation and requirements if using singular or in a cluster network, some examples are below:</p>
<p><strong><em>Singular IP network connection example:</em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo ufw allow proto tcp from &lt;ip address> to any port 11211</code></pre>
<p><strong><em>Cluster IP network connection with many instances example:</em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo ufw allow proto tcp from &lt;ip address>/24 to any port 11211</code></pre>
<p>Note, the second UFW rule is a subnet rule. Note, make sure the internal network is secure and trustworthy before allowing it.</p><div class="linux-content" id="linux-1521049280"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7703471362501005" data-ad-slot="7240151726" data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<h2><span id="Install_Memcached_PHP_Libraries">Install Memcached PHP Libraries</span></h2>
<p>Memcached comes with various extensions for the programming languages, but it is primarily used for the PHP. To install the PHP library enter the following.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install php-memcached apache2 libapache2-mod-php php php-cli php-memcached php-memcached</code></pre>
<h3><span id="Apache_HTTP_Server">Apache HTTP Server</span></h3>
<p>Apache users can execute the following code to enable Memcached on their system.</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">phpenmod memcached &amp;&amp; sudo service apache2 restart</code></pre>
<h3><span id="Nginx_HTTP_Server">Nginx HTTP Server</span></h3>
<p>Memcached for Nginx will be enabled in your PHP block by default once installed.</p>
<h2><span id="Install_Additional_Libraries"><span class="has-inline-color has-vivid-purple-color">Install Additional Libraries</span></span></h2>
<p>You can install Python and or Perl support by executing the following commands.</p>
<p><strong><em>Python support:</em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install python3-pymemcache</code></pre>
<p><strong><em>Perl support:</em></strong></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo apt install libcache-memcached-libmemcached-perl</code></pre>
<h2><span id="Accessing_Memcached_from_Command_Line"><span class="has-inline-color has-vivid-purple-color">Accessing Memcached from Command Line</span></span></h2>
<p>Memcached stats can be gathered by much additional software and WEB UI&#8217;s that it works in conjunction with. However, a better way to check is to interact with Memcached directly using the command line.</p>
<p>First, <strong>TELNET</strong> into your service:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">telnet localhost 11211</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.</code></pre>
<p>Next, you can get an overview of your Memcached service by using the following command:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">stats</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">STAT pid 5934
STAT uptime 1275
STAT time 1631930242
STAT version 1.6.9
STAT libevent 2.1.12-stable
STAT pointer_size 64
STAT rusage_user 0.113635
STAT rusage_system 0.000000
STAT max_connections 1024
STAT curr_connections 1
STAT total_connections 2
STAT rejected_connections 0
STAT connection_structures 2
STAT response_obj_oom 0
STAT response_obj_count 1
STAT response_obj_bytes 16384
STAT read_buf_count 2
STAT read_buf_bytes 32768
STAT read_buf_bytes_free 0
STAT read_buf_oom 0
STAT reserved_fds 20
STAT cmd_get 0
STAT cmd_set 0
STAT cmd_flush 0
STAT cmd_touch 0
STAT cmd_meta 0
STAT get_hits 0
STAT get_misses 0
STAT get_expired 0
STAT get_flushed 0
STAT delete_misses 0
STAT delete_hits 0
STAT incr_misses 0
STAT incr_hits 0
STAT decr_misses 0
STAT decr_hits 0
STAT cas_misses 0
STAT cas_hits 0
STAT cas_badval 0
STAT touch_hits 0
STAT touch_misses 0
STAT auth_cmds 0
STAT auth_errors 0
STAT bytes_read 7
STAT bytes_written 0
STAT limit_maxbytes 67108864
STAT accepting_conns 1
STAT listen_disabled_num 0
STAT time_in_listen_disabled_us 0
STAT threads 4
STAT conn_yields 0
STAT hash_power_level 16
STAT hash_bytes 524288
STAT hash_is_expanding 0
STAT slab_reassign_rescues 0
STAT slab_reassign_chunk_rescues 0
STAT slab_reassign_evictions_nomem 0
STAT slab_reassign_inline_reclaim 0
STAT slab_reassign_busy_items 0
STAT slab_reassign_busy_deletes 0
STAT slab_reassign_running 0
STAT slabs_moved 0
STAT lru_crawler_running 0
STAT lru_crawler_starts 6
STAT lru_maintainer_juggles 1325
STAT malloc_fails 0
STAT log_worker_dropped 0
STAT log_worker_written 0
STAT log_watcher_skipped 0
STAT log_watcher_sent 0
STAT unexpected_napi_ids 0
STAT round_robin_fallback 0
STAT bytes 0
STAT curr_items 0
STAT total_items 0
STAT slab_global_page_pool 0
STAT expired_unfetched 0
STAT evicted_unfetched 0
STAT evicted_active 0
STAT evictions 0
STAT reclaimed 0
STAT crawler_reclaimed 0
STAT crawler_items_checked 0
STAT lrutail_reflocked 0
STAT moves_to_cold 0
STAT moves_to_warm 0
STAT moves_within_lru 0
STAT direct_reclaims 0
STAT lru_bumps_dropped 0
END</code></pre>
<p>As above, this shows some crucial things you may want to see, such as uptime, number of items in the cache, and the number of client connections to the instance</p>
<p>You can refine the search by looking into the different Memcached slabs (partitions) of memory to return results. </p>
<p><strong>Examples below:</strong></p>
<p><em>List the slabs in the instance connected:</em></p><div class="linux-content" id="linux-1093285846"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7703471362501005" data-ad-slot="7240151726" data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<pre class="wp-block-code"><code lang="bash" class="language-bash">stats slabs</code></pre>
<p><em>List of slabs which includes a count of the items stored within each slab</em>:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">stats items</code></pre>
<p>Next, you can access and delete data using the <strong>cachedump command</strong> to list the keys.</p>
<p>First, execute the <strong>cachedump command</strong>:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">stats cachedump [slab ID] [number of items, 0 for all items]</code></pre>
<p><em>Example in action:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">stats cachedump 1 0</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">ITEM testkey [9 b; 1296857316 s]
END</code></pre>
<p>As above, SLAB 1 has one item with the key <strong>&#8220;testkey.&#8221;</strong> To get the actual value, you can use the <strong>&#8220;get key&#8221;</strong> command as follows:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">get testkey</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">VALUE testkey 0 9
test data
END</code></pre>
<p>Lastly, to delete a cached item, in this case, the <strong>&#8220;testkey&#8221; </strong>use the following command:</p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">delete testkey</code></pre>
<p><em>Example output:</em></p>
<pre class="wp-block-code"><code lang="bash" class="language-bash">DELETED</code></pre>
<h2><span id="Comments_and_Conclusion"><span class="has-inline-color has-vivid-purple-color">Comments and Conclusion</span></span></h2>
<p>The tutorial has shown you how to install Memcached on your Debian 11 Bullseye operating system, installing the additional libraries and how to access the terminal command list. </p>
<p>For further documentation, the project’s <a target="_blank" href="https://github.com/memcached/memcached/wiki" rel="noreferrer noopener">Github Wiki</a> page explains further in great detail for server admins any specifications or information they require.</p>
<div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.linuxcapable.com/tag/cache/" rel="tag">Cache</a><a href="https://www.linuxcapable.com/tag/debian/" rel="tag">Debian</a><a href="https://www.linuxcapable.com/tag/debian-11/" rel="tag">Debian 11</a><a href="https://www.linuxcapable.com/tag/debian-bullseye/" rel="tag">Debian Bullseye</a><a href="https://www.linuxcapable.com/tag/memcached/" rel="tag">Memcached</a></div>
</div>
</div>
<div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix">
<div class="jeg_sharelist">
<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=How+to+Install+Memcached+on+Debian+11+Bullseye&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet</span></a><a href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-reddit expanded"><i class="fa fa-reddit"></i><span>Share</span></a><a href="https://www.tumblr.com/widgets/share/tool?canonicalUrl=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-tumbrl expanded"><i class="fa fa-tumblr"></i><span>Share</span></a>
<div class="share-secondary">
<a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-linkedin"><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&media=https://www.linuxcapable.com/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye.png&description=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-pinterest"><i class="fa fa-pinterest"></i></a><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F&title=How+to+Install+Memcached+on+Debian+11+Bullseye" rel='nofollow' class="jeg_btn-stumbleupon"><i class="fa fa-stumbleupon"></i></a>
</div>
<a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_bottom_ads"><div class='ads-wrapper'></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
<a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/" class="post prev-post">
<span class="caption">Previous Post</span>
<h3 class="post-title">How to Install Redis on Debian 11 Bullseye</h3>
</a>
<a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/" class="post next-post">
<span class="caption">Next Post</span>
<h3 class="post-title">How to Install Brave Browser on Linux Mint 20</h3>
</a>
</div></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div class="jeg_postblock_8 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_12055_0_6147b11bc5916" data-unique="jnews_module_12055_0_6147b11bc5916">
<div class="jeg_block_heading jeg_block_heading_3 jeg_subcat_right">
<h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts_wrap"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_1 format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/"><div class="thumbnail-container  size-500"><img width="360" height="180" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-360x180.png.webp" class="attachment-jnews-360x180 size-jnews-360x180 wp-post-image" alt="How to Install Redis on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-360x180.png.webp 360w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-750x375.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-1140x570.png.webp 1140w" sizes="(max-width: 360px) 100vw, 360px" title="How to Install Redis on Debian 11 Bullseye 5"></div></a>
<div class="jeg_post_category">
<span><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/" class="category-debian">Debian</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/">How to Install Redis on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> September 18, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 53 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_md_1 format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-java-17-openjdk-17-on-debian-11-bullseye/"><div class="thumbnail-container  size-500"><img width="360" height="180" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Instal-Java-17-OpenJDK-17-on-Debian-11-Bullseye-360x180.png.webp" class="attachment-jnews-360x180 size-jnews-360x180 wp-post-image" alt="How to Install Java 17 (OpenJDK 17) on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Instal-Java-17-OpenJDK-17-on-Debian-11-Bullseye-360x180.png.webp 360w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Instal-Java-17-OpenJDK-17-on-Debian-11-Bullseye-750x375.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Instal-Java-17-OpenJDK-17-on-Debian-11-Bullseye-1140x570.png.webp 1140w" sizes="(max-width: 360px) 100vw, 360px" title="How to Install Java 17 (OpenJDK 17) on Debian 11 Bullseye 6"></div></a>
<div class="jeg_post_category">
<span><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/" class="category-debian">Debian</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-java-17-openjdk-17-on-debian-11-bullseye/">How to Install Java 17 (OpenJDK 17) on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-java-17-openjdk-17-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> September 16, 2021 - Updated on September 17, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-java-17-openjdk-17-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 151 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_md_1 format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-and-use-ffmpeg-on-debian-11/"><div class="thumbnail-container  size-500"><img width="360" height="180" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-and-Use-FFmpeg-on-Debian-11-360x180.png.webp" class="attachment-jnews-360x180 size-jnews-360x180 wp-post-image" alt="How to Install and Use FFmpeg on Debian 11" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-and-Use-FFmpeg-on-Debian-11-360x180.png.webp 360w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-and-Use-FFmpeg-on-Debian-11-750x375.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-and-Use-FFmpeg-on-Debian-11-1140x570.png.webp 1140w" sizes="(max-width: 360px) 100vw, 360px" title="How to Install and Use FFmpeg on Debian 11 7"></div></a>
<div class="jeg_post_category">
<span><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/" class="category-debian">Debian</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-and-use-ffmpeg-on-debian-11/">How to Install and Use FFmpeg on Debian 11</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-and-use-ffmpeg-on-debian-11/"><i class="fa fa-clock-o"></i> September 14, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-and-use-ffmpeg-on-debian-11/"><i class="fa fa-eye"></i> 192 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_md_1 format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-set-or-change-timezone-on-debian-11/"><div class="thumbnail-container  size-500"><img width="360" height="180" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-To-Set-or-Change-Timezone-on-Debian-11-360x180.png.webp" class="attachment-jnews-360x180 size-jnews-360x180 wp-post-image" alt="How To Set or Change Timezone on Debian 11" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-To-Set-or-Change-Timezone-on-Debian-11-360x180.png.webp 360w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-To-Set-or-Change-Timezone-on-Debian-11-750x375.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-To-Set-or-Change-Timezone-on-Debian-11-1140x570.png.webp 1140w" sizes="(max-width: 360px) 100vw, 360px" title="How To Set or Change Timezone on Debian 11 8"></div></a>
<div class="jeg_post_category">
<span><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/" class="category-debian">Debian</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-set-or-change-timezone-on-debian-11/">How To Set or Change Timezone on Debian 11</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-set-or-change-timezone-on-debian-11/"><i class="fa fa-clock-o"></i> September 12, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-set-or-change-timezone-on-debian-11/"><i class="fa fa-eye"></i> 129 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_md_1 format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-glances-system-monitor-on-debian-11/"><div class="thumbnail-container  size-500"><img width="360" height="180" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Glances-System-Monitor-on-Debian-11-1-360x180.png.webp" class="attachment-jnews-360x180 size-jnews-360x180 wp-post-image" alt="How to Install Glances System Monitor on Debian 11" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Glances-System-Monitor-on-Debian-11-1-360x180.png.webp 360w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Glances-System-Monitor-on-Debian-11-1-750x375.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Glances-System-Monitor-on-Debian-11-1-1140x570.png.webp 1140w" sizes="(max-width: 360px) 100vw, 360px" title="How to Install Glances System Monitor on Debian 11 9"></div></a>
<div class="jeg_post_category">
<span><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/" class="category-debian">Debian</a></span>
</div>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-glances-system-monitor-on-debian-11/">How to Install Glances System Monitor on Debian 11</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://www.linuxcapable.com/author/josh/">Joshua James</a></div><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-glances-system-monitor-on-debian-11/"><i class="fa fa-clock-o"></i> September 11, 2021 - Updated on September 12, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-glances-system-monitor-on-debian-11/"><i class="fa fa-eye"></i> 157 </a></div></div>
</div>
</article></div></div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_12055_0_6147b11bc5916 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_3","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"5","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":12055,"include_category":"","exclude_category":"","include_author":"","include_tag":"477,160,642,692,454","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"5","pagination_scroll_limit":3,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_8"};</script>
</div></div><div class="jnews_popup_post_container"> <section class="jeg_popup_post">
<span class="caption">Next Post</span>
<div class="jeg_popup_content">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/">
<div class="thumbnail-container  size-1000"><img width="75" height="75" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-75x75.png.webp" class="attachment-jnews-75x75 size-jnews-75x75 wp-post-image" alt="How to Install Brave Browser on Linux Mint 20" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-75x75.png.webp 75w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-150x150.png.webp 150w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-350x350.png.webp 350w" sizes="(max-width: 75px) 100vw, 75px" title="How to Install Brave Browser on Linux Mint 20 10"></div> </a>
</div>
<h3 class="post-title">
<a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/">
How to Install Brave Browser on Linux Mint 20 </a>
</h3>
</div>
<a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
</section>
</div><div class="jnews_comment_container"> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-install-memcached-on-debian-11-bullseye/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.linuxcapable.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-form-privacy_policy">
<label for="privacy_policy">Privacy Policy Agreement <span class="required">*</span></label>
<input id="privacy_policy" name="privacy_policy" required='required' type='checkbox'> I agree to the Terms & Conditions and <a href="https://www.linuxcapable.com/privacy-policy-statement/">Privacy Policy</a>.
</p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='12055' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div>
</div>
</div>
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
<div class="widget linux-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7703471362501005" data-ad-slot="2495123327" data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-2"><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_12055_1_6147b11bcad19  normal" data-unique="jnews_module_12055_1_6147b11bcad19">
<div class="jeg_block_heading jeg_block_heading_8 jeg_subcat_right">
<h3 class="jeg_block_title"><span>You might also like</span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-plex-media-server-on-fedora/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Plex-Media-Server-on-Fedora-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install Plex Media Server on Fedora" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Plex-Media-Server-on-Fedora-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Plex-Media-Server-on-Fedora-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Plex-Media-Server-on-Fedora-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Plex-Media-Server-on-Fedora-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Plex Media Server on Fedora 11"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-plex-media-server-on-fedora/">How to Install Plex Media Server on Fedora</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-plex-media-server-on-fedora/"><i class="fa fa-clock-o"></i> September 19, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-plex-media-server-on-fedora/"><i class="fa fa-eye"></i> 32 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-rust-on-almalinux-8/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Rust-on-AlmaLinux-8-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install Rust on AlmaLinux 8" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Rust-on-AlmaLinux-8-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Rust-on-AlmaLinux-8-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Rust-on-AlmaLinux-8-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Rust-on-AlmaLinux-8-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Rust on AlmaLinux 8 12"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-rust-on-almalinux-8/">How to Install Rust on AlmaLinux 8</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-rust-on-almalinux-8/"><i class="fa fa-clock-o"></i> September 19, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-rust-on-almalinux-8/"><i class="fa fa-eye"></i> 26 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install Brave Browser on Linux Mint 20" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Brave-Browser-on-Linux-Mint-20-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Brave Browser on Linux Mint 20 13"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/">How to Install Brave Browser on Linux Mint 20</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/"><i class="fa fa-clock-o"></i> September 19, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-brave-browser-on-linux-mint-20/"><i class="fa fa-eye"></i> 21 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install Memcached on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Memcached-on-Debian-11-Bullseye-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Memcached on Debian 11 Bullseye 14"></div></a>
 </div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/">How to Install Memcached on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> September 18, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-memcached-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 34 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install Redis on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-Redis-on-Debian-11-Bullseye-1-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Redis on Debian 11 Bullseye 15"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/">How to Install Redis on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> September 18, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-redis-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 53 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-virtualbox-on-ubuntu-20-04/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-VirtualBox-on-Ubuntu-20.04-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install VirtualBox on Ubuntu 20.04" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-VirtualBox-on-Ubuntu-20.04-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-VirtualBox-on-Ubuntu-20.04-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-VirtualBox-on-Ubuntu-20.04-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-VirtualBox-on-Ubuntu-20.04-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install VirtualBox on Ubuntu 20.04 16"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-virtualbox-on-ubuntu-20-04/">How to Install VirtualBox on Ubuntu 20.04</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-virtualbox-on-ubuntu-20-04/"><i class="fa fa-clock-o"></i> September 18, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-virtualbox-on-ubuntu-20-04/"><i class="fa fa-eye"></i> 99 </a></div></div>
</div>
</article></div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_12055_1_6147b11bcad19 = {"header_icon":"","first_title":"You might also like","second_title":"","url":"","header_type":"heading_8","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":"0","unique_content":"unique4","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"0","pagination_mode":"disable","pagination_nextprev_showtext":"0","pagination_number_post":"6","pagination_scroll_limit":"0","boxed":"0","boxed_shadow":"0","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"};</script>
</div></div><div class="widget linux-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7703471362501005" data-ad-slot="9803957073" data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-3"><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_12055_2_6147b11bce6ba  normal" data-unique="jnews_module_12055_2_6147b11bce6ba">
<div class="jeg_block_heading jeg_block_heading_8 jeg_subcat_right">
<h3 class="jeg_block_title"><span>Popular Tutorials This Month</span></h3>
</div>
<div class="jeg_block_container">
<div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-upgrade-to-gnome-40-on-debian-11-bullseye/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Upgrade-to-Gnome-40-on-Debian-11-Bullseye-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Upgrade to Gnome 40 on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Upgrade-to-Gnome-40-on-Debian-11-Bullseye-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Upgrade-to-Gnome-40-on-Debian-11-Bullseye-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Upgrade-to-Gnome-40-on-Debian-11-Bullseye-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Upgrade-to-Gnome-40-on-Debian-11-Bullseye-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Upgrade to Gnome 40 on Debian 11 Bullseye 17"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-upgrade-to-gnome-40-on-debian-11-bullseye/">How to Upgrade to Gnome 40 on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-upgrade-to-gnome-40-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> August 16, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-upgrade-to-gnome-40-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 1.3k </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-gnome-40-on-ubuntu-21-04/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-GNOME-40-on-Ubuntu-21.04-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install GNOME 40 on Ubuntu 21.04" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-GNOME-40-on-Ubuntu-21.04-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-GNOME-40-on-Ubuntu-21.04-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-GNOME-40-on-Ubuntu-21.04-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-GNOME-40-on-Ubuntu-21.04-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install GNOME 40 on Ubuntu 21.04 18"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-gnome-40-on-ubuntu-21-04/">How to Install GNOME 40 on Ubuntu 21.04</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-gnome-40-on-ubuntu-21-04/"><i class="fa fa-clock-o"></i> August 20, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-gnome-40-on-ubuntu-21-04/"><i class="fa fa-eye"></i> 1.1k </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-anydesk-on-ubuntu-20-04/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-AnyDesk-on-Ubuntu-20.04-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install AnyDesk on Ubuntu 20.04" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-AnyDesk-on-Ubuntu-20.04-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-AnyDesk-on-Ubuntu-20.04-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-AnyDesk-on-Ubuntu-20.04-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/09/How-to-Install-AnyDesk-on-Ubuntu-20.04-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install AnyDesk on Ubuntu 20.04 19"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-anydesk-on-ubuntu-20-04/">How to Install AnyDesk on Ubuntu 20.04</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-anydesk-on-ubuntu-20-04/"><i class="fa fa-clock-o"></i> September 7, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-anydesk-on-ubuntu-20-04/"><i class="fa fa-eye"></i> 1k </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-wine-on-linux-mint-20/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-Wine-on-Linux-Mint-20-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="How to Install Wine on Linux Mint 20" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-Wine-on-Linux-Mint-20-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-Wine-on-Linux-Mint-20-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-Wine-on-Linux-Mint-20-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/How-to-Install-Wine-on-Linux-Mint-20-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Wine on Linux Mint 20 20"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-wine-on-linux-mint-20/">How to Install Wine on Linux Mint 20</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-wine-on-linux-mint-20/"><i class="fa fa-clock-o"></i> August 17, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-wine-on-linux-mint-20/"><i class="fa fa-eye"></i> 1.1k </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-php-8-on-debian-11-bullseye/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/how-to-install-php-8-on-debian-11-bullseye-120x86.png.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="how to install php 8 on debian 11 bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/how-to-install-php-8-on-debian-11-bullseye-120x86.png.webp 120w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/how-to-install-php-8-on-debian-11-bullseye-350x250.png.webp 350w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/how-to-install-php-8-on-debian-11-bullseye-750x536.png.webp 750w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/08/how-to-install-php-8-on-debian-11-bullseye-1140x815.png.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install PHP 8 on Debian 11 Bullseye 21"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-php-8-on-debian-11-bullseye/">How to Install PHP 8 on Debian 11 Bullseye</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-php-8-on-debian-11-bullseye/"><i class="fa fa-clock-o"></i> August 17, 2021 - Updated on September 9, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-php-8-on-debian-11-bullseye/"><i class="fa fa-eye"></i> 988 </a></div></div>
</div>
</article><article class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://www.linuxcapable.com/how-to-install-python-3-10-on-ubuntu-20-04/"><div class="thumbnail-container  size-715"><img width="120" height="86" src="https://www.linuxcapable.com/wp-content/uploads/2021/07/how-to-install-python-3.10-on-ubuntu-120x86.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="how to install python 3.10 on ubuntu" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/07/how-to-install-python-3.10-on-ubuntu-120x86.webp 120w,   https://www.linuxcapable.com/wp-content/uploads/2021/07/how-to-install-python-3.10-on-ubuntu-350x250.webp 350w,   https://www.linuxcapable.com/wp-content/uploads/2021/07/how-to-install-python-3.10-on-ubuntu-750x536.webp 750w" sizes="(max-width: 120px) 100vw, 120px" title="How to Install Python 3.10 on Ubuntu 20.04 22"></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://www.linuxcapable.com/how-to-install-python-3-10-on-ubuntu-20-04/">How to Install Python 3.10 on Ubuntu 20.04</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.linuxcapable.com/how-to-install-python-3-10-on-ubuntu-20-04/"><i class="fa fa-clock-o"></i> July 18, 2021 - Updated on July 24, 2021</a></div><div class="jeg_meta_views"><a href="https://www.linuxcapable.com/how-to-install-python-3-10-on-ubuntu-20-04/"><i class="fa fa-eye"></i> 1.1k </a></div></div>
</div>
</article></div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_12055_2_6147b11bce6ba = {"header_icon":"","first_title":"Popular Tutorials This Month","second_title":"","url":"","header_type":"heading_8","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":"0","unique_content":"unique4","include_post":"","exclude_post":"12086,12117,12107,12055,12034,11905","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"popular_post_month","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"0","pagination_mode":"disable","pagination_nextprev_showtext":"0","pagination_number_post":"6","pagination_scroll_limit":"0","boxed":"0","boxed_shadow":"0","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"};</script>
</div></div><div class="widget linux-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7703471362501005" data-ad-slot="8490875402" data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div></div> </div>
<div class="jeg_ad jeg_article jnews_article_bottom_ads">
<div class='ads-wrapper'></div> </div>
</div>
</div>
</div>
</div>
<div id="post-body-class" class="post-template-default single single-post postid-12055 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jsc_normal elementor-default elementor-kit-3206 aa-prefix-linux-"></div>
</div>
<div class="post-ajax-overlay">
<div class="preloader_type preloader_dot">
<div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="newsfeed_preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="newsfeed_preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="footer-holder" id="footer" data-id="footer">
<div class="jeg_footer jeg_footer_4 dark">
<div class="jeg_footer_container jeg_container">
<div class="jeg_footer_content">
<div class="container">
<div class="row">
<div class="jeg_footer_primary clearfix">
<div class="col-md-9 footer_column">
<ul class="jeg_menu_footer"><li id="menu-item-11239" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11239"><a href="https://www.linuxcapable.com/about-linuxcapable/">About LinuxCapable</a></li>
<li id="menu-item-10151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10151"><a href="https://www.linuxcapable.com/contact-form/">Contact Form</a></li>
<li id="menu-item-9500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9500"><a href="https://www.linuxcapable.com/html-sitemap/">HTML Sitemap</a></li>
<li id="menu-item-8989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-8989"><a href="https://www.linuxcapable.com/privacy-policy-statement/">Privacy Policy Statement</a></li>
<li id="menu-item-8991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8991"><a href="https://www.linuxcapable.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul> </div>
<div class="col-md-3 footer_column footer_right">
<div class="footer-text">
</div>
</div>
</div>
<div class="jeg_footer_secondary clearfix">
<div class="col-md-9 footer_column">
<p class="copyright"> © 2021 <a href="https://www.linuxcapable.com" title="LinuxCapable - Linux Articles, Guides and Tutorials">LinuxCapable</a> all rights reserved.<br>
All logos, trademarks and registered trademarks are the property of their respective owners. </p>
</div>
<div class="col-md-3 footer_column footer_right">
<div class="jeg_social_icon_block socials_widget nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://linuxcapable.tumblr.com" target='_blank' rel='external noopener nofollow' class="jeg_tumblr"><i class="fa fa-tumblr"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
</div>
</div>

<div id="jeg_off_canvas" class="dark">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
<div class="jeg_bg_overlay"></div>
<div class="jeg_mobile_wrapper">
<div class="nav_wrap">
<div class="item_main">

<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand rounded">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://www.linuxcapable.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_aside_item">
<ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-11965"><a href="https://www.linuxcapable.com/category/cms-tutorials/">CMS Tutorials</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11978"><a href="https://www.linuxcapable.com/category/cms-tutorials/wordpress/">WordPress</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11979"><a href="https://www.linuxcapable.com/category/commands-tips/">Commands/Tips</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-11960"><a href="https://www.linuxcapable.com/category/distro-tutorials/">Distro Tutorials</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10902"><a href="https://www.linuxcapable.com/category/distro-tutorials/almalinux/">AlmaLinux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9010"><a href="https://www.linuxcapable.com/category/distro-tutorials/debian/">Debian</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9745"><a href="https://www.linuxcapable.com/category/distro-tutorials/fedora/">Fedora</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9012"><a href="https://www.linuxcapable.com/category/distro-tutorials/linux-mint/">Linux Mint</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9014"><a href="https://www.linuxcapable.com/category/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9015"><a href="https://www.linuxcapable.com/category/distro-tutorials/ubuntu/">Ubuntu</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11966"><a href="https://www.linuxcapable.com/category/webserver-tutorials/">Webserver Tutorials</a></li>
</ul></div> </div>
<div class="item_bottom">
<div class="jeg_aside_item jeg_aside_copyright">
<p>© 2021 <a href="https://www.linuxcapable.com" title="LinuxCapable - Linux Articles, Guides and Tutorials">LinuxCapable</a> all rights reserved.<br>
All logos, trademarks and registered trademarks are the property of their respective owners.</p>
</div><div class="jeg_aside_item socials_widget nobg">
<a href="https://www.facebook.com/linuxcapable" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/linuxcapable/" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://linuxcapable.tumblr.com" target='_blank' rel='external noopener nofollow' class="jeg_tumblr"><i class="fa fa-tumblr"></i> </a><a href="https://www.linuxcapable.com/feed/" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a></div> </div>
</div> </div>
</div><script type="text/javascript">var jfla = ["view_counter"]</script><div id="selectShareContainer">
<div class="selectShare-inner">
<div class="select_share jeg_share_button">
<button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" data-image-url="" data-title="How+to+Install+Memcached+on+Debian+11+Bullseye"><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-memcached-on-debian-11-bullseye%2F" data-image-url="" data-title="How+to+Install+Memcached+on+Debian+11+Bullseye"><i class="fa fa-twitter"></i></a>
</div>
<div class="selectShare-arrowClip">
<div class="selectShare-arrow"></div>
</div>
</div>
</div><div class="jnews-cookie-law-policy">This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="https://www.linuxcapable.com/privacy-policy-statement/">Privacy and Cookie Policy</a>. <button data-expire="7" class="btn btn-cookie">I Agree</button></div><div class="jeg_read_progress_wrapper"><div class="jeg_progress_container bottom"><span class="progress-bar"></span></div></div><script type='text/javascript' id='mkaz-code-syntax-prism-js-js-extra'>
/* <![CDATA[ */
var prism_settings = {"pluginUrl":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/code-syntax-block\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism/prism.js?ver=1631988615' id='mkaz-code-syntax-prism-js-js' defer></script>
<script type='text/javascript' id='copy-the-code-js-extra'>
/* <![CDATA[ */
var copyTheCode = {"copy_content_as":"","previewMarkup":"<h2>Hello World<\/h2>","buttonMarkup":"<button class=\"copy-the-code-button\" title=\"\"><\/button>","buttonSvg":"<svg viewBox=\"-21 0 512 512\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\"><path d=\"m186.667969 416c-49.984375 0-90.667969-40.683594-90.667969-90.667969v-218.664062h-37.332031c-32.363281 0-58.667969 26.300781-58.667969 58.664062v288c0 32.363281 26.304688 58.667969 58.667969 58.667969h266.664062c32.363281 0 58.667969-26.304688 58.667969-58.667969v-37.332031zm0 0\"><\/path><path d=\"m469.332031 58.667969c0-32.40625-26.261719-58.667969-58.664062-58.667969h-224c-32.40625 0-58.667969 26.261719-58.667969 58.667969v266.664062c0 32.40625 26.261719 58.667969 58.667969 58.667969h224c32.402343 0 58.664062-26.261719 58.664062-58.667969zm0 0\"><\/path><\/svg>","selectors":[{"selector":"pre","style":"button","button_text":"Copy","button_title":"Copy to Clipboard","button_copy_text":"Copied!","button_position":"inside"}],"selector":"pre","settings":{"selector":"pre","button-text":"Copy","button-title":"Copy to Clipboard","button-copy-text":"Copied!","button-position":"inside"},"string":{"title":"Copy to Clipboard","copy":"Copy","copied":"Copied!"},"image-url":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/copy-the-code\/\/assets\/images\/copy-1.svg"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/copy-the-code/assets/js/copy-the-code.js?ver=2.2.2' id='copy-the-code-js' defer></script>
<script type='text/javascript' id='toc-front-js-extra'>
/* <![CDATA[ */
var tocplus = {"visibility_show":"show","visibility_hide":"hide","width":"100%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=2106' id='toc-front-js' defer></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.13.0' id='advanced-ds-pro/front-js' defer></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js' defer></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js' defer></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js' defer></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/www.linuxcapable.com\/how-to-install-memcached-on-debian-11-bullseye","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_AU","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"12055","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"www.linuxcapable.com","zoom_button":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=9.0.5' id='jnews-frontend-js' defer></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=9.0.5' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' data-cfasync="false" data-no-optimize="1" src='https://www.linuxcapable.com/wp-content/plugins/perfmatters/vendor/instant-page/instantpage.js?ver=1.7.8' id='perfmatters-instant-page-js'></script>
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js' defer></script>
<script type='text/javascript' src='https://www.linuxcapable.com/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js' defer></script>
<div class="jeg_ad jnews_mobile_sticky_ads"></div><script>
    (function(c,l,a,r,i,t,y){
        c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
        t=l.createElement(r);t.async=1;t.src="https://www.clarity.ms/tag/"+i;
        y=l.getElementsByTagName(r)[0];y.parentNode.insertBefore(t,y);
    })(window, document, "clarity", "script", "7ewcpxc1bx");
</script><script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(e.data.counter,(function(e,n){o[n].length&&t.forEach(o[n],(function(n,o){t.setText(n,e)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script></body>
</html>