<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">

			<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}		</style>
		<meta name="uri-translation" content="on" /><link rel="alternate" hreflang="en" href="https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="af" href="https://af.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sq" href="https://sq.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="am" href="https://am.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ar" href="https://ar.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="hy" href="https://hy.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="az" href="https://az.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="eu" href="https://eu.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="be" href="https://be.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="bn" href="https://bn.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="bs" href="https://bs.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="bg" href="https://bg.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ca" href="https://ca.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ceb" href="https://ceb.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ny" href="https://ny.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="zh-CN" href="https://zh-CN.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="zh-TW" href="https://zh-TW.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="co" href="https://co.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="hr" href="https://hr.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="cs" href="https://cs.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="da" href="https://da.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="nl" href="https://nl.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="eo" href="https://eo.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="et" href="https://et.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="tl" href="https://tl.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="fi" href="https://fi.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="fr" href="https://fr.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="fy" href="https://fy.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="gl" href="https://gl.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ka" href="https://ka.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="de" href="https://de.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="el" href="https://el.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="gu" href="https://gu.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ht" href="https://ht.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ha" href="https://ha.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="haw" href="https://haw.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="he" href="https://iw.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="hi" href="https://hi.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="hmn" href="https://hmn.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="hu" href="https://hu.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="is" href="https://is.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ig" href="https://ig.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="id" href="https://id.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ga" href="https://ga.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="it" href="https://it.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ja" href="https://ja.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="jv" href="https://jw.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="kn" href="https://kn.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="kk" href="https://kk.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="km" href="https://km.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ko" href="https://ko.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ku" href="https://ku.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ky" href="https://ky.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="lo" href="https://lo.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="la" href="https://la.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="lv" href="https://lv.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="lt" href="https://lt.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="lb" href="https://lb.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="mk" href="https://mk.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="mg" href="https://mg.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ms" href="https://ms.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ml" href="https://ml.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="mt" href="https://mt.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="mi" href="https://mi.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="mr" href="https://mr.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="mn" href="https://mn.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="my" href="https://my.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ne" href="https://ne.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="no" href="https://no.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ps" href="https://ps.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="fa" href="https://fa.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="pl" href="https://pl.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="pt" href="https://pt.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="pa" href="https://pa.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ro" href="https://ro.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ru" href="https://ru.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sm" href="https://sm.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="gd" href="https://gd.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sr" href="https://sr.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="st" href="https://st.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sn" href="https://sn.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sd" href="https://sd.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="si" href="https://si.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sk" href="https://sk.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sl" href="https://sl.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="so" href="https://so.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="es" href="https://es.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="su" href="https://su.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sw" href="https://sw.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="sv" href="https://sv.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="tg" href="https://tg.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ta" href="https://ta.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="te" href="https://te.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="th" href="https://th.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="tr" href="https://tr.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="uk" href="https://uk.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="ur" href="https://ur.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="uz" href="https://uz.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="vi" href="https://vi.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="cy" href="https://cy.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="xh" href="https://xh.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="yi" href="https://yi.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="yo" href="https://yo.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel="alternate" hreflang="zu" href="https://zu.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<link rel='preconnect' href='https://www.google-analytics.com' >
<link rel='preconnect' href='https://www.googletagmanager.com' >
<link rel='preconnect' href='https://adservice.google.com' >
<link rel='preconnect' href='https://googleads.g.doubleclick.net' >
<link rel='preconnect' href='https://www.googletagservices.com' >
<link rel='preconnect' href='https://tpc.googlesyndication.com' >
<link rel='preconnect' href='https://pagead2.googlesyndication.com' >
<link rel='preconnect' href='https://stats.linuxcapable.com' crossorigin>
<link rel='preconnect' href='https://www.google.com' >
<link rel='preconnect' href='https://stats.g.doubleclick.net' >
<link rel='preconnect' href='https://partner.googleadservices.com/' >
<meta name="viewport" content="width=device-width, initial-scale=1">
<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>How to Install MariaDB 10.7 on openSUSE Leap 15 - LinuxCapable</title>
<meta name="description" content="In the following tutorial, you will learn how to install MariaDB 10.7 on openSUSE Leap 15."/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install MariaDB 10.7 on openSUSE Leap 15 - LinuxCapable" />
<meta property="og:description" content="In the following tutorial, you will learn how to install MariaDB 10.7 on openSUSE Leap 15." />
<meta property="og:url" content="https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/" />
<meta property="og:site_name" content="LinuxCapable" />
<meta property="article:publisher" content="https://www.linuxcapable.com/linuxcapable" />
<meta property="article:tag" content="MariaDB" />
<meta property="article:tag" content="openSUSE Leap 15" />
<meta property="article:section" content="openSUSE" />
<meta property="og:updated_time" content="2021-12-28T09:54:19+08:00" />
<meta property="og:image" content="https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-1024x576.png" />
<meta property="og:image:secure_url" content="https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-1024x576.png" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:image:alt" content="How to Install MariaDB 10.7 on openSUSE Leap 15" />
<meta property="og:image:type" content="image/png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to Install MariaDB 10.7 on openSUSE Leap 15 - LinuxCapable" />
<meta name="twitter:description" content="In the following tutorial, you will learn how to install MariaDB 10.7 on openSUSE Leap 15." />
<meta name="twitter:site" content="@linuxcapable" />
<meta name="twitter:creator" content="@LinuxCapable" />
<meta name="twitter:image" content="https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-1024x576.png" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Joshua James" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="6 minutes" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.linuxcapable.com/#organization","name":"LinuxCapable.com","logo":{"@type":"ImageObject","@id":"https://www.linuxcapable.com/#logo","url":"https://www.linuxcapable.com/wp-content/uploads/2021/07/linuxcapable.webp","caption":"LinuxCapable.com","inLanguage":"en-US"}},{"@type":"WebSite","@id":"https://www.linuxcapable.com/#website","url":"https://www.linuxcapable.com","name":"LinuxCapable.com","publisher":{"@id":"https://www.linuxcapable.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15.png","url":"https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15.png","width":"2240","height":"1260","caption":"How to Install MariaDB 10.7 on openSUSE Leap 15","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://www.linuxcapable.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://www.linuxcapable.com/distro-tutorials/opensuse/","name":"openSUSE"}},{"@type":"ListItem","position":"3","item":{"@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/","name":"How to Install MariaDB 10.7 on openSUSE Leap 15"}}]},{"@type":"Person","@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#author","name":"Joshua James","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/95d766cbde8b7da9dc0ca224f93b988b?s=96&amp;r=g","url":"https://secure.gravatar.com/avatar/95d766cbde8b7da9dc0ca224f93b988b?s=96&amp;r=g","caption":"Joshua James","inLanguage":"en-US"},"sameAs":["https://www.linuxcapable.com","https://twitter.com/LinuxCapable"],"worksFor":{"@id":"https://www.linuxcapable.com/#organization"}},{"@type":"WebPage","@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#webpage","url":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/","name":"How to Install MariaDB 10.7 on openSUSE Leap 15 - LinuxCapable","datePublished":"2021-12-28T09:54:16+08:00","dateModified":"2021-12-28T09:54:19+08:00","author":{"@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#author"},"isPartOf":{"@id":"https://www.linuxcapable.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15.png"},"inLanguage":"en-US","breadcrumb":{"@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#breadcrumb"}},{"@type":"Article","headline":"How to Install MariaDB 10.7 on openSUSE Leap 15 - LinuxCapable","keywords":"MariaDB 10.7","datePublished":"2021-12-28T09:54:16+08:00","dateModified":"2021-12-28T09:54:19+08:00","author":{"@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#author"},"publisher":{"@id":"https://www.linuxcapable.com/#organization"},"description":"In the following tutorial, you will learn how to install MariaDB 10.7 on openSUSE Leap 15.","name":"How to Install MariaDB 10.7 on openSUSE Leap 15 - LinuxCapable","@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#richSnippet","isPartOf":{"@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#webpage"},"image":{"@id":"https://www.linuxcapable.com/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15.png"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='stylesheet' id='gtranslate-style-css'  href='https://www.linuxcapable.com/wp-content/plugins/gtranslate/gtranslate-style32.css?ver=5.8.2' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.linuxcapable.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-block-style-css'  href='https://www.linuxcapable.com/wp-content/plugins/social-icons-widget-by-wpzoom/block/dist/style-wpzoom-social-icons.css?ver=4.2.2' media='all' />
<link rel='stylesheet' id='mkaz-code-syntax-prism-css-css'  href='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism-a11y-dark.css?ver=1635732604' media='all' />
<link rel='stylesheet' id='copy-the-code-css'  href='https://www.linuxcapable.com/wp-content/plugins/copy-the-code/assets/css/copy-the-code.css?ver=2.2.2' media='all' />
<link rel='stylesheet' id='lbwps-styles-css'  href='https://www.linuxcapable.com/wp-content/plugins/lightbox-photoswipe/assets/styles/default.css?ver=3.2.10' media='all' />
<link rel='stylesheet' id='generate-comments-css'  href='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/css/components/comments.min.css?ver=3.1.0' media='all' />
<link rel='stylesheet' id='generate-widget-areas-css'  href='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/css/components/widget-areas.min.css?ver=3.1.0' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/css/main.min.css?ver=3.1.0' media='all' />
<style id='generate-style-inline-css'>
.is-right-sidebar{width:25%;}.is-left-sidebar{width:25%;}.site-content .content-area{width:75%;}@media (max-width: 768px){.main-navigation .menu-toggle,.sidebar-nav-mobile:not(#sticky-placeholder){display:block;}.main-navigation ul,.gen-sidebar-nav,.main-navigation:not(.slideout-navigation):not(.toggled) .main-nav > ul,.has-inline-mobile-toggle #site-navigation .inside-navigation > *:not(.navigation-search):not(.main-nav){display:none;}.nav-align-right .inside-navigation,.nav-align-center .inside-navigation{justify-content:space-between;}}
</style>
<link rel='stylesheet' id='recent-posts-widget-with-thumbnails-public-style-css'  href='https://www.linuxcapable.com/wp-content/plugins/recent-posts-widget-with-thumbnails/public.css?ver=7.1.1' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-styles-css'  href='https://www.linuxcapable.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/wpzoom-social-icons-styles.css?ver=1637923502' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.38' media='all' />
<link rel='stylesheet' id='generatepress-dynamic-css'  href='https://www.linuxcapable.com/wp-content/uploads/generatepress/style.min.css?ver=1641197804' media='all' />
<link rel='stylesheet' id='fixedtoc-style-css'  href='https://www.linuxcapable.com/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=3.1.24' media='all' />
<style id='fixedtoc-style-inline-css'>
.ftwp-in-post#ftwp-container-outer { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-center { width: auto; } #ftwp-container.ftwp-wrap #ftwp-contents { width: auto; height: auto; } .ftwp-in-post#ftwp-container-outer #ftwp-contents { height: auto; } .ftwp-in-post#ftwp-container-outer.ftwp-float-center #ftwp-contents { width: auto; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 50px; height: 50px; font-size: 30px; } #ftwp-container #ftwp-trigger.ftwp-border-medium { font-size: 29px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 22px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 14px; font-family: inherit; } #ftwp-container #ftwp-list.ftwp-liststyle-decimal .ftwp-anchor::before { font-size: 14px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 15.4px; } #ftwp-container #ftwp-list.ftwp-strong-first.ftwp-liststyle-decimal>.ftwp-item>.ftwp-anchor::before { font-size: 15.4px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #ffffff; background: rgba(98,0,234,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(255,255,255,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(255,255,255,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #ffffff; background: rgba(97,0,234,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #6100ea; } #ftwp-container.ftwp-wrap #ftwp-list { color: #ffffff; background: rgba(98,0,234,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #6200ea; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #a370ea; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(163,112,234,0.95); } .ftwp-heading-target::before { background: rgba(163,112,234,0.95); }
</style>
<link rel='stylesheet' id='generate-blog-images-css'  href='https://www.linuxcapable.com/wp-content/plugins/gp-premium/blog/functions/css/featured-images.min.css?ver=2.1.1' media='all' />
<link rel='stylesheet' id='srpw-style-css'  href='https://www.linuxcapable.com/wp-content/plugins/smart-recent-posts-widget/assets/css/srpw-frontend.css?ver=5.8.2' media='all' />
<link rel='stylesheet' id='generate-navigation-branding-css'  href='https://www.linuxcapable.com/wp-content/plugins/gp-premium/menu-plus/functions/css/navigation-branding-flex.min.css?ver=2.1.1' media='all' />
<style id='generate-navigation-branding-inline-css'>
.main-navigation.has-branding .inside-navigation.grid-container, .main-navigation.has-branding.grid-container .inside-navigation:not(.grid-container){padding:0px 50px 0px 50px;}.main-navigation.has-branding:not(.grid-container) .inside-navigation:not(.grid-container) .navigation-branding{margin-left:10px;}.navigation-branding img, .site-logo.mobile-header-logo img{height:65px;width:auto;}.navigation-branding .main-title{line-height:65px;}@media (max-width: 768px){.main-navigation.has-branding.nav-align-center .menu-bar-items, .main-navigation.has-sticky-branding.navigation-stick.nav-align-center .menu-bar-items{margin-left:auto;}.navigation-branding{margin-right:auto;margin-left:10px;}.navigation-branding .main-title, .mobile-header-navigation .site-logo{margin-left:10px;}.main-navigation.has-branding .inside-navigation.grid-container{padding:0px;}}
</style>
<script src='https://www.linuxcapable.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>

<!-- Google Analytics snippet added by Site Kit -->
<script src='https://www.googletagmanager.com/gtag/js?id=UA-201586352-1' id='google_gtagjs-js' async></script>
<script id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.linuxcapable.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-201586352-1");
gtag("config", "G-3QMFH07WVP");
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<meta name="generator" content="Site Kit by Google 1.48.1" /><script>var gt_request_uri = '/how-to-install-mariadb-10-7-on-opensuse-leap-15/';</script>
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->

<!-- Google AdSense snippet added by Site Kit -->
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7703471362501005" crossorigin="anonymous"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxcapable.com/wp-content/uploads/2021/09/cropped-linuxcapable-tux-270x270.png" />
		<style id="wp-custom-css">
			/* GeneratePress Site CSS */ .inside-article,
.sidebar .widget,
.comments-area {
	border-right: 2px solid rgba(0, 0, 0, 0.07);
	border-bottom: 2px solid rgba(0, 0, 0, 0.07);
	box-shadow: 0 0 10px rgba(232, 234, 237, 0.5);
}

.separate-containers .page-header {
	background: transparent;
	padding-top: 20px;
	padding-bottom: 20px;
}

.page-header h1 {
	font-size: 1.5em;
}

.button, .wp-block-button .wp-block-button__link {
	padding: 15px 25px;
}

/* Stick last widgets in sidebars */
@media(min-width: 769px) {
    .inside-right-sidebar,
    .inside-left-sidebar {
        height: 100%;
    }
}
 /* End GeneratePress Site CSS */

pre.wp-block-code code {
    white-space: pre-wrap !important;
}

h2, h3 {
    line-height: 100%;
}

div#wpd-bubble-wrapper {
    bottom: 160px !important;
}

div.heateor_sss_horizontal_sharing{margin-bottom:25px}		</style>
		<style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>

<script>
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.linuxcapable.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//stats.linuxcapable.com/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
	
<script async="" src=https://securepubads.g.doubleclick.net/tag/js/gpt.js></script>

<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
              googletag.defineSlot('/22538769055/300x250', [300, 250], 'div-gpt-ad-1641180298478-0').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/300x250', [300, 250], 'div-gpt-ad-1641180298478-1').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/300x600', [300, 600], 'div-gpt-ad-1641180380603-0').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/300x600', [300, 600], 'div-gpt-ad-1641180380603-1').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/336x280-article', [336, 280], 'div-gpt-ad-1641180894306-0').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/336x280-article', [336, 280], 'div-gpt-ad-1641180894306-1').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/336x280-article', [336, 280], 'div-gpt-ad-1641180894306-2').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/336x280-article', [336, 280], 'div-gpt-ad-1641180894306-3').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/336x280-article', [336, 280], 'div-gpt-ad-1641180894306-4').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/336x280-article', [336, 280], 'div-gpt-ad-1641180894306-5').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/300x250-side', [300, 250], 'div-gpt-ad-1641181252383-0').addService(googletag.pubads());
	          googletag.defineSlot('/22538769055/300x250-side', [300, 250], 'div-gpt-ad-1641181252383-1').addService(googletag.pubads());
              googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
	
	</head>

<body class="post-template-default single single-post postid-17692 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-no-transition sticky-enabled both-sticky-menu right-sidebar nav-below-header separate-containers nav-search-enabled header-aligned-left dropdown-hover featured-image-active has-ftoc" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<nav class="auto-hide-sticky has-branding main-navigation nav-align-right has-menu-bar-items sub-menu-right" id="site-navigation" aria-label="Primary"  itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container">
				<div class="navigation-branding"><p class="main-title" itemprop="headline">
					<a href="https://www.linuxcapable.com/" rel="home">
						LinuxCapable
					</a>
				</p></div><form method="get" class="search-form navigation-search" action="https://www.linuxcapable.com/">
					<input type="search" class="search-field" value="" name="s" title="Search" />
				</form>				<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="gp-icon icon-menu-bars"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 96c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24zm0 160c0-13.255 10.745-24 24-24h464c13.255 0 24 10.745 24 24s-10.745 24-24 24H24c-13.255 0-24-10.745-24-24z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span><span class="mobile-menu">Menu</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-primary-marketer" class=" menu sf-menu"><li id="menu-item-42" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-42"><a href="https://www.linuxcapable.com/">Home</a></li>
<li id="menu-item-16629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16629"><a>Distro Tutorials<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-16635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16635"><a href="https://www.linuxcapable.com/distro-tutorials/almalinux/">AlmaLinux</a></li>
	<li id="menu-item-16995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16995"><a href="https://www.linuxcapable.com/distro-tutorials/centos-stream/">CentOS Stream</a></li>
	<li id="menu-item-16631" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16631"><a href="https://www.linuxcapable.com/distro-tutorials/debian/">Debian</a></li>
	<li id="menu-item-16632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16632"><a href="https://www.linuxcapable.com/distro-tutorials/fedora/">Fedora</a></li>
	<li id="menu-item-16634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16634"><a href="https://www.linuxcapable.com/distro-tutorials/linux-mint/">Linux Mint</a></li>
	<li id="menu-item-16636" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16636"><a href="https://www.linuxcapable.com/distro-tutorials/opensuse/">openSUSE</a></li>
	<li id="menu-item-16633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16633"><a href="https://www.linuxcapable.com/distro-tutorials/rocky-linux/">Rocky Linux</a></li>
	<li id="menu-item-16630" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16630"><a href="https://www.linuxcapable.com/distro-tutorials/ubuntu/">Ubuntu</a></li>
	<li id="menu-item-16637" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16637"><a href="https://www.linuxcapable.com/distro-tutorials/pop_os/">Pop!_OS</a></li>
</ul>
</li>
<li id="menu-item-16638" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16638"><a>General Tutorials<span role="presentation" class="dropdown-menu-toggle"><span class="gp-icon icon-arrow"><svg viewBox="0 0 330 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M305.913 197.085c0 2.266-1.133 4.815-2.833 6.514L171.087 335.593c-1.7 1.7-4.249 2.832-6.515 2.832s-4.815-1.133-6.515-2.832L26.064 203.599c-1.7-1.7-2.832-4.248-2.832-6.514s1.132-4.816 2.832-6.515l14.162-14.163c1.7-1.699 3.966-2.832 6.515-2.832 2.266 0 4.815 1.133 6.515 2.832l111.316 111.317 111.316-111.317c1.7-1.699 4.249-2.832 6.515-2.832s4.815 1.133 6.515 2.832l14.162 14.163c1.7 1.7 2.833 4.249 2.833 6.515z" /></svg></span></span></a>
<ul class="sub-menu">
	<li id="menu-item-16639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16639"><a href="https://www.linuxcapable.com/general-tutorials/cms-tutorials/">CMS Tutorials</a></li>
	<li id="menu-item-16640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16640"><a href="https://www.linuxcapable.com/general-tutorials/commands-tips/">Commands/Tips</a></li>
	<li id="menu-item-16641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16641"><a href="https://www.linuxcapable.com/general-tutorials/server-tutorials/">Server Tutorials</a></li>
</ul>
</li>
</ul></div><div class="menu-bar-items"><span class="menu-bar-item search-item"><a aria-label="Open Search Bar" href="#"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M71.029 71.029c9.373-9.372 24.569-9.372 33.942 0L256 222.059l151.029-151.03c9.373-9.372 24.569-9.372 33.942 0 9.372 9.373 9.372 24.569 0 33.942L289.941 256l151.03 151.029c9.372 9.373 9.372 24.569 0 33.942-9.373 9.372-24.569 9.372-33.942 0L256 289.941l-151.029 151.03c-9.373 9.372-24.569 9.372-33.942 0-9.372-9.373-9.372-24.569 0-33.942L222.059 256 71.029 104.971c-9.372-9.373-9.372-24.569 0-33.942z" /></svg></span></a></span></div>			</div>
		</nav>
		
	<div class="site grid-container container hfeed" id="page">
				<div class="site-content" id="content">
			
	<div class="content-area" id="primary">
		<main class="site-main" id="main">
			
<article id="post-17692" class="post-17692 post type-post status-publish format-standard has-post-thumbnail hentry category-opensuse tag-mariadb tag-opensuse-leap-15 post-ftoc" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
		<div class="featured-image  page-header-image-single ">
				<img width="1024" height="576" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-1024x576.png.webp" class="attachment-large size-large" alt="How to Install MariaDB 10.7 on openSUSE Leap 15" itemprop="image" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-1024x576.png.webp 1024w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-300x169.png.webp 300w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-768x432.png.webp 768w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-1536x864.png.webp 1536w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/Install-MariaDB-on-openSUSE-Leap-15-2048x1152.png.webp 2048w" sizes="(max-width: 1024px) 100vw, 1024px" />
			</div>			<header class="entry-header" aria-label="Content">
				<h1 class="entry-title" itemprop="headline">How to Install MariaDB 10.7 on openSUSE Leap 15</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2021-12-28T09:54:16+08:00" itemprop="datePublished">Tuesday, December 28, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.linuxcapable.com/author/josh/" title="View all posts by Joshua James" rel="author" itemprop="url"><span class="author-name" itemprop="name">Joshua James</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			<div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/'><div class='heateor_sss_sharing_title' style="font-weight:bold" ></div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff"/></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015" title="LinkedIn" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z"/></svg></span></a><a class="heateor_sss_whatsapp" href="https://api.whatsapp.com/send?text=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015 https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Whatsapp" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#55eb4c;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-6 -5 40 40"><path class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke="#fff" stroke-width="2" fill="none" d="M 11.579798566743314 24.396926207859085 A 10 10 0 1 0 6.808479557110079 20.73576436351046"></path><path d="M 7 19 l -1 6 l 6 -1" class="heateor_sss_no_fill heateor_sss_svg_stroke" stroke="#fff" stroke-width="2" fill="none"></path><path d="M 10 10 q -1 8 8 11 c 5 -1 0 -6 -1 -3 q -4 -3 -5 -5 c 4 -2 -1 -5 -1 -4" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_telegram" href="https://telegram.me/share/url?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&text=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015" title="Telegram" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_telegram" style="background-color:#3da5f1;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M25.515 6.896L6.027 14.41c-1.33.534-1.322 1.276-.243 1.606l5 1.56 1.72 5.66c.226.625.115.873.77.873.506 0 .73-.235 1.012-.51l2.43-2.363 5.056 3.734c.93.514 1.602.25 1.834-.863l3.32-15.638c.338-1.363-.52-1.98-1.41-1.577z"></path></svg></span></a><a class="heateor_sss_button_tumblr" href="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015&caption=" title="Tumblr" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg aheateor_sss_s__default heateor_sss_s_tumblr" style="background-color:#29435d;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 36 36"><path fill="#fff" d="M20.775 21.962c-.37.177-1.08.33-1.61.345-1.598.043-1.907-1.122-1.92-1.968v-6.217h4.007V11.1H17.26V6.02h-2.925s-.132.044-.144.15c-.17 1.556-.895 4.287-3.923 5.378v2.578h2.02v6.522c0 2.232 1.647 5.404 5.994 5.33 1.467-.025 3.096-.64 3.456-1.17l-.96-2.846z"/></svg></span></a><a class="heateor_sss_button_copy_link" title="Copy Link" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_copy_link" style="background-color:#ffc112;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 40 40"><path fill="#fff" d="M24.412 21.177c0-.36-.126-.665-.377-.917l-2.804-2.804a1.235 1.235 0 0 0-.913-.378c-.377 0-.7.144-.97.43.026.028.11.11.255.25.144.14.24.236.29.29s.117.14.2.256c.087.117.146.232.177.344.03.112.046.236.046.37 0 .36-.126.666-.377.918a1.25 1.25 0 0 1-.918.377 1.4 1.4 0 0 1-.373-.047 1.062 1.062 0 0 1-.345-.175 2.268 2.268 0 0 1-.256-.2 6.815 6.815 0 0 1-.29-.29c-.14-.142-.223-.23-.25-.254-.297.28-.445.607-.445.984 0 .36.126.664.377.916l2.778 2.79c.243.243.548.364.917.364.36 0 .665-.118.917-.35l1.982-1.97c.252-.25.378-.55.378-.9zm-9.477-9.504c0-.36-.126-.665-.377-.917l-2.777-2.79a1.235 1.235 0 0 0-.913-.378c-.35 0-.656.12-.917.364L7.967 9.92c-.254.252-.38.553-.38.903 0 .36.126.665.38.917l2.802 2.804c.242.243.547.364.916.364.377 0 .7-.14.97-.418-.026-.027-.11-.11-.255-.25s-.24-.235-.29-.29a2.675 2.675 0 0 1-.2-.255 1.052 1.052 0 0 1-.176-.344 1.396 1.396 0 0 1-.047-.37c0-.36.126-.662.377-.914.252-.252.557-.377.917-.377.136 0 .26.015.37.046.114.03.23.09.346.175.117.085.202.153.256.2.054.05.15.148.29.29.14.146.222.23.25.258.294-.278.442-.606.442-.983zM27 21.177c0 1.078-.382 1.99-1.146 2.736l-1.982 1.968c-.745.75-1.658 1.12-2.736 1.12-1.087 0-2.004-.38-2.75-1.143l-2.777-2.79c-.75-.747-1.12-1.66-1.12-2.737 0-1.106.392-2.046 1.183-2.818l-1.186-1.185c-.774.79-1.708 1.186-2.805 1.186-1.078 0-1.995-.376-2.75-1.13l-2.803-2.81C5.377 12.82 5 11.903 5 10.826c0-1.08.382-1.993 1.146-2.738L8.128 6.12C8.873 5.372 9.785 5 10.864 5c1.087 0 2.004.382 2.75 1.146l2.777 2.79c.75.747 1.12 1.66 1.12 2.737 0 1.105-.392 2.045-1.183 2.817l1.186 1.186c.774-.79 1.708-1.186 2.805-1.186 1.078 0 1.995.377 2.75 1.132l2.804 2.804c.754.755 1.13 1.672 1.13 2.75z"/></svg></span></a><a class="heateor_sss_email" onclick="window.open('mailto:?subject=' + decodeURIComponent('How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F' ), '_blank')" title="Email" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#649a3f;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 43 43"><path d="M 5.5 11 h 23 v 1 l -11 6 l -11 -6 v -1 m 0 2 l 11 6 l 11 -6 v 11 h -22 v -11" stroke-width="1" fill="#fff"></path></svg></span></a><a class="heateor_sss_pinboard" href="https://pinboard.in/popup_login/?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015&later=&description=&next=same" title="Pinboard" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#1341de;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M17.357 18.913l-5.01 5.014.88-4.5-6.588-8.075-3.48.044 4.314-4.313 4.035-4.04V6.85l7.795 6.403 4.502-.786-4.876 4.87 9.908 11.62"></path></svg></span></a><a class="heateor_sss_button_instagram" href="https://www.instagram.com/" title="Instagram" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#53beee;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" version="1.1" viewBox="-10 -10 148 148" width="100%" height="100%" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g><g><path d="M86,112H42c-14.336,0-26-11.663-26-26V42c0-14.337,11.664-26,26-26h44c14.337,0,26,11.663,26,26v44 C112,100.337,100.337,112,86,112z M42,24c-9.925,0-18,8.074-18,18v44c0,9.925,8.075,18,18,18h44c9.926,0,18-8.075,18-18V42 c0-9.926-8.074-18-18-18H42z" fill="#fff"></path></g><g><path d="M64,88c-13.234,0-24-10.767-24-24c0-13.234,10.766-24,24-24s24,10.766,24,24C88,77.233,77.234,88,64,88z M64,48c-8.822,0-16,7.178-16,16s7.178,16,16,16c8.822,0,16-7.178,16-16S72.822,48,64,48z" fill="#fff"></path></g><g><circle cx="89.5" cy="38.5" fill="#fff" r="5.5"></circle></g></g></svg></span></a><a class="heateor_sss_button_mail_ru" href="https://connect.mail.ru/share?share_url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Mail.Ru" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_mail_ru" style="background-color:#356fac;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M19.975 15.894c-.134-2.542-2.02-4.07-4.3-4.07h-.086c-2.63 0-4.09 2.068-4.09 4.417 0 2.633 1.765 4.296 4.077 4.296 2.58 0 4.275-1.89 4.4-4.127l-.003-.515zm-4.37-6.346c1.755 0 3.407.776 4.62 1.993v.006c0-.584.395-1.024.94-1.024h.14c.85 0 1.025.808 1.025 1.063l.005 9.08c-.06.595.613.9.988.52 1.457-1.497 3.203-7.702-.907-11.295-3.83-3.352-8.967-2.8-11.7-.916-2.904 2.003-4.764 6.438-2.958 10.603 1.968 4.543 7.6 5.896 10.947 4.546 1.696-.684 2.48 1.607.72 2.355-2.66 1.132-10.066 1.02-13.525-4.972-2.338-4.046-2.212-11.163 3.987-14.85 4.74-2.822 10.99-2.042 14.762 1.895 3.937 4.117 3.705 11.82-.137 14.818-1.742 1.36-4.326.035-4.312-1.947l-.02-.647c-1.21 1.203-2.824 1.905-4.58 1.905-3.475 0-6.53-3.056-6.53-6.528 0-3.508 3.057-6.6 6.533-6.6"/></svg></span></a><a class="heateor_sss_button_diaspora" href="https://joindiaspora.com/bookmarklet?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015&v=1&" title="Diaspora" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_diaspora" style="background-color:#2e3436;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-1 -1 34 34"><path fill="#fff" d="M13.498 6.49v6.258l-5.953-1.933L6 15.57l5.95 1.934-3.677 5.063 4.046 2.942L16 20.44l3.68 5.064 4.047-2.943L20.05 17.5 26 15.57l-1.545-4.755-5.953 1.933V6.49h-5.004z"/></svg></span></a><a class="heateor_sss_button_vkontakte" href="https://vk.com/share.php?&url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Vkontakte" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_vkontakte" style="background-color:#5e84ac;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-1 -2 34 34"><path fill-rule="evenodd" clip-rule="evenodd" fill="#fff" d="M15.764 22.223h1.315s.394-.044.6-.262c.184-.2.18-.574.18-.574s-.03-1.764.79-2.023c.81-.255 1.844 1.705 2.942 2.46.832.57 1.464.445 1.464.445l2.936-.04s1.538-.097.81-1.304c-.06-.1-.426-.894-2.186-2.526-1.843-1.71-1.594-1.434.624-4.39 1.353-1.804 1.893-2.902 1.724-3.374-.16-.45-1.153-.33-1.153-.33l-3.306.02s-.247-.034-.428.074c-.178.108-.293.356-.293.356s-.522 1.394-1.223 2.58c-1.47 2.5-2.06 2.633-2.3 2.476-.563-.36-.42-1.454-.42-2.23 0-2.423.365-3.435-.72-3.696-.357-.085-.623-.143-1.544-.15-1.182-.014-2.18.003-2.743.28-.378.185-.667.595-.49.62.218.027.713.13.975.49.34.46.33 1.496.33 1.496s.193 2.852-.46 3.206c-.442.245-1.056-.252-2.37-2.52-.67-1.163-1.18-2.446-1.18-2.446s-.1-.24-.273-.37c-.212-.155-.506-.204-.506-.204l-3.145.02s-.473.015-.647.22c-.154.183-.01.56-.01.56s2.46 5.757 5.245 8.657c2.553 2.66 5.454 2.485 5.454 2.485z"/></svg></span></a><a class="heateor_sss_button_skype" href="https://web.skype.com/share?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Skype" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_skype" style="background-color:#00aff0;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" d="M27.15 18c-.007.04-.012.084-.02.126l-.04-.24.06.113c.124-.678.19-1.37.19-2.06 0-1.53-.3-3.013-.892-4.41a11.273 11.273 0 0 0-2.43-3.602 11.288 11.288 0 0 0-8.012-3.32c-.72 0-1.443.068-2.146.203h-.005c.04.023.08.04.118.063l-.238-.037c.04-.01.08-.018.12-.026a6.717 6.717 0 0 0-3.146-.787 6.67 6.67 0 0 0-4.748 1.965A6.7 6.7 0 0 0 4 10.738c0 1.14.293 2.262.844 3.253.007-.04.012-.08.02-.12l.04.238-.06-.114c-.112.643-.17 1.3-.17 1.954a11.285 11.285 0 0 0 3.32 8.012c1.04 1.04 2.25 1.86 3.602 2.43 1.397.592 2.882.89 4.412.89.666 0 1.334-.06 1.985-.175-.038-.02-.077-.04-.116-.063l.242.04c-.046.01-.088.015-.13.02a6.68 6.68 0 0 0 3.3.87 6.661 6.661 0 0 0 4.743-1.963A6.666 6.666 0 0 0 28 21.26c0-1.145-.295-2.27-.85-3.264zm-11.098 4.885c-4.027 0-5.828-1.98-5.828-3.463 0-.76.562-1.294 1.336-1.294 1.723 0 1.277 2.474 4.49 2.474 1.647 0 2.556-.893 2.556-1.808 0-.55-.27-1.16-1.355-1.426l-3.58-.895c-2.88-.723-3.405-2.282-3.405-3.748 0-3.043 2.865-4.186 5.556-4.186 2.478 0 5.4 1.37 5.4 3.192 0 .783-.677 1.237-1.45 1.237-1.472 0-1.2-2.035-4.163-2.035-1.47 0-2.285.666-2.285 1.618 0 .95 1.16 1.254 2.17 1.484l2.65.587c2.905.647 3.64 2.342 3.64 3.94 0 2.47-1.895 4.318-5.726 4.318z"></path></svg></span></a><a class="heateor_sss_button_slashdot" href="//slashdot.org/submission?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="Slashdot" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_slashdot" style="background-color:#004242;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><g fill="#fff"><path d="M20.89 6h-5L8.61 26h5"/><circle cx="20.89" cy="23.5" r="2.5"/></g></svg></span></a><a class="heateor_sss_MeWe" href="https://mewe.com/share?link=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F" title="MeWe" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#007da1;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -3 38 38"><g fill="#fff"><path d="M9.636 10.427a1.22 1.22 0 1 1-2.44 0 1.22 1.22 0 1 1 2.44 0zM15.574 10.431a1.22 1.22 0 0 1-2.438 0 1.22 1.22 0 1 1 2.438 0zM22.592 10.431a1.221 1.221 0 1 1-2.443 0 1.221 1.221 0 0 1 2.443 0zM29.605 10.431a1.221 1.221 0 1 1-2.442 0 1.221 1.221 0 0 1 2.442 0zM3.605 13.772c0-.471.374-.859.859-.859h.18c.374 0 .624.194.789.457l2.935 4.597 2.95-4.611c.18-.291.43-.443.774-.443h.18c.485 0 .859.387.859.859v8.113a.843.843 0 0 1-.859.845.857.857 0 0 1-.845-.845V16.07l-2.366 3.559c-.18.276-.402.443-.72.443-.304 0-.526-.167-.706-.443l-2.354-3.53V21.9c0 .471-.374.83-.845.83a.815.815 0 0 1-.83-.83v-8.128h-.001zM14.396 14.055a.9.9 0 0 1-.069-.333c0-.471.402-.83.872-.83.415 0 .735.263.845.624l2.23 6.66 2.187-6.632c.139-.402.428-.678.859-.678h.124c.428 0 .735.278.859.678l2.187 6.632 2.23-6.675c.126-.346.415-.609.83-.609.457 0 .845.361.845.817a.96.96 0 0 1-.083.346l-2.867 8.032c-.152.43-.471.706-.887.706h-.165c-.415 0-.721-.263-.872-.706l-2.161-6.328-2.16 6.328c-.152.443-.47.706-.887.706h-.165c-.415 0-.72-.263-.887-.706l-2.865-8.032z"></path></g></svg></span></a><a class="heateor_sss_button_pocket" href="https://readitlaterlist.com/save?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015" title="Pocket" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg aheateor_sss_s__default heateor_sss_s_pocket" style="background-color:#f0f0f0;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 -1 32 32"><path fill="#fff" d="M16.005 6.244c2.927 0 5.854-.002 8.782 0 1.396.002 2.195.78 2.188 2.165-.015 2.485.116 4.987-.11 7.456-.75 8.204-10.027 12.607-16.91 8.064-3.086-2.036-4.82-4.925-4.917-8.672-.06-2.34-.034-4.684-.018-7.025.008-1.214.812-1.98 2.056-1.983 2.975-.01 5.952-.004 8.93-.006zm-5.037 5.483c-.867.093-1.365.396-1.62 1.025-.27.67-.078 1.256.417 1.732 1.688 1.62 3.378 3.238 5.09 4.838.745.695 1.537.687 2.278-.01 1.654-1.55 3.298-3.112 4.93-4.686.827-.797.91-1.714.252-2.38-.694-.704-1.583-.647-2.447.17-1.097 1.04-2.215 2.06-3.266 3.143-.485.494-.77.434-1.227-.025-1.1-1.107-2.234-2.18-3.39-3.225-.325-.29-.77-.447-1.017-.583z"></path></svg></span></a><a class="heateor_sss_button_digg" href="http://digg.com/submit?url=https%3A%2F%2Fwww.linuxcapable.com%2Fhow-to-install-mariadb-10-7-on-opensuse-leap-15%2F&title=How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015" title="Digg" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_digg" style="background-color:#006094;width:25px;height:25px;border-radius:999px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;border-radius:999px;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 49 49"><path class="heateor_sss_svg_stroke heateor_sss_no_fill" d="M 6 20 h 10 c 0 -14 -9 -14 -9 0 m 5 0 v 7 m -1 0 v -7 m 4 -7 h 4.5 v -5 h 8 v 8 h -8 v -3 m 8 0 h 4 v 5.5 h -3 v 12 h -4 v -8 m 0 8 h -6.5 v -12 h -2" stroke-width="2" stroke="#fff" fill="none"></path><ellipse cx="11.5" cy="28.5" rx="4" ry="2" fill="#fff"></ellipse></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:25px;height:25px;border-radius:999px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://www.linuxcapable.com/how-to-install-mariadb-10-7-on-opensuse-leap-15/', 'How%20to%20Install%20MariaDB%2010.7%20on%20openSUSE%20Leap%2015', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;border-radius:999px;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div><div id="ftwp-postcontent">
<p><a href="https://mariadb.com/" target="_blank" rel="noreferrer noopener"><strong>MariaDB</strong></a>&nbsp;is one of the most popular open-source databases next to its originator&nbsp;<strong>MySQL</strong>. The original creators of&nbsp;<strong>MySQL&nbsp;</strong>developed&nbsp;<strong>MariaDB</strong>&nbsp;in response to fears that&nbsp;<strong>MySQL</strong>&nbsp;would suddenly become a paid service due to Oracle acquiring it in 2010. With its history of doing similar tactics, the developers behind MariaDB have promised to keep it open source and free from such fears as what has happened to&nbsp;<strong>MySQL</strong>.</p>



<p><strong>MariaDB</strong>&nbsp;has become just as popular as&nbsp;<strong>MySQL</strong>&nbsp;with developers, with advanced clustering with&nbsp;<strong>Galera Cluster 4</strong>, faster cache/indexes, storage engines, and features/extensions that you won’t find in&nbsp;<strong>MySQL</strong>.</p>



<p>In the following tutorial, you will learn <strong>how to install MariaDB 10.7 on openSUSE Leap 15.</strong></p>



<div id="ftwp-container-outer" class="ftwp-in-post ftwp-float-center"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-middle-right"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-medium" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-number"></span></button><nav id="ftwp-contents" class="ftwp-shape-square ftwp-border-medium"><header id="ftwp-header"><span id="ftwp-header-control" class="ftwp-icon-number"></span><button type="button" id="ftwp-header-minimize" class="ftwp-icon-expand" aria-labelledby="ftwp-header-title" aria-label="Expand or collapse"></button><h3 id="ftwp-header-title">Contents</h3></header><ol id="ftwp-list" class="ftwp-liststyle-decimal ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first ftwp-colexp ftwp-colexp-icon"><li class="ftwp-item ftwp-has-sub ftwp-expand"><button type="button" aria-label="Expand or collapse" class="ftwp-icon-expand"></button><a class="ftwp-anchor" href="#ftoc-heading-1"><span class="ftwp-text">Prerequisites</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-2"><span class="ftwp-text">Update Operating System</span></a></li></ol></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-6"><span class="ftwp-text">Import MariaDB 10.7 Repository</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-7"><span class="ftwp-text">Install MariaDB 10.7 on openSUSE</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-8"><span class="ftwp-text">Check MariaDB 10.7 Service Status</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-9"><span class="ftwp-text">Secure MariaDB 10.7 with Security Script</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-10"><span class="ftwp-text">Login to MariaDB 10.7 Instance</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-11"><span class="ftwp-text">How to Remove (Uninstall) MariaDB 10.7</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#ftoc-heading-12"><span class="ftwp-text">Comments and Conclusion</span></a></li></ol></nav></div></div><h2 id="ftoc-heading-1" class="ftwp-heading">Prerequisites</h2>



<ul><li><strong>Recommended OS:</strong> <a href="https://get.opensuse.org/" target="_blank" rel="noreferrer noopener">openSUSE Leap – 15.x</a>.</li><li><strong>User account:</strong> A user account with sudo or root access.</li><li><strong>Required Packages: </strong>wget</li></ul>



<h3 id="ftoc-heading-2" class="ftwp-heading">Update Operating System</h3>



<p>Update your&nbsp;<strong>openSUSE</strong>&nbsp;operating system to make sure all existing packages are up to date:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper refresh</code></pre>



<p>Once refreshed, run the update command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper update</code></pre>



<p>The tutorial will be using the<strong> sudo command</strong> and <strong>assuming you have sudo status</strong>.</p>



<p>To verify sudo status on your account:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo whoami</code></pre>



<p><em>Example output showing sudo status:</em></p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">[joshua@opensuse ~]$ sudo whoami
root</code></pre>



<p>To set up an existing or new sudo account, visit our tutorial on&nbsp;<a href="https://www.linuxcapable.com/how-to-add-a-user-to-sudoers-on-opensuse/"><strong>adding a User to Sudoers on openSUSE</strong>.</a></p>



<p>To use the&nbsp;<strong>root account</strong>, use the following command with the root password to log in.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">su</code></pre>



<div class='code-block code-block-3 code-block-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div class="ai-attributes">
<div class="code-block-label">Advertisement</div>
</div>
<!-- in article option 1 - display -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="5616595120"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2 id="ftoc-heading-6" class="ftwp-heading">Import MariaDB 10.7 Repository</h2>



<p>The first task is to import the MariaDB 10.7 repository, but first, you need to import the MariaDB GPG keys to verify the authenticity of the installed packages.</p>



<p>Use the following command to download the GPG keys required in your terminal.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo rpm --import https://yum.mariadb.org/RPM-GPG-KEY-MariaDB</code></pre>



<p>Next, import the GPG keys from MariaDB and refresh.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper --gpg-auto-import-keys refresh</code></pre>



<p>Next, import the 10.7 repositories.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper addrepo --gpgcheck --refresh https://yum.mariadb.org/10.7/opensuse/15/x86_64 mariadb</code></pre>



<p><em>Example output:</em></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/12/import-mariadb-10.7-repository-opensuse-leap-15.png" data-lbwps-width="706" data-lbwps-height="353"><img width="706" height="353" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/import-mariadb-10.7-repository-opensuse-leap-15.png.webp" alt="How to Install MariaDB 10.7 on openSUSE Leap 15" class="wp-image-17697" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/import-mariadb-10.7-repository-opensuse-leap-15.png.webp 706w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/import-mariadb-10.7-repository-opensuse-leap-15-300x150.png.webp 300w" sizes="(max-width: 706px) 100vw, 706px" /></a></figure></div>



<p><strong>Type Y,</strong> then press the <strong>ENTER KEY</strong> to proceed and complete the import.</p>



<p>Note, you may notice repositories like 10.7.1 in the MariaDB repository. Using the standard 10.7 will automatically keep your version upgraded to the latest repositories. You do not need to add each repository to receive updates.</p>



<p>Optionally, you can run the following command to ensure your repository caches are up to date.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper refresh</code></pre>



<h2 id="ftoc-heading-7" class="ftwp-heading">Install MariaDB 10.7 on openSUSE</h2>



<p>To install MariaDB, you will need to install the client and the server packages. This can be done as follows:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper install MariaDB-server MariaDB-client</code></pre>



<p><em>Example output:</em></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/12/install-mariadb-10.7-on-opensuse-leap-15.png" data-lbwps-width="706" data-lbwps-height="389"><img width="706" height="389" src="https://www.linuxcapable.com/wp-content/uploads/2021/12/install-mariadb-10.7-on-opensuse-leap-15.png" alt="How to Install MariaDB 10.7 on openSUSE Leap 15" class="wp-image-17698" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/12/install-mariadb-10.7-on-opensuse-leap-15.png 706w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/install-mariadb-10.7-on-opensuse-leap-15-300x165.png.webp 300w" sizes="(max-width: 706px) 100vw, 706px" /></a></figure></div>



<p><strong>Type Y</strong>&nbsp;and then press the&nbsp;<strong>ENTER KEY</strong>&nbsp;to proceed with the installation.</p>



<p>Confirm the installation of MariaDB by checking the version and build:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">mariadb --version</code></pre>



<p><em>Example output:</em></p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">mariadb  Ver 15.1 Distrib 10.7.1-MariaDB, for Linux (x86_64) using readline 5.1</code></pre>



<div class='code-block code-block-4 code-block-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div class="ai-attributes">
<div class="code-block-label">Advertisement</div>
</div>
<!-- in article option 2 - display -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="1868728286"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2 id="ftoc-heading-8" class="ftwp-heading">Check MariaDB 10.7 Service Status</h2>



<p>Now you have installed MariaDB, and you need first to enable the service.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl enable --now mariadb</code></pre>



<p><em>Example output:</em></p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">Created symlink /etc/systemd/system/multi-user.target.wants/mariadb.service → /usr/lib/systemd/system/mariadb.service.</code></pre>



<p>Next, verify the status of the database software by using the following <strong>systemctl command</strong>:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">systemctl status mariadb</code></pre>



<p><em>Example:</em></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/12/mariadb-10.7-systemctl-status-ok-opensuse-leap-15.png" data-lbwps-width="706" data-lbwps-height="389"><img width="706" height="389" src="https://www.linuxcapable.com/wp-content/uploads/2021/12/mariadb-10.7-systemctl-status-ok-opensuse-leap-15.png" alt="" class="wp-image-17699" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/12/mariadb-10.7-systemctl-status-ok-opensuse-leap-15.png 706w, https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/mariadb-10.7-systemctl-status-ok-opensuse-leap-15-300x165.png.webp 300w" sizes="(max-width: 706px) 100vw, 706px" /></a></figure></div>



<p>By default, you will find MariaDB status to be activated. If not, start MariaDB, use the following command:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl start mariadb</code></pre>



<p>To stop MariaDB:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl stop mariadb</code></pre>



<p>To enable MariaDB on system startup:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl enable mariadb</code></pre>



<p>To disable MariaDB on system startup:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl disable mariadb</code></pre>



<p>To restart the MariaDB service:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo systemctl restart mariadb</code></pre>



<h2 id="ftoc-heading-9" class="ftwp-heading">Secure MariaDB 10.7 with Security Script</h2>



<p>When installing <strong>MariaDB</strong> fresh, default settings are considered weak by most standards and cause concern for potentially allowing intrusion or exploiting hackers. A solution is to run the installation security script with the <strong>MariaDB</strong> installation.</p>



<p>First, use the following command to launch the&nbsp;<strong>(mysql_secure_installation)</strong>:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo mariadb-secure-installation</code></pre>



<p>Next, follow below:</p>



<ul><li>Setting the password for<strong>&nbsp;root&nbsp;</strong>accounts.</li><li>Removing root accounts that are accessible from outside the local host.</li><li>Removing anonymous-user accounts.</li><li>Removing the test database, which by default can be accessed by anonymous users.</li></ul>



<p>Note, you use&nbsp;<strong>(Y)</strong>&nbsp;to remove everything.</p>



<p><em>Example:</em></p>



<pre class="wp-block-code"><code lang="" class="">[joshua@opensuse-leap ~]$ sudo mariadb-secure-installation

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user. If you've just installed MariaDB, and
haven't set the root password yet, you should just press enter here.

Enter current password for root (enter for none): 
OK, successfully used password, moving on...

Setting the root password or using the unix_socket ensures that nobody
can log into the MariaDB root user without the proper authorisation.

You already have your root account protected, so you can safely answer 'n'.

Switch to unix_socket authentication [Y/n] <strong><strong><span class="has-inline-color has-contrast-2-color"><strong><span style="color:#9aff36" class="has-inline-color">Y</span><span style="color:#a75fff" class="has-inline-color"> &lt;---- Type Y then press the ENTER KEY.</span></strong></span></strong></strong>
Enabled successfully!
Reloading privilege tables..
 ... Success!


You already have your root account protected, so you can safely answer 'n'.

Change the root password? [Y/n] <strong><span class="has-inline-color has-contrast-2-color"><strong><span style="color:#9aff36" class="has-inline-color">Y</span><span style="color:#a75fff" class="has-inline-color"> &lt;---- Type Y then press the ENTER KEY.</span></strong></span></strong>
New password: 
Re-enter new password: 
Password updated successfully!
Reloading privilege tables..
 ... Success!


By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] <strong><span class="has-inline-color has-contrast-2-color"><strong><span style="color:#9aff36" class="has-inline-color">Y</span><span style="color:#a75fff" class="has-inline-color"> &lt;---- Type Y then press the ENTER KEY.</span></strong></span></strong>
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] <strong><span class="has-inline-color has-contrast-2-color"><strong><span style="color:#9aff36" class="has-inline-color">Y</span><span style="color:#a75fff" class="has-inline-color"> &lt;---- Type Y then press the ENTER KEY.</span></strong></span></strong>
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] <strong><span class="has-inline-color has-contrast-2-color"><strong><span style="color:#9aff36" class="has-inline-color">Y</span><span style="color:#a75fff" class="has-inline-color"> &lt;---- Type Y then press the ENTER KEY.</span></strong></span></strong>
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] <strong><span class="has-inline-color has-contrast-2-color"><strong><span style="color:#a75fff" class="has-inline-color"><strong><span style="color:#9aff36" class="has-inline-color">Y</span><span style="color:#a75fff" class="has-inline-color"> &lt;---- Type Y then press the ENTER KEY.</span></strong></span></strong></span></strong>
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!</code></pre>



<div class='code-block code-block-5 code-block-block-5' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div class="ai-attributes">
<div class="code-block-label">Advertisement</div>
</div>
<!-- in article option 3 - display -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="8242564942"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2 id="ftoc-heading-10" class="ftwp-heading">Login to MariaDB 10.7 Instance</h2>



<p>Now that you have completed the post-installation installation security script, login into your&nbsp;<strong>MariaDB</strong>&nbsp;database can be done using the following:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo mysql -u root -p</code></pre>



<p>You will be prompted to enter the root password that you set in either the installation setup or post-installation security script. Once inside the MySQL service instance, you can execute the following command as a test to see it in operation.</p>



<p>Type the following&nbsp;<strong>SHOW DATABASE command</strong>:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">SHOW DATABASES;</code></pre>



<p>For those new to MySQL, all commands syntax must end with “<strong>;</strong>”</p>



<p><em>Example:</em></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/12/mariadb-10.7-terminal-in-action-opensuse-leap-15.png" data-lbwps-width="706" data-lbwps-height="605"><img width="706" height="605" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/mariadb-10.7-terminal-in-action-opensuse-leap-15.png.webp" alt="How to Install MariaDB 10.7 on openSUSE Leap 15" class="wp-image-17700" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/mariadb-10.7-terminal-in-action-opensuse-leap-15.png.webp 706w,  https://www.linuxcapable.com/wp-content/uploads/2021/12/mariadb-10.7-terminal-in-action-opensuse-leap-15-300x257.png 300w" sizes="(max-width: 706px) 100vw, 706px" /></a></figure></div>



<p>TO&nbsp;<strong>(CREATE)</strong>&nbsp;a database, use the following command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">CREATE DATABASE MYDATATEST;</code></pre>



<p>To delete&nbsp;<strong>(DROP)</strong>&nbsp;a database, use the following command.</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">DROP DATABASE MYDATATEST;</code></pre>



<p>To exit the terminal, type the following&nbsp;&nbsp;<strong>exit command</strong>&nbsp;:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">EXIT;</code></pre>



<h2 id="ftoc-heading-11" class="ftwp-heading">How to Remove (Uninstall) MariaDB 10.7</h2>



<p>If you no longer wish to use MariaDB and want to remove it in full, execute the following command:</p>



<pre class="wp-block-code"><code lang="bash" class="language-bash">sudo zypper remove MariaDB*</code></pre>



<p><em>Example output:</em></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://www.linuxcapable.com/wp-content/uploads/2021/12/remove-mariadb-10.7-from-opensuse-leap-15.png" data-lbwps-width="706" data-lbwps-height="281"><img width="706" height="281" src="https://www.linuxcapable.com/wp-content/uploads/2021/12/remove-mariadb-10.7-from-opensuse-leap-15.png" alt="How to Install MariaDB 10.7 on openSUSE Leap 15" class="wp-image-17701" srcset="https://www.linuxcapable.com/wp-content/uploads/2021/12/remove-mariadb-10.7-from-opensuse-leap-15.png 706w,  https://www.linuxcapable.com/wp-content/uploads/2021/12/remove-mariadb-10.7-from-opensuse-leap-15-300x119.png 300w" sizes="(max-width: 706px) 100vw, 706px" /></a></figure></div>



<p><strong>Type Y</strong>&nbsp;and then press the&nbsp;<strong>ENTER KEY</strong>&nbsp;to proceed with the uninstallation.</p>



<p>Note that this command will remove most of the unused dependencies in the MariaDB installation to help clean up your system.</p>



<div class='code-block code-block-6 code-block-block-6' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div class="ai-attributes">
<div class="code-block-label">Advertisement</div>
</div>
<!-- in article option 4 - display -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="8050993256"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2 id="ftoc-heading-12" class="ftwp-heading">Comments and Conclusion</h2>



<p>In the tutorial, you have learned how to install the latest MariaDB 10.7 Community release openSUSE Leap 15.</p>



<p>Overall, it would help if you upgraded from the old stable 10.5 as it’s pretty seasoned now compared to 10.6 if you are not moving to 10.7 just yet. There are considerable advantages in performance with upgrading. If you do upgrade, always back up your database before doing so to avoid countless hours of pain and utter frustration in anything to do with database maintenance or upgrades.</p>
</div>		</div>

				<footer class="entry-meta" aria-label="Entry meta">
			<span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://www.linuxcapable.com/distro-tutorials/opensuse/" rel="category tag">openSUSE</a></span> <span class="tags-links"><span class="gp-icon icon-tags"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M20 39.5c-8.836 0-16 7.163-16 16v176c0 4.243 1.686 8.313 4.687 11.314l224 224c6.248 6.248 16.378 6.248 22.626 0l176-176c6.244-6.244 6.25-16.364.013-22.615l-223.5-224A15.999 15.999 0 00196.5 39.5H20zm56 96c0-13.255 10.745-24 24-24s24 10.745 24 24-10.745 24-24 24-24-10.745-24-24z"/><path d="M259.515 43.015c4.686-4.687 12.284-4.687 16.97 0l228 228c4.686 4.686 4.686 12.284 0 16.97l-180 180c-4.686 4.687-12.284 4.687-16.97 0-4.686-4.686-4.686-12.284 0-16.97L479.029 279.5 259.515 59.985c-4.686-4.686-4.686-12.284 0-16.97z" /></svg></span><span class="screen-reader-text">Tags </span><a href="https://www.linuxcapable.com/tag/mariadb/" rel="tag">MariaDB</a>, <a href="https://www.linuxcapable.com/tag/opensuse-leap-15/" rel="tag">openSUSE Leap 15</a></span> 		<nav id="nav-below" class="post-navigation" aria-label="Single Post">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" /></svg></span><span class="prev" title="Previous"><a href="https://www.linuxcapable.com/how-to-install-open-vm-tools-on-pop_os/" rel="prev">How to Install Open VM Tools on Pop!_OS</a></span></div><div class="nav-next"><span class="gp-icon icon-arrow-right"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 256.001c0 2.266-1.133 4.815-2.832 6.515L43.599 394.509c-1.7 1.7-4.248 2.833-6.514 2.833s-4.816-1.133-6.515-2.833l-14.163-14.162c-1.699-1.7-2.832-3.966-2.832-6.515 0-2.266 1.133-4.815 2.832-6.515l111.317-111.316L16.407 144.685c-1.699-1.7-2.832-4.249-2.832-6.515s1.133-4.815 2.832-6.515l14.163-14.162c1.7-1.7 4.249-2.833 6.515-2.833s4.815 1.133 6.514 2.833l131.994 131.993c1.7 1.7 2.832 4.249 2.832 6.515z" fill-rule="nonzero" /></svg></span><span class="next" title="Next"><a href="https://www.linuxcapable.com/how-to-install-mysql-8-0-on-opensuse-leap-15/" rel="next">How to Install MySQL 8.0 on openSUSE Leap 15</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-install-mariadb-10-7-on-opensuse-leap-15/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.linuxcapable.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" required></textarea></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-form-comment-subscribe"><label for="cren_subscribe_to_comment"><input id="cren_subscribe_to_comment" name="cren_subscribe_to_comment" type="checkbox" value="on" checked>Notify me via e-mail if anyone answers my comment.</label></p>
<p class="comment-form-comment-subscribe"><label for="cren_gdpr"><input id="cren_gdpr" name="cren_gdpr" type="checkbox" value="yes" required="required">I consent to LinuxCapable collecting and storing the data I submit in this form. <a target='_blank' href='https://www.linuxcapable.com/privacy-policy-statement/'>(Privacy Policy)</a> <span class="required">*</span></label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='17692' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div class="widget-area sidebar is-right-sidebar" id="right-sidebar">
	<div class="inside-right-sidebar">
		<aside id="block-16" class="widget inner-padding widget_block">
<div class="wp-block-group zoom-social-icons-widget zoom-social-icons-legacy-widget-group"><div class="wp-block-group__inner-container">
<h3><strong>Follow Me</strong></h3>



<div class="wp-block-wpzoom-blocks-social-icons is-style-with-label-canvas-rounded" style="--wpz-social-icons-block-item-font-size:20px;--wpz-social-icons-block-item-padding-horizontal:5px;--wpz-social-icons-block-item-padding-vertical:5px;--wpz-social-icons-block-item-margin-horizontal:5px;--wpz-social-icons-block-item-margin-vertical:5px;--wpz-social-icons-block-item-border-radius:50px;--wpz-social-icons-block-label-font-size:15px;--wpz-social-icons-block-label-color:#fff;--wpz-social-icons-block-label-color-hover:#fff;--wpz-social-icons-alignment:flex-start"><a href="https://www.facebook.com/LinuxCapable/" class="social-icon-link" target="_blank" rel="noopener noreferrer" style="--wpz-social-icons-block-item-color:#3b5998;--wpz-social-icons-block-item-color-hover:#6c7993"><span class="social-icon socicon socicon-facebook"></span><span class="icon-label">Facebook</span></a><a href="https://twitter.com/linuxcapable/" class="social-icon-link" target="_blank" rel="noopener noreferrer" style="--wpz-social-icons-block-item-color:#55acee;--wpz-social-icons-block-item-color-hover:#96cffa"><span class="social-icon socicon socicon-twitter"></span><span class="icon-label">Twitter</span></a><a href="https://www.linuxcapable.com/feed/" class="social-icon-link" target="_blank" rel="noopener noreferrer" style="--wpz-social-icons-block-item-color:#ff7300;--wpz-social-icons-block-item-color-hover:#ffa041"><span class="social-icon socicon socicon-rss"></span><span class="icon-label">RSS</span></a><a href="https://www.pinterest.com/linuxcapable/" class="social-icon-link" target="_blank" rel="noopener noreferrer" style="--wpz-social-icons-block-item-color:#e50c14;--wpz-social-icons-block-item-color-hover:#f6918b"><span class="social-icon socicon socicon-pinterest"></span><span class="icon-label">Pinterest</span></a><a href="https://linuxcapable.tumblr.com/" class="social-icon-link" target="_blank" rel="noopener noreferrer" style="--wpz-social-icons-block-item-color:#001935;--wpz-social-icons-block-item-color-hover:#46617f"><span class="social-icon socicon socicon-tumblr"></span><span class="icon-label">Tumblr</span></a></div>



<hr class="wp-block-separator"/>



<h3><strong>Buy Me A Coffee</strong></h3>



<p><a href="https://www.buymeacoffee.com/linuxcapable" target="_blank"><img width="545" height="153" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2021/12/default-yellow.png.webp" alt="Buy Me A Coffee" style="height: 60px !important;width: 217px !important;"></a></p>
</div></div>
</aside><aside id="block-18" class="widget inner-padding widget_block">
<div class="wp-block-group"><div class="wp-block-group__inner-container">
<h3><strong>Choose Language</strong></h3>



<p><!-- GTranslate: https://gtranslate.io/ -->
<style>
.switcher {font-family:Arial;font-size:14pt;text-align:left;cursor:pointer;overflow:hidden;width:193px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:14pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#303030 linear-gradient(180deg, #474747 0%, #303030 70%);position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #161616;color:#f7f7f7;padding:3px 5px;width:181px;}
.switcher .selected a:after {height:32px;display:inline-block;position:absolute;right:10px;width:15px;background-position:50%;background-size:12px;background-image:url("data:image/svg+xml;utf8,<svg xmlns='http://www.w3.org/2000/svg' width='16' height='16' viewBox='0 0 285 285'><path d='M282 76.5l-14.2-14.3a9 9 0 0 0-13.1 0L142.5 174.4 30.3 62.2a9 9 0 0 0-13.2 0L3 76.5a9 9 0 0 0 0 13.1l133 133a9 9 0 0 0 13.1 0l133-133a9 9 0 0 0 0-13z' style='fill:%23f2f2f2'/></svg>");background-repeat:no-repeat;content:""!important;transition:all .2s;}
.switcher .selected a.open:after {-webkit-transform: rotate(-180deg);transform:rotate(-180deg);}
.switcher .selected a:hover {background:#3a3a3a}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #161616;border-right:1px solid #161616;border-bottom:1px solid #161616;background-color:#474747;display:none;width:191px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#eaeaea;padding:3px 5px;}
.switcher .option a:hover {background:#748393;}
.switcher .option a.selected {background:#748393;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#f5f5f5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/en-us.png" height="32" width="32" alt="en" /> English</a>
</div>
<div class="option">
<a href="https://af.linuxcapable.com" onclick="doGTranslate('en|af');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Afrikaans" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/af.png" height="32" width="32" alt="af" /> Afrikaans</a><a href="https://sq.linuxcapable.com" onclick="doGTranslate('en|sq');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Shqip" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sq.png" height="32" width="32" alt="sq" /> Shqip</a><a href="https://am.linuxcapable.com" onclick="doGTranslate('en|am');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="አማርኛ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/am.png" height="32" width="32" alt="am" /> አማርኛ</a><a href="https://ar.linuxcapable.com" onclick="doGTranslate('en|ar');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="العربية" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ar.png" height="32" width="32" alt="ar" /> العربية</a><a href="https://hy.linuxcapable.com" onclick="doGTranslate('en|hy');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Հայերեն" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/hy.png" height="32" width="32" alt="hy" /> Հայերեն</a><a href="https://az.linuxcapable.com" onclick="doGTranslate('en|az');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Azərbaycan dili" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/az.png" height="32" width="32" alt="az" /> Azərbaycan dili</a><a href="https://eu.linuxcapable.com" onclick="doGTranslate('en|eu');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Euskara" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/eu.png" height="32" width="32" alt="eu" /> Euskara</a><a href="https://be.linuxcapable.com" onclick="doGTranslate('en|be');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Беларуская мова" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/be.png" height="32" width="32" alt="be" /> Беларуская мова</a><a href="https://bn.linuxcapable.com" onclick="doGTranslate('en|bn');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="বাংলা" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/bn.png" height="32" width="32" alt="bn" /> বাংলা</a><a href="https://bs.linuxcapable.com" onclick="doGTranslate('en|bs');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Bosanski" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/bs.png" height="32" width="32" alt="bs" /> Bosanski</a><a href="https://bg.linuxcapable.com" onclick="doGTranslate('en|bg');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Български" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/bg.png" height="32" width="32" alt="bg" /> Български</a><a href="https://ca.linuxcapable.com" onclick="doGTranslate('en|ca');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Català" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ca.png" height="32" width="32" alt="ca" /> Català</a><a href="https://ceb.linuxcapable.com" onclick="doGTranslate('en|ceb');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Cebuano" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ceb.png" height="32" width="32" alt="ceb" /> Cebuano</a><a href="https://ny.linuxcapable.com" onclick="doGTranslate('en|ny');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Chichewa" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ny.png" height="32" width="32" alt="ny" /> Chichewa</a><a href="https://zh-CN.linuxcapable.com" onclick="doGTranslate('en|zh-CN');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="简体中文" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/zh-CN.png" height="32" width="32" alt="zh-CN" /> 简体中文</a><a href="https://zh-TW.linuxcapable.com" onclick="doGTranslate('en|zh-TW');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="繁體中文" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/zh-TW.png" height="32" width="32" alt="zh-TW" /> 繁體中文</a><a href="https://co.linuxcapable.com" onclick="doGTranslate('en|co');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Corsu" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/co.png" height="32" width="32" alt="co" /> Corsu</a><a href="https://hr.linuxcapable.com" onclick="doGTranslate('en|hr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Hrvatski" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/hr.png" height="32" width="32" alt="hr" /> Hrvatski</a><a href="https://cs.linuxcapable.com" onclick="doGTranslate('en|cs');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Čeština‎" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/cs.png" height="32" width="32" alt="cs" /> Čeština‎</a><a href="https://da.linuxcapable.com" onclick="doGTranslate('en|da');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Dansk" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/da.png" height="32" width="32" alt="da" /> Dansk</a><a href="https://nl.linuxcapable.com" onclick="doGTranslate('en|nl');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Nederlands" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/nl.png" height="32" width="32" alt="nl" /> Nederlands</a><a href="https://www.linuxcapable.com" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/en-us.png" height="32" width="32" alt="en" /> English</a><a href="https://eo.linuxcapable.com" onclick="doGTranslate('en|eo');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Esperanto" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/eo.png" height="32" width="32" alt="eo" /> Esperanto</a><a href="https://et.linuxcapable.com" onclick="doGTranslate('en|et');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Eesti" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/et.png" height="32" width="32" alt="et" /> Eesti</a><a href="https://tl.linuxcapable.com" onclick="doGTranslate('en|tl');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Filipino" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/tl.png" height="32" width="32" alt="tl" /> Filipino</a><a href="https://fi.linuxcapable.com" onclick="doGTranslate('en|fi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Suomi" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/fi.png" height="32" width="32" alt="fi" /> Suomi</a><a href="https://fr.linuxcapable.com" onclick="doGTranslate('en|fr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Français" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/fr-qc.png" height="32" width="32" alt="fr" /> Français</a><a href="https://fy.linuxcapable.com" onclick="doGTranslate('en|fy');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Frysk" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/fy.png" height="32" width="32" alt="fy" /> Frysk</a><a href="https://gl.linuxcapable.com" onclick="doGTranslate('en|gl');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Galego" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/gl.png" height="32" width="32" alt="gl" /> Galego</a><a href="https://ka.linuxcapable.com" onclick="doGTranslate('en|ka');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ქართული" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ka.png" height="32" width="32" alt="ka" /> ქართული</a><a href="https://de.linuxcapable.com" onclick="doGTranslate('en|de');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Deutsch" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/de.png" height="32" width="32" alt="de" /> Deutsch</a><a href="https://el.linuxcapable.com" onclick="doGTranslate('en|el');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Ελληνικά" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/el.png" height="32" width="32" alt="el" /> Ελληνικά</a><a href="https://gu.linuxcapable.com" onclick="doGTranslate('en|gu');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ગુજરાતી" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/gu.png" height="32" width="32" alt="gu" /> ગુજરાતી</a><a href="https://ht.linuxcapable.com" onclick="doGTranslate('en|ht');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Kreyol ayisyen" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ht.png" height="32" width="32" alt="ht" /> Kreyol ayisyen</a><a href="https://ha.linuxcapable.com" onclick="doGTranslate('en|ha');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Harshen Hausa" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ha.png" height="32" width="32" alt="ha" /> Harshen Hausa</a><a href="https://haw.linuxcapable.com" onclick="doGTranslate('en|haw');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Ōlelo Hawaiʻi" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/haw.png" height="32" width="32" alt="haw" /> Ōlelo Hawaiʻi</a><a href="https://iw.linuxcapable.com" onclick="doGTranslate('en|iw');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="עִבְרִית" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/iw.png" height="32" width="32" alt="iw" /> עִבְרִית</a><a href="https://hi.linuxcapable.com" onclick="doGTranslate('en|hi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="हिन्दी" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/hi.png" height="32" width="32" alt="hi" /> हिन्दी</a><a href="https://hmn.linuxcapable.com" onclick="doGTranslate('en|hmn');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Hmong" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/hmn.png" height="32" width="32" alt="hmn" /> Hmong</a><a href="https://hu.linuxcapable.com" onclick="doGTranslate('en|hu');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Magyar" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/hu.png" height="32" width="32" alt="hu" /> Magyar</a><a href="https://is.linuxcapable.com" onclick="doGTranslate('en|is');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Íslenska" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/is.png" height="32" width="32" alt="is" /> Íslenska</a><a href="https://ig.linuxcapable.com" onclick="doGTranslate('en|ig');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Igbo" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ig.png" height="32" width="32" alt="ig" /> Igbo</a><a href="https://id.linuxcapable.com" onclick="doGTranslate('en|id');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Bahasa Indonesia" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/id.png" height="32" width="32" alt="id" /> Bahasa Indonesia</a><a href="https://ga.linuxcapable.com" onclick="doGTranslate('en|ga');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Gaelige" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ga.png" height="32" width="32" alt="ga" /> Gaelige</a><a href="https://it.linuxcapable.com" onclick="doGTranslate('en|it');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Italiano" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/it.png" height="32" width="32" alt="it" /> Italiano</a><a href="https://ja.linuxcapable.com" onclick="doGTranslate('en|ja');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="日本語" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ja.png" height="32" width="32" alt="ja" /> 日本語</a><a href="https://jw.linuxcapable.com" onclick="doGTranslate('en|jw');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Basa Jawa" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/jw.png" height="32" width="32" alt="jw" /> Basa Jawa</a><a href="https://kn.linuxcapable.com" onclick="doGTranslate('en|kn');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ಕನ್ನಡ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/kn.png" height="32" width="32" alt="kn" /> ಕನ್ನಡ</a><a href="https://kk.linuxcapable.com" onclick="doGTranslate('en|kk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Қазақ тілі" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/kk.png" height="32" width="32" alt="kk" /> Қазақ тілі</a><a href="https://km.linuxcapable.com" onclick="doGTranslate('en|km');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ភាសាខ្មែរ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/km.png" height="32" width="32" alt="km" /> ភាសាខ្មែរ</a><a href="https://ko.linuxcapable.com" onclick="doGTranslate('en|ko');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="한국어" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ko.png" height="32" width="32" alt="ko" /> 한국어</a><a href="https://ku.linuxcapable.com" onclick="doGTranslate('en|ku');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="كوردی‎" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ku.png" height="32" width="32" alt="ku" /> كوردی‎</a><a href="https://ky.linuxcapable.com" onclick="doGTranslate('en|ky');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Кыргызча" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ky.png" height="32" width="32" alt="ky" /> Кыргызча</a><a href="https://lo.linuxcapable.com" onclick="doGTranslate('en|lo');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ພາສາລາວ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/lo.png" height="32" width="32" alt="lo" /> ພາສາລາວ</a><a href="https://la.linuxcapable.com" onclick="doGTranslate('en|la');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Latin" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/la.png" height="32" width="32" alt="la" /> Latin</a><a href="https://lv.linuxcapable.com" onclick="doGTranslate('en|lv');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Latviešu valoda" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/lv.png" height="32" width="32" alt="lv" /> Latviešu valoda</a><a href="https://lt.linuxcapable.com" onclick="doGTranslate('en|lt');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Lietuvių kalba" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/lt.png" height="32" width="32" alt="lt" /> Lietuvių kalba</a><a href="https://lb.linuxcapable.com" onclick="doGTranslate('en|lb');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Lëtzebuergesch" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/lb.png" height="32" width="32" alt="lb" /> Lëtzebuergesch</a><a href="https://mk.linuxcapable.com" onclick="doGTranslate('en|mk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Македонски јазик" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/mk.png" height="32" width="32" alt="mk" /> Македонски јазик</a><a href="https://mg.linuxcapable.com" onclick="doGTranslate('en|mg');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Malagasy" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/mg.png" height="32" width="32" alt="mg" /> Malagasy</a><a href="https://ms.linuxcapable.com" onclick="doGTranslate('en|ms');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Bahasa Melayu" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ms.png" height="32" width="32" alt="ms" /> Bahasa Melayu</a><a href="https://ml.linuxcapable.com" onclick="doGTranslate('en|ml');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="മലയാളം" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ml.png" height="32" width="32" alt="ml" /> മലയാളം</a><a href="https://mt.linuxcapable.com" onclick="doGTranslate('en|mt');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Maltese" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/mt.png" height="32" width="32" alt="mt" /> Maltese</a><a href="https://mi.linuxcapable.com" onclick="doGTranslate('en|mi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Te Reo Māori" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/mi.png" height="32" width="32" alt="mi" /> Te Reo Māori</a><a href="https://mr.linuxcapable.com" onclick="doGTranslate('en|mr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="मराठी" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/mr.png" height="32" width="32" alt="mr" /> मराठी</a><a href="https://mn.linuxcapable.com" onclick="doGTranslate('en|mn');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Монгол" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/mn.png" height="32" width="32" alt="mn" /> Монгол</a><a href="https://my.linuxcapable.com" onclick="doGTranslate('en|my');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ဗမာစာ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/my.png" height="32" width="32" alt="my" /> ဗမာစာ</a><a href="https://ne.linuxcapable.com" onclick="doGTranslate('en|ne');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="नेपाली" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ne.png" height="32" width="32" alt="ne" /> नेपाली</a><a href="https://no.linuxcapable.com" onclick="doGTranslate('en|no');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Norsk bokmål" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/no.png" height="32" width="32" alt="no" /> Norsk bokmål</a><a href="https://ps.linuxcapable.com" onclick="doGTranslate('en|ps');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="پښتو" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ps.png" height="32" width="32" alt="ps" /> پښتو</a><a href="https://fa.linuxcapable.com" onclick="doGTranslate('en|fa');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="فارسی" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/fa.png" height="32" width="32" alt="fa" /> فارسی</a><a href="https://pl.linuxcapable.com" onclick="doGTranslate('en|pl');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Polski" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/pl.png" height="32" width="32" alt="pl" /> Polski</a><a href="https://pt.linuxcapable.com" onclick="doGTranslate('en|pt');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Português" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/pt-br.png" height="32" width="32" alt="pt" /> Português</a><a href="https://pa.linuxcapable.com" onclick="doGTranslate('en|pa');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ਪੰਜਾਬੀ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/pa.png" height="32" width="32" alt="pa" /> ਪੰਜਾਬੀ</a><a href="https://ro.linuxcapable.com" onclick="doGTranslate('en|ro');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Română" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ro.png" height="32" width="32" alt="ro" /> Română</a><a href="https://ru.linuxcapable.com" onclick="doGTranslate('en|ru');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Русский" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ru.png" height="32" width="32" alt="ru" /> Русский</a><a href="https://sm.linuxcapable.com" onclick="doGTranslate('en|sm');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Samoan" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sm.png" height="32" width="32" alt="sm" /> Samoan</a><a href="https://gd.linuxcapable.com" onclick="doGTranslate('en|gd');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Gàidhlig" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/gd.png" height="32" width="32" alt="gd" /> Gàidhlig</a><a href="https://sr.linuxcapable.com" onclick="doGTranslate('en|sr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Српски језик" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sr.png" height="32" width="32" alt="sr" /> Српски језик</a><a href="https://st.linuxcapable.com" onclick="doGTranslate('en|st');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Sesotho" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/st.png" height="32" width="32" alt="st" /> Sesotho</a><a href="https://sn.linuxcapable.com" onclick="doGTranslate('en|sn');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Shona" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sn.png" height="32" width="32" alt="sn" /> Shona</a><a href="https://sd.linuxcapable.com" onclick="doGTranslate('en|sd');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="سنڌي" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sd.png" height="32" width="32" alt="sd" /> سنڌي</a><a href="https://si.linuxcapable.com" onclick="doGTranslate('en|si');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="සිංහල" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/si.png" height="32" width="32" alt="si" /> සිංහල</a><a href="https://sk.linuxcapable.com" onclick="doGTranslate('en|sk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Slovenčina" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sk.png" height="32" width="32" alt="sk" /> Slovenčina</a><a href="https://sl.linuxcapable.com" onclick="doGTranslate('en|sl');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Slovenščina" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sl.png" height="32" width="32" alt="sl" /> Slovenščina</a><a href="https://so.linuxcapable.com" onclick="doGTranslate('en|so');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Afsoomaali" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/so.png" height="32" width="32" alt="so" /> Afsoomaali</a><a href="https://es.linuxcapable.com" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Español" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/es-mx.png" height="32" width="32" alt="es" /> Español</a><a href="https://su.linuxcapable.com" onclick="doGTranslate('en|su');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Basa Sunda" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/su.png" height="32" width="32" alt="su" /> Basa Sunda</a><a href="https://sw.linuxcapable.com" onclick="doGTranslate('en|sw');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Kiswahili" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sw.png" height="32" width="32" alt="sw" /> Kiswahili</a><a href="https://sv.linuxcapable.com" onclick="doGTranslate('en|sv');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Svenska" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/sv.png" height="32" width="32" alt="sv" /> Svenska</a><a href="https://tg.linuxcapable.com" onclick="doGTranslate('en|tg');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Тоҷикӣ" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/tg.png" height="32" width="32" alt="tg" /> Тоҷикӣ</a><a href="https://ta.linuxcapable.com" onclick="doGTranslate('en|ta');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="தமிழ்" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ta.png" height="32" width="32" alt="ta" /> தமிழ்</a><a href="https://te.linuxcapable.com" onclick="doGTranslate('en|te');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="తెలుగు" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/te.png" height="32" width="32" alt="te" /> తెలుగు</a><a href="https://th.linuxcapable.com" onclick="doGTranslate('en|th');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="ไทย" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/th.png" height="32" width="32" alt="th" /> ไทย</a><a href="https://tr.linuxcapable.com" onclick="doGTranslate('en|tr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Türkçe" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/tr.png" height="32" width="32" alt="tr" /> Türkçe</a><a href="https://uk.linuxcapable.com" onclick="doGTranslate('en|uk');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Українська" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/uk.png" height="32" width="32" alt="uk" /> Українська</a><a href="https://ur.linuxcapable.com" onclick="doGTranslate('en|ur');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="اردو" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/ur.png" height="32" width="32" alt="ur" /> اردو</a><a href="https://uz.linuxcapable.com" onclick="doGTranslate('en|uz');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="O‘zbekcha" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/uz.png" height="32" width="32" alt="uz" /> O‘zbekcha</a><a href="https://vi.linuxcapable.com" onclick="doGTranslate('en|vi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Tiếng Việt" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/vi.png" height="32" width="32" alt="vi" /> Tiếng Việt</a><a href="https://cy.linuxcapable.com" onclick="doGTranslate('en|cy');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Cymraeg" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/cy.png" height="32" width="32" alt="cy" /> Cymraeg</a><a href="https://xh.linuxcapable.com" onclick="doGTranslate('en|xh');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="isiXhosa" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/xh.png" height="32" width="32" alt="xh" /> isiXhosa</a><a href="https://yi.linuxcapable.com" onclick="doGTranslate('en|yi');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="יידיש" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/yi.png" height="32" width="32" alt="yi" /> יידיש</a><a href="https://yo.linuxcapable.com" onclick="doGTranslate('en|yo');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Yorùbá" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/yo.png" height="32" width="32" alt="yo" /> Yorùbá</a><a href="https://zu.linuxcapable.com" onclick="doGTranslate('en|zu');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Zulu" class="nturl"><img data-gt-lazy-src="//www.linuxcapable.com/wp-content/plugins/gtranslate/flags/32/zu.png" height="32" width="32" alt="zu" /> Zulu</a></div>
</div>
<script>
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta/10);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>


<script>
function doGTranslate(lang_pair) {if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(typeof ga=='function'){ga('send', 'event', 'GTranslate', lang, location.hostname+location.pathname+location.search);}var plang=location.hostname.split('.')[0];if(plang.length !=2 && plang.toLowerCase() != 'zh-cn' && plang.toLowerCase() != 'zh-tw' && plang != 'hmn' && plang != 'haw' && plang != 'ceb')plang='en';location.href=location.protocol+'//'+(lang == 'en' ? '' : lang+'.')+location.hostname.replace('www.', '').replace(RegExp('^' + plang + '[.]'), '')+gt_request_uri;}
</script>
<script>jQuery(document).ready(function() {var lang_html = jQuery(".switcher div.option a[onclick*='|"+jQuery('html').attr('lang')+"']").html();if(typeof lang_html != "undefined")jQuery('.switcher div.selected a').html(lang_html.replace("data-gt-lazy-", ""))});</script></p>
</div></div>
</aside><aside id="ai_widget-26" class="widget inner-padding ai_widget ai-viewport-1"><div class='code-block code-block-11 code-block-block-11' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- sidebar 1 unit -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="6957596951"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</aside><aside id="ai_widget-25" class="widget inner-padding ai_widget"><div class='code-block code-block-13 code-block-block-13' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- side unit 3 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="3756718543"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</aside><aside id="ai_widget-27" class="widget inner-padding ai_widget ai-viewport-1"><div class='code-block code-block-12 code-block-block-12' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- side unit 2 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="6766025260"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<ul>
		<li><a href="https://www.linuxcapable.com/how-to-lxqt-desktop-environment-on-debian-11-bullseye/"><img width="500" height="281" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye.png.webp" class="attachment-500x500 size-500x500 wp-post-image" alt="How to LXQt Desktop Environment on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye.png.webp 2240w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye-300x169.png.webp 300w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye-1024x576.png.webp 1024w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye-768x432.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye-1536x864.png.webp 1536w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-LXQt-on-Debian-11-Bullseye-2048x1152.png.webp 2048w" sizes="(max-width: 500px) 100vw, 500px" /></a></li>
		<li><a href="https://www.linuxcapable.com/how-to-install-mate-desktop-environment-on-debian-11-bullseye/"><img width="500" height="281" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye.png.webp" class="attachment-500x500 size-500x500 wp-post-image" alt="How to Install MATE Desktop Environment on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye.png.webp 2240w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye-300x169.png.webp 300w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye-1024x576.png.webp 1024w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye-768x432.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye-1536x864.png.webp 1536w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-MATE-Desktop-Environment-on-Debian-11-Bullseye-2048x1152.png.webp 2048w" sizes="(max-width: 500px) 100vw, 500px" /></a></li>
		<li><a href="https://www.linuxcapable.com/how-to-install-openjdk-17-on-ubuntu-20-04/"><img width="500" height="281" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa.png.webp" class="attachment-500x500 size-500x500 wp-post-image" alt="How to Install OpenJDK 17 on Ubuntu 20.04" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa.png.webp 2240w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa-300x169.png.webp 300w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa-1024x576.png.webp 1024w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa-768x432.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa-1536x864.png.webp 1536w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-OpenJDK-17-on-Ubuntu-20.04-LTS-Focal-Fossa-2048x1152.png.webp 2048w" sizes="(max-width: 500px) 100vw, 500px" /></a></li>
		<li><a href="https://www.linuxcapable.com/how-to-install-kde-plasma-on-debian-11-bullseye/"><img width="500" height="281" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1.png.webp" class="attachment-500x500 size-500x500 wp-post-image" alt="How to Install KDE Plasma on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1.png.webp 2240w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1-300x169.png.webp 300w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1-1024x576.png.webp 1024w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1-768x432.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1-1536x864.png.webp 1536w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-KDE-Plasma-on-Debian-11-Bullseye-1-2048x1152.png.webp 2048w" sizes="(max-width: 500px) 100vw, 500px" /></a></li>
		<li><a href="https://www.linuxcapable.com/how-to-install-xfce-desktop-on-debian-11-bullseye/"><img width="500" height="281" src="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye.png.webp" class="attachment-500x500 size-500x500 wp-post-image" alt="How to Install Xfce Desktop on Debian 11 Bullseye" srcset="https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye.png.webp 2240w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye-300x169.png.webp 300w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye-1024x576.png.webp 1024w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye-768x432.png.webp 768w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye-1536x864.png.webp 1536w,  https://www.linuxcapable.com/wp-content/webp-express/webp-images/doc-root/wp-content/uploads/2022/01/Install-Xfce-desktop-environment-on-Debian-11-Bullseye-2048x1152.png.webp 2048w" sizes="(max-width: 500px) 100vw, 500px" /></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside><aside id="ai_widget-24" class="widget inner-padding ai_widget"><div class='code-block code-block-14 code-block-block-14' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- side unit 4 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="7504391865"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</aside><aside id="ai_widget-23" class="widget inner-padding ai_widget ai-viewport-1"><div class='code-block code-block-15 code-block-block-15' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- side unit 1 - sticky -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="1015005134"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</aside><aside id="ai_widget-22" class="widget inner-padding ai_widget ai-viewport-1"><div class='code-block code-block-16 code-block-block-16' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- side unit 2 - sticky -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7703471362501005"
     data-ad-slot="8071368077"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</aside>	</div>
</div>

	</div>
</div>


<div class="site-footer footer-bar-active footer-bar-align-center">
			<footer class="site-info" aria-label="Site"  itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container">
						<div class="footer-bar">
			<aside id="nav_menu-1" class="widget inner-padding widget_nav_menu"><div class="menu-footer-bar-marketer-container"><ul id="menu-footer-bar-marketer" class="menu"><li id="menu-item-16598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16598"><a href="https://www.linuxcapable.com/about-linuxcapable/">About LinuxCapable</a></li>
<li id="menu-item-18014" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18014"><a href="https://www.linuxcapable.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-17884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17884"><a href="https://www.linuxcapable.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16926"><a href="https://www.linuxcapable.com/sitemap/">Sitemap</a></li>
<li id="menu-item-16599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16599"><a href="https://www.linuxcapable.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-16597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-16597"><a href="https://www.linuxcapable.com/privacy-policy-statement/">Privacy Policy Statement</a></li>
</ul></div></aside>		</div>
						<div class="copyright-bar">
					&copy; 2022 LinuxCapable all rights reserved.<br>
All logos, trademarks and registered trademarks are the property of their respective owners.<br>
This website is for educational purposes only. No warranty or compensation is given for any loss of data or hardware.				</div>
			</div>
		</footer>
		</div>

<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
    <div class="pswp__bg"></div>
    <div class="pswp__scroll-wrap">
        <div class="pswp__container">
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
        </div>
        <div class="pswp__ui pswp__ui--hidden">
            <div class="pswp__top-bar">
                <div class="pswp__counter"></div>
                <button class="pswp__button pswp__button--close wp-dark-mode-ignore" title="Close (Esc)"></button>
                <button class="pswp__button pswp__button--share wp-dark-mode-ignore" title="Share"></button>
                <button class="pswp__button pswp__button--fs wp-dark-mode-ignore" title="Toggle fullscreen"></button>
                <button class="pswp__button pswp__button--zoom wp-dark-mode-ignore" title="Zoom in/out"></button>
                <div class="pswp__preloader">
                    <div class="pswp__preloader__icn">
                      <div class="pswp__preloader__cut">
                        <div class="pswp__preloader__donut"></div>
                      </div>
                    </div>
                </div>
            </div>
            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
                <div class="pswp__share-tooltip">
                </div> 
            </div>
            <button class="pswp__button pswp__button--arrow--left wp-dark-mode-ignore" title="Previous (arrow left)"></button>
            <button class="pswp__button pswp__button--arrow--right wp-dark-mode-ignore" title="Next (arrow right)"></button>
            <div class="pswp__caption">
                <div class="pswp__caption__center"></div>
            </div>
        </div>
    </div>
</div><script id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script>        <!--[if lte IE 9]>
        <script>
            'use strict';
            (function($) {
                $(document).ready(function() {
                    $('#ftwp-container').addClass('ftwp-ie9');
                });
            })(jQuery);
        </script>
        <![endif]-->
		<script src='https://www.linuxcapable.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=2.1.1' id='generate-sticky-js'></script>
<script id='mkaz-code-syntax-prism-js-js-extra'>
var prism_settings = {"pluginUrl":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/code-syntax-block\/"};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/code-syntax-block/assets/prism/prism.js?ver=1635732604' id='mkaz-code-syntax-prism-js-js'></script>
<script id='copy-the-code-js-extra'>
var copyTheCode = {"copy_content_as":"","previewMarkup":"<h2>Hello World<\/h2>","buttonMarkup":"<button class=\"copy-the-code-button\" title=\"\"><\/button>","buttonSvg":"<svg viewBox=\"-21 0 512 512\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\"><path d=\"m186.667969 416c-49.984375 0-90.667969-40.683594-90.667969-90.667969v-218.664062h-37.332031c-32.363281 0-58.667969 26.300781-58.667969 58.664062v288c0 32.363281 26.304688 58.667969 58.667969 58.667969h266.664062c32.363281 0 58.667969-26.304688 58.667969-58.667969v-37.332031zm0 0\"><\/path><path d=\"m469.332031 58.667969c0-32.40625-26.261719-58.667969-58.664062-58.667969h-224c-32.40625 0-58.667969 26.261719-58.667969 58.667969v266.664062c0 32.40625 26.261719 58.667969 58.667969 58.667969h224c32.402343 0 58.664062-26.261719 58.664062-58.667969zm0 0\"><\/path><\/svg>","selectors":[{"selector":"pre","style":"svg-icon","button_text":"Copy","button_title":"Copy to Clipboard","button_copy_text":"Copied!","button_position":"inside"}],"selector":"pre","settings":{"selector":"pre","button-text":"Copy","button-title":"Copy to Clipboard","button-copy-text":"Copied!","button-position":"inside"},"string":{"title":"Copy to Clipboard","copy":"Copy","copied":"Copied!"},"image-url":"https:\/\/www.linuxcapable.com\/wp-content\/plugins\/copy-the-code\/\/assets\/images\/copy-1.svg"};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/copy-the-code/assets/js/copy-the-code.js?ver=2.2.2' id='copy-the-code-js'></script>
<script id='lbwps-js-extra'>
var lbwpsOptions = {"label_facebook":"Share on Facebook","label_twitter":"Tweet","label_pinterest":"Pin it","label_download":"Download image","label_copyurl":"Copy image URL","share_facebook":"1","share_twitter":"1","share_pinterest":"1","share_download":"1","share_direct":"0","share_copyurl":"1","share_custom_label":"","share_custom_link":"","wheelmode":"close","close_on_drag":"1","history":"1","show_counter":"1","show_fullscreen":"1","show_zoom":"1","show_caption":"1","loop":"1","pinchtoclose":"1","taptotoggle":"1","spacing":"12","close_on_click":"1","fulldesktop":"0","use_alt":"0","desktop_slider":"1","idletime":"4000","hide_scrollbars":"1"};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/lightbox-photoswipe/assets/scripts.js?ver=3.2.10' id='lbwps-js'></script>
<!--[if lte IE 11]>
<script src='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.0' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script src='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.0' id='generate-menu-js'></script>
<script id='generate-navigation-search-js-extra'>
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
</script>
<script src='https://www.linuxcapable.com/wp-content/themes/generatepress/assets/js/navigation-search.min.js?ver=3.1.0' id='generate-navigation-search-js'></script>
<script src='https://www.linuxcapable.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script src='https://www.linuxcapable.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1637923502' id='zoom-social-icons-widget-frontend-js'></script>
<script id='q2w3_fixed_widget-js-extra'>
var q2w3_sidebar_options = [{"sidebar":"sidebar-1","margin_top":10,"margin_bottom":0,"stop_id":"","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["ai_widget-23","ai_widget-22"]}];
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.3.0' id='q2w3_fixed_widget-js'></script>
<script id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://www.linuxcapable.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.38' id='heateor_sss_sharing_js-js'></script>
<script id='fixedtoc-js-js-extra'>
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"1","showColExpIcon":"1","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"3","fixedOffsetY":"0","fixedPosition":"middle-right","contentsFixedHeight":"0","inPost":"1","contentsFloatInPost":"center","contentsWidthInPost":"0","contentsHeightInPost":"","contentsColexpInitMobile":"1","inWidget":"","fixedWidget":"","triggerBorder":"medium","contentsBorder":"medium","triggerSize":"50","isClickableHeader":"","debug":"0","postContentSelector":"#ftwp-postcontent","mobileMaxWidth":"768","disappearPoint":"content-bottom","contentsColexpInit":""};
</script>
<script src='https://www.linuxcapable.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js?ver=3.1.24' id='fixedtoc-js-js'></script>
<script data-cfasync="false" data-no-optimize="1" src='https://www.linuxcapable.com/wp-content/plugins/perfmatters/vendor/instant-page/instantpage.js?ver=1.8.4' id='perfmatters-instant-page-js'></script>

</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using redis 

Served from: www.linuxcapable.com @ 2022-01-05 14:56:17 by W3 Total Cache
-->